LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 02-08-2003, 05:48 PM   #1
illtbagu
Member
 
Registered: Dec 2002
Location: Nevada
Distribution: fedora, RHEL, ubuntu, suse
Posts: 343

Rep: Reputation: 30
moving my hard drive


looking at moving my hard drive from my controller card onto my onboard ide. currently my hard drive has been assigned hde so is the only thing i need to do is change the entry in the lilo config from hde to hda or is there more to it then that. like my etc/fstab file does it also change or will it get updated during boot.

here is my etc/lilo.config file

prompt
timeout="50"
default=linux
boot="/dev/hde"
map=/boot/map
install=/boot/boot.b
message=/boot/message
linear
vga="792"

image="/boot/vmlinuz-2.4.18-14"
label="linux.bak"
initrd="/boot/initrd-2.4.18-14.img"
read-only
append="hdc=ide-scsi root=LABEL=/"

image=/boot/vmlinuz-2.4.18-19.8.0
label=linux.bak1
append="hdc=ide-scsi root=LABEL=/"
read-only
initrd=/boot/initrd-2.4.18-19.8.0.img

image=/boot/vmlinuz-2.4.18-24.8.0
label=linux
append="hdc=ide-scsi root=LABEL=/"
read-only
initrd=/boot/initrd-2.4.18-24.8.0.img



etc/fstab

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hde7 swap swap defaults 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hde2 /mnt/hde2 vfat auto
/dev/hde3 /mnt/hde3 vfat auto
/dev/hde4 /mnt/hde4 vfat auto

/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0


thanks for any advise,
AD
 
Old 02-08-2003, 05:52 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
You need to change both lilo.conf and fstab (won't be changed automatically). Simple replace all hde by hda (and hde1 with hda1 and so on). With the two files changed it will work correctly.
 
Old 02-08-2003, 05:56 PM   #3
illtbagu
Member
 
Registered: Dec 2002
Location: Nevada
Distribution: fedora, RHEL, ubuntu, suse
Posts: 343

Original Poster
Rep: Reputation: 30
thanks here goes nothing. im crossing my fingers!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving Hard Drive Files Zawi Linux - General 10 08-17-2005 12:08 PM
Moving Hard Drive After Install PiscisBos Linux - Software 2 02-14-2005 01:14 AM
Moving Hard drive between PC's the_imax Linux - Hardware 13 11-20-2004 01:55 PM
Moving partitions from one hard drive to another robthebob Linux - Software 2 07-15-2004 05:47 AM
moving to a new hard drive n1wil Linux - Software 4 05-21-2003 03:38 PM


All times are GMT -5. The time now is 10:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration