LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-21-2006, 12:43 AM   #1
stephen_wq
LQ Newbie
 
Registered: Sep 2006
Posts: 12

Rep: Reputation: 0
Locked Out


I certainly know how to make problems that i cant fix. This is the third linux forum i've turned to, as i got no replies on the last one, and the one before was rather inactive. So i hope people here can help me.
I cant start fedora core 5 at all at the moment, it runs through the boot process, enters runlevel 3 and then sits on bringing up eth1, a spare network card which i want to get rid of. So i even tried taking it out, trying to start it again, still sits there, trying to start it, whether the card is even in there, or if there is a network cable in or not. I disabled eth1 before, and would remove it if i could even get in there to take it out completely.
I plugged a cable into which would it start it in init 5, but right now im in init 3, which doesnt just say Failed to start eth1 like 5 does, it just sits there doing nothing, and inittab is set to default 3, as when you type init 3 in root console, it pretty much becomes useless. It stops some things, and sits there doing nothing. So i had to use inittab to get to runlevel 3, to install some drivers.
But now im locked out of fedora essentially, as it wont start.

I know i have to do one of two things:
  • Disable network on boot/disable eth1
  • Edit inittab back to 5 in hope that it will start like it did before, and then trash eth1.

I've tried getting into the hard drive using DSL to modify inittab. mounting the hard drive doesnt work, it never has when ive tried in the past, it says you must specify the filesystem (ext2). So i popped open a terminal and tried to mount it. and it says special device hda2 doesnt exist.
I have no idea.
Im sure that just from having Fedora ive cut a year worth of my life just from stress. But oh well.

Last edited by stephen_wq; 09-21-2006 at 12:45 AM.
 
Old 09-21-2006, 01:17 AM   #2
Nathanael
Member
 
Registered: May 2004
Location: Karlsruhe, Germany
Distribution: debian, gentoo, os x (darwin), ubuntu
Posts: 940

Rep: Reputation: 32
hitting ctrl-c should cancle the init process of any eth card
of course you should not be viewing fedoras bootup splash screen.

you can also check if grub has a 'failsafe' mode for fedora which you could boot with

if /dev/hda2 does not exitst - are you using ide or sata - and which ide-channel / sata channel is it connected to?


i.e.
IDE:
primary master = /dev/hda
primary slave = /dev/hdb
secondary master = /dev/hdc
secondary slave = /dev/hdd

SATA:
primary = /dev/sda
secondary /dev/sdb
 
Old 09-21-2006, 01:23 AM   #3
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
You can use a kernel parameter to boot into a specific run level. This parameter must be last, and consists of the run level number only. Just edit the kernel line in grub and add a 5 to boot into run level 5.
 
Old 09-22-2006, 12:30 AM   #4
stephen_wq
LQ Newbie
 
Registered: Sep 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Adding the 5 worked. But now it doesnt want to start eth1 either.
Ctrl C did nothing.

i'll hunt for failsafe to see if i can somehow stop networking. edit: Cant find it, anyone help in turning off networking?

Im using IDE.
Single drive on master of primary channel. Two partitions, boot and the main one. Boot can be accessed, but the other cant.

Last edited by stephen_wq; 09-22-2006 at 12:36 AM.
 
Old 09-22-2006, 12:34 AM   #5
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Quote:
Single drive on master of primary channel. Two partitions, boot and the main one. Boot can be accessed, but the other cant.
Could you post the output of (as root):
Code:
fdisk -l /dev/hda
 
Old 09-22-2006, 06:51 PM   #6
stephen_wq
LQ Newbie
 
Registered: Sep 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Code:
root@0[knoppix]# fdisk -l /dev/hda

Disk /dev/hda: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          13      104391   83  Linux
/dev/hda2              14       10011    80308935   8e  Linux LVM
Obviously in knoppix, as i cant get into fedora. FS is Ext2, Fedora default install.

Last edited by stephen_wq; 09-22-2006 at 06:55 PM.
 
Old 09-22-2006, 07:37 PM   #7
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
That explains why you can't mount /dev/hda2 - it's an LVM partition.

What are the contents of your /etc/fstab file?
 
Old 09-22-2006, 08:23 PM   #8
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 1,979

Rep: Reputation: 289Reputation: 289Reputation: 289
Quote:
Originally Posted by stephen_wq
i'll hunt for failsafe to see if i can somehow stop networking. edit: Cant find it, anyone help in turning off networking?
There's got to be some kernel boot parameter to accomplish this, but I can't tell you what that would be off hand. I'm guessing it's either hanging on the probe for your NIC, or loading some inappropriate driver and then hanging when that driver goes to initialize your card or something. You might check out the Linux Ethernet HowTo:

http://yolinux.com/HOWTO/Ethernet-HOWTO.html

I think there's something like a "noprobe" boot parameter, but that's probably a bit drastic. That would disable all hardware probing and you'd have to identify your hardware and specify which modules to load manually. Yeuch. I'm not sure if the "noapic" boot parameter would be helpful in your case. I guess it can't get much worse than it is now, so might as well try it if you're desperate.
 
Old 09-23-2006, 01:47 AM   #9
stephen_wq
LQ Newbie
 
Registered: Sep 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by zhangmaike
That explains why you can't mount /dev/hda2 - it's an LVM partition.

What are the contents of your /etc/fstab file?
No idea. Whatever the default Fedora install is, i suppose. I formatted not too long ago.

Tried noapic, did nothing. Noprobe is excessive. I wouldnt know what to do.
edit: Well, after rebooting after noapic, its started. Im in init3 and can get root access.
Now, could anyone give me a command to completely remove eth1?

Last edited by stephen_wq; 09-23-2006 at 07:40 AM.
 
Old 09-23-2006, 02:35 PM   #10
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,060

Rep: Reputation: 295Reputation: 295Reputation: 295
You should be able to remove /etc/sysconfig/network-scripts/ifcfg-eth1 -- you can probably also use system-config-hardware or some such GUI util to do it.
 
Old 09-23-2006, 04:34 PM   #11
stephen_wq
LQ Newbie
 
Registered: Sep 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Oh great, it was working until i removed that file.
It used to say it had a different mac address than expected. Now its sitting there trying to start it again.


But once again, rebooting it after i tried noapic, it fails to start eth1, and ive got terminal access again. Typed init 5 and it started up. Ive removed the network card out of system-config-network and the device too.

Thanks for your help, i still wish i could read it in knoppix though.

Last edited by stephen_wq; 09-23-2006 at 04:42 PM.
 
Old 09-23-2006, 05:18 PM   #12
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 1,979

Rep: Reputation: 289Reputation: 289Reputation: 289
Quote:
Originally Posted by stephen_wq
i still wish i could read it in knoppix though.
The following will work in Knoppix 5 (which includes support for LVM2)
Code:
(1) boot Knoppix
(2) open a terminal window
(3) su to root
(4) run "vgscan"
(5) run "vgchange -a y"
(6) run "pvs; vgs; lvs" to see your LVM stuff.  Note your specific VG and LV names.
(7) run "mkdir /mnt/tmp"
(8) run "mount /dev/vg0/usr /mnt/tmp"
    (adjust the above command based on your specific VG and LV names and the filesystem you want access to)
(9) access your mounted stuff on /mnt/tmp
If you do not have Knoppix 5, and are using older version 4, you will need to install LVM2 manually first (before doing the above). Here's how:
Code:
(1) boot Knoppix
(2) open a terminal window
(3) su to root
(4) modprobe dm-mod
(5) apt-get update
(6) apt-get install lvm-common lvm2
(7) lndir /lib/lvm-200/ /usr/sbin/
(8) procede to step (4) (the "vgscan" step) up in the first listing
 
  


Reply

Tags
help, locked, network


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
seems I locked myself out... adin Linux - Newbie 4 06-24-2006 10:29 PM
locked out kwickcut Mandriva 6 11-14-2005 10:09 PM
Locked out of SU... wiskic10_4 Linux - Newbie 6 12-03-2004 06:49 PM
Locked out downinthemine Mandriva 1 10-28-2003 04:00 PM
Locked out captain_bogus Linux - Newbie 11 08-11-2003 04:32 PM


All times are GMT -5. The time now is 04:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration