LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-08-2005, 01:51 PM   #1
Noido
Member
 
Registered: Apr 2005
Location: Cambridge, UK
Distribution: Slackware 10.2
Posts: 48

Rep: Reputation: 15
Keyboard map


I'd just like to know how to change my keyboard map from the US to UK? i'm running slackware, and i'm very much a newbie

thanks

-Noido
 
Old 06-08-2005, 01:56 PM   #2
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
In X or the console?

For X have a look at /etc/X11/xorg.conf in the keyboard section there is an example line for setting the keyboard map to de, just uncomment that and chage the de to uk, for the console I don't know, have always set it when asked to when first installing the system
 
Old 06-10-2005, 10:49 AM   #3
Noido
Member
 
Registered: Apr 2005
Location: Cambridge, UK
Distribution: Slackware 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
well x but the console would be nice too if there's a way to do that - I'll have a look at what you suggest above though.
 
Old 06-10-2005, 04:48 PM   #4
Noido
Member
 
Registered: Apr 2005
Location: Cambridge, UK
Distribution: Slackware 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
Keyboard map

oh dear. now im stuck in german mode and I cant get out of it. I tried editing it back to defaults but nothing happens. Im very truly stuck.

Last edited by Noido; 06-10-2005 at 05:30 PM.
 
Old 06-10-2005, 05:46 PM   #5
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
well, without knowing what you did, its hard to suggest a solution....

which files did you change/edit? what did you do, exactly.

Last edited by Genesee; 06-10-2005 at 05:48 PM.
 
Old 06-10-2005, 05:56 PM   #6
Noido
Member
 
Registered: Apr 2005
Location: Cambridge, UK
Distribution: Slackware 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
well first I added a line after the comments about changing it to something like this

# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#
# Option "XkbOptions" "ctrl:swapcaps"


# These are the default XKB settings for X.Org
#
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc101"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

Option "XkbLayout" "uk"



but that didnt do anything as far as I could tell so I changed it to de instead and now it wont change back

even if I delete that line and restart KDE (or completely)
 
Old 06-10-2005, 06:40 PM   #7
DaWallace
Member
 
Registered: Feb 2004
Location: Southern Maine, United States
Distribution: Slackware Ubuntu Debian FreeBSD
Posts: 418

Rep: Reputation: 31
you can use loadkeys to change the keymap in the console. you can edit /etc/rc.d/rc.keymap to make it do it at boot.
 
Old 06-12-2005, 01:07 PM   #8
Noido
Member
 
Registered: Apr 2005
Location: Cambridge, UK
Distribution: Slackware 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
Changing it in KDE

but how can I change the map in KDE!!!

Im still stuck in german mode here. its annoying.

please help!!



oh and by the way I cant see that rc.keymap file.

Last edited by Noido; 06-12-2005 at 01:10 PM.
 
Old 06-12-2005, 06:09 PM   #9
DaWallace
Member
 
Registered: Feb 2004
Location: Southern Maine, United States
Distribution: Slackware Ubuntu Debian FreeBSD
Posts: 418

Rep: Reputation: 31
the keyboard layout thing in the control panel..
 
Old 06-13-2005, 03:57 PM   #10
Noido
Member
 
Registered: Apr 2005
Location: Cambridge, UK
Distribution: Slackware 10.2
Posts: 48

Original Poster
Rep: Reputation: 15
yeah I know, but how do you do it from the command line?

- I found that control panel thing after posting that, but if anyone knows how to do it from command line then tell.
 
Old 06-14-2005, 02:41 AM   #11
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Just run xorgconfig and reconfigure X or edit xorg.config and change Option "XkbLayout" "uk" to Option "XkbLayout" "gb". You actually changed your keyboard layout to Ukranian and not British.

Edit:

To load the UK keys by default in the console, edit /etc/rc.d/rc.keymap and change the keymap from us.map to uk.map.

Cheers

Last edited by reddazz; 06-14-2005 at 02:46 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard Map UltraSoul *BSD 1 02-08-2005 11:21 AM
keyboard map logicport Linux - Software 1 07-26-2004 11:45 PM
Trouble on keyboard map SykoMachine Slackware - Installation 9 01-29-2004 04:01 PM
Keyboard map? Gerardoj Linux - Hardware 0 09-29-2003 09:46 PM
Keyboard Map Gerardoj Linux - General 2 08-07-2003 02:57 PM


All times are GMT -5. The time now is 03:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration