LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-28-2002, 02:57 PM   #1
jchim32
LQ Newbie
 
Registered: May 2001
Posts: 4

Rep: Reputation: 0
Unhappy Help with 8.0 install - Anaconda fails


I am attempting to perform a clean install of RH 8.0. This system had RH 7.1 installed previously and was working (X included)without any problems. When I attempt to install 8.0 the problems occur regardless of the install type (Personal Desktop, Workstation, Server, Custom). When I do a text based install and select the defaults for server install, it installs fine (but it has to be the defaults. Whenever I make any custom selections, it crashes there too). The installation starts through X, I select to remove all partitions on disk and I let the installation configure the partitions automatically. I am able to get all the way to when it starts to install the packages and it crashes telling me an unhandled exception had occured.

It reads something like this:
Exception Occurred
An unhandled exception had occurred. This is most likely a bug.
Please copy the fill text of this exception or dave the crash dump
to a floppy then file a detailed bug report against anaconda at
http://bugzilla.redhat.com/bugzilla

Traceback(most recent call last)

File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
self.currentWindo.renderCallback ()
FIle "/usr/lib/anaconda/iw/progress.gui", line 149 in renderCallback
self.intf.icw.nextClicked ()
FIle "/usr/lib/anaconda/gui.py", line 632 in nextClicked
self.dispatch.gotoNext ()
File "/usr/lib/anaconda/dispatch.py". line 150 gotoNext
self.moveStep ()
File "/usr/lib/anaconda/dispatch.py", line 215 in moveStep
rc=apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 430 in TurnOnFilesystems
Partitions.doMetaDeletes (diskset)
File "/usr/lib/anaconda/partitions.py", line 1110 in doMetaDeletes
lvm.vgactivate ()
File "/usr/lib/anaconda/lvm.py", line 54 in vgactivate
SearchPaths ()
File "/usr/lib/anaconda/iutil.py", line 66 in execWithRedirect
childpid=os.fork ()
OSError: [Errno 12] Cannot allocate Memory

If anyone can help with this I would be GRATEFUL!!!!!

Thanks,

Jeff
 
Old 11-28-2002, 09:10 PM   #2
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
RHL 8.0 demands more sys resources even in text mode (minimum mem is 32 M!). What's the spec of your machine?
 
Old 11-30-2002, 03:25 PM   #3
jchim32
LQ Newbie
 
Registered: May 2001
Posts: 4

Original Poster
Rep: Reputation: 0
I found that I need 64MB+ to install and run X. I was using 48MB which worked for RH 7.1. I have installed more memory and since installed RH 8. Pretty sweet so far except there is a little more to configuring Samba on 8 than 7.1.
 
Old 01-08-2003, 10:23 PM   #4
lifeisahighway
LQ Newbie
 
Registered: Jan 2003
Distribution: RedHat 8
Posts: 2

Rep: Reputation: 0
Same Problem, More memory than above

I am having the same problem with Anaconda crashing and displaying an unhandled exception error upon installation. This occurs before the end of the first disk, regardless of packages chosen. My system spec's are below:

AMD Athlon XP1800
512MB DDR 2100
4 HD's 1x80gb 1x30gb 1x40gb 1x20gb
Acer 10x8x32x CD-R
Creative 4x Burner
Creative 24x CDRom* I have tried disconnecting all but this cd drive

I have the exact same error message as below. I have tried 6 different copies (downloaded ISO's from different locations) as well as store bought cd's, in any of the drives. I have even loaded the images on to a local FTP server and receive the same error.

I can send the crash dump if it is of any use to anyone, it says nothing about the error, the crash occurs when installing the last package. I have used the same CD's to install the RPM on another machine and it works fine, so the RPM must be good.

Thanks,

Mark


Last two packages:
Installing xinetd-2.3.7-2.
Installing zlib-1.1.4-4.
 
Old 01-24-2003, 06:15 PM   #5
Viper_iii
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
Re: Same Problem, More memory than above

Ditto on that.. I'm running an Asus P3B-F

P-III 550c
256Mb SDram
Millenium G550
Maybe some other crap...

But always on disc two.. I can't get past a few bad packages.. no matter where I get the ISO or what kind of Burner I use or what speed I burn at..

Now I'm on a minimum install .. and I don't know the first thing to do to get KDE/GNOME/X windows installed.. and running...

Any help or links to help would be great!!!..

Thx



Quote:
Originally posted by lifeisahighway
I am having the same problem with Anaconda crashing and displaying an unhandled exception error upon installation. This occurs before the end of the first disk, regardless of packages chosen. My system spec's are below:

AMD Athlon XP1800
512MB DDR 2100
4 HD's 1x80gb 1x30gb 1x40gb 1x20gb
Acer 10x8x32x CD-R
Creative 4x Burner
Creative 24x CDRom* I have tried disconnecting all but this cd drive

I have the exact same error message as below. I have tried 6 different copies (downloaded ISO's from different locations) as well as store bought cd's, in any of the drives. I have even loaded the images on to a local FTP server and receive the same error.

I can send the crash dump if it is of any use to anyone, it says nothing about the error, the crash occurs when installing the last package. I have used the same CD's to install the RPM on another machine and it works fine, so the RPM must be good.

Thanks,

Mark


Last two packages:
Installing xinetd-2.3.7-2.
Installing zlib-1.1.4-4.
 
Old 01-24-2003, 08:30 PM   #6
lifeisahighway
LQ Newbie
 
Registered: Jan 2003
Distribution: RedHat 8
Posts: 2

Rep: Reputation: 0
Viper try this

Viper, I was able to get mine to install by simple selecting the option to "select individual packages" and de-selecting the package that gave me the errors. After install which went seamlessly. I installed the rpm using "rpm -Uvh" for that package. everything seems to work wonderfully. Let me know if this helps.

~Mark
 
Old 01-25-2003, 02:53 PM   #7
Viper_iii
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
Kool Thx

I was having mulitple packages errors but the most common one seemed to be x-windows screen saver... I'll select away from that one... and see if I can get it running...

Right now its up.. but with only a minimal install options. And Unfortuantly I'm too much a beginner to start installing KDE and other packages from CLI.

.......

Unless... I can use the rpm -Uvh I'll give the CLI a try first.. then go for re-install...

Thx
 
Old 05-26-2003, 10:48 AM   #8
srini
LQ Newbie
 
Registered: Mar 2003
Location: India
Posts: 6

Rep: Reputation: 0
Angry Re: Help with 8.0 install - Anaconda fails

hi,
I am also faced same problem and any one can throw lite on the same.
Thanks
Srinivas Anupindi
srinivas_a@integramicro.com


Quote:
Originally posted by jchim32
I am attempting to perform a clean install of RH 8.0. This system had RH 7.1 installed previously and was working (X included)without any problems. When I attempt to install 8.0 the problems occur regardless of the install type (Personal Desktop, Workstation, Server, Custom). When I do a text based install and select the defaults for server install, it installs fine (but it has to be the defaults. Whenever I make any custom selections, it crashes there too). The installation starts through X, I select to remove all partitions on disk and I let the installation configure the partitions automatically. I am able to get all the way to when it starts to install the packages and it crashes telling me an unhandled exception had occured.

It reads something like this:
Exception Occurred
An unhandled exception had occurred. This is most likely a bug.
Please copy the fill text of this exception or dave the crash dump
to a floppy then file a detailed bug report against anaconda at
http://bugzilla.redhat.com/bugzilla

Traceback(most recent call last)

File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
self.currentWindo.renderCallback ()
FIle "/usr/lib/anaconda/iw/progress.gui", line 149 in renderCallback
self.intf.icw.nextClicked ()
FIle "/usr/lib/anaconda/gui.py", line 632 in nextClicked
self.dispatch.gotoNext ()
File "/usr/lib/anaconda/dispatch.py". line 150 gotoNext
self.moveStep ()
File "/usr/lib/anaconda/dispatch.py", line 215 in moveStep
rc=apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 430 in TurnOnFilesystems
Partitions.doMetaDeletes (diskset)
File "/usr/lib/anaconda/partitions.py", line 1110 in doMetaDeletes
lvm.vgactivate ()
File "/usr/lib/anaconda/lvm.py", line 54 in vgactivate
SearchPaths ()
File "/usr/lib/anaconda/iutil.py", line 66 in execWithRedirect
childpid=os.fork ()
OSError: [Errno 12] Cannot allocate Memory

If anyone can help with this I would be GRATEFUL!!!!!

Thanks,

Jeff
 
Old 05-26-2003, 10:58 AM   #9
srini
LQ Newbie
 
Registered: Mar 2003
Location: India
Posts: 6

Rep: Reputation: 0
Unhappy OSError: [Errno 12] Cannot allocate memory

Still I have problem in installing in GUI mode for the following configuration. What need to be done on this?

PIII 650 MHz
64MB RAM
seagate 20GB IDE hard disk
pioneer DVD ROM(106sz)

Regards,
Srinivas
 
Old 05-26-2003, 11:35 AM   #10
srini
LQ Newbie
 
Registered: Mar 2003
Location: India
Posts: 6

Rep: Reputation: 0
Redhat 8 Install out of memory?

hi,
redhat recommends the following for RH-Linux8.0

memory:
minimum for text mode:64 MB
minimum for GUI mode:128MB
(recommended for graphical is :192MB)

I have tried with 128MB GUI interface , its working fine and i have to try with 64MB for text mode also.

regards
srinivas anupindi
srinivas_a@integramicro.com
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anaconda doesn't recognize the CDROM in FC2 install Anaxamemnon Fedora - Installation 17 05-07-2005 03:21 PM
anaconda build from src rpm fails LampMan Fedora 3 03-28-2005 02:55 AM
fedora 3 anaconda freezing during install on IBM ServeRaid jacko0 Linux - Software 1 03-10-2005 06:56 PM
install debian using anaconda abd_bela Debian 6 05-13-2004 07:24 AM
Redhat 7.1 Install, Anaconda Error? smoshea Linux - General 2 01-16-2003 07:54 AM


All times are GMT -5. The time now is 08:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration