LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-06-2010, 04:19 AM   #1
marguelles
LQ Newbie
 
Registered: Sep 2008
Location: Argentina
Distribution: At home Debian 5.04 64bit // At work RHEL 5.4 - SLES 10
Posts: 9

Rep: Reputation: 0
Talking Halt breaks WOL


Hi guys,

I can't do a wake on lan after 'poweroff' my Debian Lenny system.

For example, if I shutdown the machine holding the power button, pulling the power cord or cutting the power with the power supply switch, then I can send a "Magic Packet" to turn it on again. But, when I do a clean shutdown like "shutdown -h now", then the nic doesn't take any action when receiving the signal.

Any ideas ?

Thanks in advance.

Last edited by marguelles; 06-08-2010 at 06:52 AM. Reason: SOLVED
 
Old 06-07-2010, 04:12 AM   #2
induswebii@gmail.com
LQ Newbie
 
Registered: Jun 2010
Posts: 1

Rep: Reputation: 0
We often take a review of that type of the reply.
 
Old 06-07-2010, 04:20 AM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Look in your power saver features. There is the "ethtool wol g" command which will enable waking on magic packets. There is also "ethtool wol d" to disable wake on lan. Your system may be executing the latter command.
 
1 members found this post helpful.
Old 06-08-2010, 06:51 AM   #4
marguelles
LQ Newbie
 
Registered: Sep 2008
Location: Argentina
Distribution: At home Debian 5.04 64bit // At work RHEL 5.4 - SLES 10
Posts: 9

Original Poster
Rep: Reputation: 0
Lightbulb

Thanks for the path jschiwal!

I've just set the WOL feature to be enabled in every boot by adding the following command in /etc/rc.local before "exit 0":
Code:
ethtool -s ethX wol g
Regards,

Quote:
Originally Posted by jschiwal View Post
Look in your power saver features. There is the "ethtool wol g" command which will enable waking on magic packets. There is also "ethtool wol d" to disable wake on lan. Your system may be executing the latter command.
 
  


Reply

Tags
debian, magic, packet, wol


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WOL Question carlosinfl Linux - Networking 1 05-17-2007 09:34 PM
Has anyone succeded WOL ? SUBARU Linux - Wireless Networking 2 06-12-2006 11:12 PM
After halt WOL feature also shuts down:( Sushy Linux - Networking 1 10-31-2005 08:18 AM
WOL help. pete1234 Linux - Networking 5 07-30-2005 09:49 PM
Wol hakcenter Linux - Networking 5 10-07-2003 01:43 PM


All times are GMT -5. The time now is 06:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration