LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-28-2005, 12:50 AM   #1
pete1234
Member
 
Registered: May 2005
Distribution: Slack, FreeBSD,NetBSD, OpenBSD, Open Solaris, Minix
Posts: 172

Rep: Reputation: 30
WOL help.


Okay, I'm currently trying to setup WOL. The machine I'm trying to wake up is running gentoo, and kernel version 2.6.12.3. For some reason the machine refuses to be woken up. I enabled WOL in my BIOS settings, but that seemed to do nothing. "Ethtool eth0" gives this output:

Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 24
Transceiver: internal
Auto-negotiation: on
Current message level: 0x00000001 (1)
Link detected: yes

When I try to enable wol via "ethtool -s eth0 wol g" I get this output:
Cannot get current wake-on-lan settings: Operation not supported
not setting wol

I've also tried enabling WOL by passing the argument at boot time via:
"append = "enable enable_wol=1" added to /etc/lilo.conf However this achieved nothing.

The ethernet card on the machine I wish to WOL is a 3Com 3c905B 100BaseTX [Cyclone] which is built in to my motherboard. lspci -v gives this output about the card:

0000:00:11.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 24)
Subsystem: Dell 3C905B Fast Etherlink XL 10/100
Flags: bus master, medium devsel, latency 64, IRQ 11
I/O ports at dc00 [size=fb000000]
Memory at ff000000 (32-bit, non-prefetchable) [size=128]
Expansion ROM at 00020000 [disabled]
Capabilities: [dc] Power Management version 1

I'm fairly certain I'm shutting down properly, and the machine I wish to wake up is not down. After a "shutdown -h -t 0 now" on the machine I wish to WOL I still mantain a sold green light where the ethernet port is, and also there is a solid green light visable on the motherboard. arp -a run from the machine I send the magic packets from gives this ouput:

? (192.168.0.2) at 00:B0:D0:25:72:87 [ether] on ra0

ra0 being the wireless interface on my laptop (the machine I send the magic packets from).

I'm stumped, and tired. Any help is appreciated.
 
Old 07-28-2005, 06:05 PM   #2
pete1234
Member
 
Registered: May 2005
Distribution: Slack, FreeBSD,NetBSD, OpenBSD, Open Solaris, Minix
Posts: 172

Original Poster
Rep: Reputation: 30
Today while at work I thought that maybe my router was somehow dropping the WOL packets, or otherwise screwing things up. However, I fired up tethereal, and found out that the packets are being send to Dest. port 9. I appended my router to allow this, and sent out some magic packets. It had a result, but not the desired one. tethereal showed that tha packets sent through the router and were sent to the correct machine. Though the machine failed to start up. Though it did produce a change in the output from arp :

Address HWtype HWaddress Flags Mask Iface
192.168.0.2 ether (incomplete) C ra0

Again any help or insight is appreciated.
 
Old 07-28-2005, 06:58 PM   #3
pete1234
Member
 
Registered: May 2005
Distribution: Slack, FreeBSD,NetBSD, OpenBSD, Open Solaris, Minix
Posts: 172

Original Poster
Rep: Reputation: 30
Okay, now this gets really strange. I got WOL to work by disabling ACPI in my bios settings. However, now I can wake up remotely, but I can't shutdown remotely. Does anyone have any idea how to solve this problem? I tried leaving ACPI diabled in my bios settings, and adding acpi=force to /etc/lilo.conf, but this still does not let me power down remotely.
 
Old 07-28-2005, 07:33 PM   #4
pete1234
Member
 
Registered: May 2005
Distribution: Slack, FreeBSD,NetBSD, OpenBSD, Open Solaris, Minix
Posts: 172

Original Poster
Rep: Reputation: 30
Okay. I solved my own damn problem. I just ditched acpi (still no idea why it conflicted with wol). I went with apm. Recompiled with apm support enabled passed apm=on and apm=power-off to the kernel, and bam. Figured I'd share for the hell of it incase anyone else has/had the same issue.
 
Old 07-28-2005, 10:55 PM   #5
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
I just wanted to say thank you for posting your solution and detailed descriptions of the problem, even though none of us here were able to help you.
 
Old 07-30-2005, 09:49 PM   #6
pete1234
Member
 
Registered: May 2005
Distribution: Slack, FreeBSD,NetBSD, OpenBSD, Open Solaris, Minix
Posts: 172

Original Poster
Rep: Reputation: 30
Just glad to help out where I can.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WOL with sk98lin driver Sushy Slackware 5 12-11-2005 05:52 AM
WOL - 3c905B not booting andguent Linux - Networking 5 02-15-2005 09:47 AM
Server WOL and standby ATrx2k Linux - Networking 1 04-25-2004 10:23 AM
Server WOL and standby ATrx2k Linux - Software 0 04-24-2004 05:28 PM
Wol hakcenter Linux - Networking 5 10-07-2003 01:43 PM


All times are GMT -5. The time now is 05:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration