LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-03-2004, 11:27 AM   #1
triona
LQ Newbie
 
Registered: Nov 2004
Posts: 18

Rep: Reputation: 0
Gumstix usbnet problems..."modprobe" command unrecognised


Hi,
Does anyone know why the modprobe command wouldn't be recognised when trying to make a usb connection to the gumstix from the host.

>modprobe usbnet
or
>/sbin/modprobe usbnet

gives error saying modprobe not recognised, and yet you can "man" the command.
I'm connected over minicom via the serial cable, which is suspended in the background, and logged in as root in both...

I'd really appreciate any info.
Thanks,
Triona
 
Old 11-03-2004, 12:57 PM   #2
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
is modutils installed ?
 
Old 11-04-2004, 03:42 AM   #3
triona
LQ Newbie
 
Registered: Nov 2004
Posts: 18

Original Poster
Rep: Reputation: 0
modutils...

When you "ls -l" /sbin you get a list including modprobe -> insmod etc., so I think it is installed yes.
 
Old 11-04-2004, 10:09 AM   #4
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
so there IS a program in your PATH variable called modprobe.... but if you try to run it, bash says the command doesnt exist !!??

i dont understand how this could happen.

after atteempting a modprobe, run the command "dmesg" this is the kernel output, see if it says anying about attempting to load the driver.

is this an "out of the Box" install ?

all i can think is maybe you are using a distro meant for a 2.4 kernel, and you have installed a 2.6 kernel without updating to a 2.6 compatable modultils package. (modutils controlls loading and unleading of kernel modules)

please post as much info you know about your distribution...

(and run "uname -a" this should print out your kenrle version)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
commands "init" and "modprobe" not working Diagmato Fedora 2 07-22-2005 11:44 PM
My system freezes after I issue the "modprobe ndiswrapper" command. markjc Linux - Wireless Networking 1 08-24-2004 09:47 AM
connecting using usbnet to gumstix linux device squeaks Linux - Networking 0 07-28-2004 12:01 PM
"depmod" and "modprobe" commands don't work The1PatO Fedora 7 06-10-2004 12:10 PM
"modprobe usbkbd" command cann't be executed! lucklemon Linux - Hardware 1 05-21-2004 08:43 AM


All times are GMT -5. The time now is 01:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration