LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-10-2002, 05:02 AM   #1
mchao
LQ Newbie
 
Registered: Feb 2002
Location: Los Angeles
Distribution: Red Hat
Posts: 17

Rep: Reputation: 0
Unhappy gtk-config script cannot be found - Help Me Pls.


I'm new to Linux. I'm using Red Hat 7.2. I 'm tryiing to compile a program called Gnewtellium and when I run ./configure I get the following error message:

*** Could not run GTK test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK was incorrectly installed
*** or that you have moved GTK since it was installed. In the latter case, you
*** may want to edit the gtk-config script: /usr/local/bin/
configure: error: Cannot find GTK: Is gtk-config in path?

I ran a find / -name "gtk-config" and came up with nothing. I also ran a locate gtk-config and that also gave me nothing. I installed gtk+-1.2.9-4.i386.rpm and it appeared successful - no warnings. So if that has been installed wherein the world is gtk-config??? and if it exists can you please teach me how to change the $PATH variable in /etc/profile ?

Thank you so much. I'm thoroughly frustrated.

Mike.
 
Old 02-10-2002, 11:46 AM   #2
therion12
Member
 
Registered: Dec 2001
Location: chicago, IL
Distribution: Gentoo 1.4_rc1
Posts: 913

Rep: Reputation: 30
Same here but with SuSE 7.3
 
Old 02-10-2002, 01:31 PM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,406

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
mchao, look at the link below. hope it helps. thanks.

therion, you really just don't even bother trying do you? i already TOLD you the solution once before.

http://www.linuxquestions.org/questi...ight=gtkconfig

and if it's not just that you've not got it installed, then ir'll be a path iissue. therion, for someone who thinks they are so informed abuot un*x you really don't show it....
 
Old 02-10-2002, 03:52 PM   #4
therion12
Member
 
Registered: Dec 2001
Location: chicago, IL
Distribution: Gentoo 1.4_rc1
Posts: 913

Rep: Reputation: 30
No, that solution didnt work this time. I just put MDK 8.1 back on and i'm golden now.
 
Old 02-10-2002, 06:17 PM   #5
mchao
LQ Newbie
 
Registered: Feb 2002
Location: Los Angeles
Distribution: Red Hat
Posts: 17

Original Poster
Rep: Reputation: 0
Unhappy found gtk-config but how do I set $PATH need help with 'exact' syntax

Hello, people. I found gtk-config -- it's in /usr/bin

Now, how do I set the path in /etc/profiles

Can you tell me how I set $PATH.

I tried, but it still gave me the error when I tried to compile.

Please help. Thanks so much.

Mike =D
 
Old 02-10-2002, 06:22 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,406

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
wisconsin's a party place

if it's /usr/bin you really hould be able to use it fine.. that's a bit odd. check what your path is at the moment...

echo $PATH

you can alter it by editing /etc/rc.local, adding a line like...

export PATH=$PATH:/new/place/for/path/

alternatively, you should be able to define exactly where the program for configure...

./configure --with-gtk-prefix=/usr/bin

hmm.. think that's right...

Last edited by acid_kewpie; 02-10-2002 at 06:25 PM.
 
Old 02-10-2002, 06:25 PM   #7
mchao
LQ Newbie
 
Registered: Feb 2002
Location: Los Angeles
Distribution: Red Hat
Posts: 17

Original Poster
Rep: Reputation: 0
Question setting path when configuring

Can I set the path to gtk-config when using ./configure.

something like: ./configure --path=/usr/bin/gtk-config ?

I know I'm probably way off. Just a side question. I've seen this flag many times --prefix=foobar OR --path=foobar

Please help the newbie.

Mike =D
 
Old 02-10-2002, 06:26 PM   #8
mchao
LQ Newbie
 
Registered: Feb 2002
Location: Los Angeles
Distribution: Red Hat
Posts: 17

Original Poster
Rep: Reputation: 0
So my question is what are these flags for: --prefix=foobar OR --path=foobar

Oh, and thanks to all who helped me. I'm going to go with all the information you guys provided me and see what happens.

Mike
 
Old 02-10-2002, 06:42 PM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,406

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
so many hills until the river

arrggghhh no foobars!!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gtk-config and glib-config scripts not found? Frustin Linux - General 17 12-26-2008 02:14 PM
i can't find gtk-config script pipebkn Linux - Software 3 03-29-2005 06:52 AM
gtk-config was not found in your $PATH eerf Debian 1 01-19-2005 03:47 AM
[Debian]gtk-config was not found in your $PATH eerf Linux - Security 1 01-18-2005 09:26 PM
pls pls pls help me ! i'm tired with httpd config on fedora apache 2.0.48 AngelOfTheDamn Fedora 0 01-24-2004 05:12 PM


All times are GMT -5. The time now is 12:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration