LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-31-2003, 09:48 PM   #1
zzzt
LQ Newbie
 
Registered: Oct 2003
Location: Kansas City
Distribution: Mandrake 9.2
Posts: 26

Rep: Reputation: 15
CTRL-ALT-Backspace won't kill X.


... Well, it kills X, but restarts it. Is there any way to kill X? I've been shutting down, pressing 'I' during the reboot for Interactive Startup, and then choosing not to start x. There has to be a better way. I know that ctrl-alt-backspace is supposed to kill x, so does anyone know how to keep it dead?
 
Old 12-31-2003, 10:20 PM   #2
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Rep: Reputation: 46
I dont know for sure if this will work but have you tried " kill PID " from a console?
 
Old 12-31-2003, 10:35 PM   #3
contrasutra
Guru
 
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Rep: Reputation: 46
You can boot into init level 3. Then you can start X manually, and not have a Display Manager "catch" it and keep restarting it.

Open your /etc/inittab file, and look for:

id:5:initdefault:

Change the 5 to a 3, and reboot.

That will boot you into text mode.

You could also edit your Display Managers config file, to turn off auto-respawning.
 
1 members found this post helpful.
Old 01-08-2004, 06:57 PM   #4
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
If you only want to shut it down from time to time, you can run (as root) "init 3"

However even in runlevel 5 you probably have some console shells: try alt+ctrl+f1-f6

Note: "init 1" will go down to single user mode. Useful for system mantainence/upgrades

Last edited by ac1980; 01-08-2004 at 06:59 PM.
 
Old 01-08-2004, 08:39 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,965
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
The "restarting" is done by kdm, gdm or xdm.

skill -9 either of those and X will die with them
(except for in some versions FatRat, errh, RedHat,
no idea how it's retarded, errrh, restarted there).


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl+alt+backspace marsques Linux - Newbie 2 02-04-2009 01:05 PM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
ctrl-alt-backspace does a hard kill on comp peeples Linux - Hardware 1 03-07-2004 09:17 AM
Cannot use Ctrl+Alt+Backspace to kill X tmorton Linux - Laptop and Netbook 3 11-11-2003 06:25 PM
Can't kill X with ctrl+alt+backspace anymore! Mega Man X Linux - General 2 07-25-2003 03:11 PM


All times are GMT -5. The time now is 04:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration