LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 07-25-2003, 01:43 PM   #1
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Angry Can't kill X with ctrl+alt+backspace anymore!


Hi!!!

I'm having some problems here with Slackware 9.0 and Gnome. I simply cannot use anymore some functions keys under X such as ctrl+alt+backspace or ctrl+alt+Fkeys.

This is quite dangerous, because if something goes wrong, I've to reestart the computer in the button. Ctrl+alt+del won't work either.

I've been doing somethings too. I've changed the keyboard layout to swedish and compiled mplayer (I don't think mplayer is the problem, but so you know I've not done much with this box). I've also edited my xf86config to get mouse wheel support adding "ZAxisMapping" "4 5" and Protocol "IPMS/2". Pretty much default stuff to get things working. Nothing more, nothing less. I've already tried to delete gnome files in my /home directory to see if it was a nautilus issue. I'm pretty new to Slackware, so I'm a bit lost too...

Added this later:

More info... I can use those keys for few moments under X, but they stop working after a while. Is it me who sucks at Linux or is Slack this naughty.. lol

Any ideas or suggestions?

Thanks in advance

Last edited by Mega Man X; 07-25-2003 at 01:51 PM.
 
Old 07-25-2003, 02:38 PM   #2
idor
LQ Newbie
 
Registered: Jul 2003
Location: Houston
Distribution: RedHat, mandrake
Posts: 3

Rep: Reputation: 0
Hello megaman,
You may wanna try this. in your /etc/X11/XF86config or XF86config-4, under section "ServerFlags" there is an entry called DontZap just comment out that and you should have your ctrl-alt-backspace working. As for your ctrl-alt-Fkeys, there is something to add in that section to enable also... but i cannot remember but someone may remember. Also, check your /etc/inittab to make sure that your console is enabled. that is usually in the bottom of the file with some like

1:........:/sbin/mingetty tty1
....
...

let me know if this works.
 
Old 07-25-2003, 03:11 PM   #3
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Original Poster
Rep: Reputation: 63
Hi idor!!!

Thanks a lot for the help and welcome to Linux Questions my friend. I think there's a little bug in a gnome application. I use a keyboard with swedish layout. To enable it under gnome, the only way I've found so far is clicking in the panel, then >> add to panel >> utility >> keyboard layout switch.

As long as this is on into my panel, it won't let me use those keys. If I remove it, then everything is normal again. Hmmmm... the problem is, if I remove that, my keyboard layout turns again into gnome's default. Wonder if we can set as swedish layout without that application.

Anyway, I'm on Redhat 9.0 now in another machine. As soon as I boot the other box into Slackware 9.0 I will try right away and post here. Thanks a lot once again for the tips .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
ctrl-alt-backspace does a hard kill on comp peeples Linux - Hardware 1 03-07-2004 09:17 AM
CTRL-ALT-Backspace won't kill X. zzzt Linux - General 4 01-08-2004 08:39 PM
Cannot use Ctrl+Alt+Backspace to kill X tmorton Linux - Laptop and Netbook 3 11-11-2003 06:25 PM
Ctrl+Alt+Backspace Socka Linux - Newbie 8 05-18-2003 07:18 AM


All times are GMT -5. The time now is 11:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration