LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-06-2008, 09:01 PM   #1
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Rep: Reputation: 83
ALSA, How to turn capture volume bar on?


Hya,

Problem is, microphone is not working.

Hardware is
Debian etch, on Toshiba laptop Satellite. Card is Intel 82801CA-ICH3 Chip is Yamaha YM753.

Software is Skype
Speakers are working, but not microphone.

Several threads suggest to adjust "Capture volume" using alsamixer. However, it is turned off and I do not know how to make it active. I think I have all necessary kernel modules compiled and loaded (lsmod output follows.) One point I am not sure is snd-ymfpci module. Documents in kernel source says it is for YMF75x, while config option page days Yamaha YMF724/740/744/754 (NO 753!!).

Does anybody know?

Happy Penguins!
Code:
wlan_tkip              11392  2 
cisco_ipsec           554268  0 
nfs                   204876  0 
lockd                  52744  1 nfs
sunrpc                127932  3 nfs,lockd
ipv6                  219232  12 
e100                   30856  0 
wlan_scan_sta          11264  1 
ath_rate_sample        12544  1 
ath_pci                86560  0 
wlan                  190020  5 wlan_tkip,wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal               189648  3 ath_rate_sample,ath_pci
pcmcia                 23564  0 
firmware_class          7296  1 pcmcia
snd_usb_audio          74464  0 
snd_usb_lib            14592  1 snd_usb_audio
yenta_socket           23564  3 
rsrc_nonstatic          9216  1 yenta_socket
pcmcia_core            33812  3 pcmcia,yenta_socket,rsrc_nonstatic
nvidia               3922060  12 
gspca                 671952  0 
snd_intel8x0           28060  1 
snd_ac97_codec         89632  1 snd_intel8x0
snd_ac97_bus            2048  1 snd_ac97_codec
snd_rawmidi            19744  1 snd_usb_lib
snd_seq_device          6796  1 snd_rawmidi
videodev               22400  1 gspca
v4l1_compat            14212  1 videodev
v4l2_common            21248  1 videodev
snd_hwdep               7172  1 snd_usb_audio
snd_pcm                71048  3 snd_usb_audio,snd_intel8x0,snd_ac97_codec
snd_timer              19332  1 snd_pcm
snd                    46564  11 snd_usb_audio,snd_usb_lib,snd_intel8x0,snd_ac97_codec,snd_rawmidi,snd_seq_device,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc          8200  2 snd_intel8x0,snd_pcm
pcspkr                  2432  0 
intel_agp              21532  1 
agpgart                25648  2 nvidia,intel_agp
shpchp                 33052  0 
pci_hotplug            12552  1 shpchp
uhci_hcd               26764  0
http://www.linuxquestions.org/questi...ophone-635428/
http://www.linuxquestions.org/questi...igured-644479/
http://www.linuxquestions.org/questi....04-rc-637134/
The last one is a kind of discouraging.
 
Old 09-07-2008, 12:33 AM   #2
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,054

Rep: Reputation: 83
using alsamixer use your arrow keys to go to mic and press the m key. It will change from MM to OO then use the up and down arrow keys to adjust the volume. Just tested and this is what I used to turn the mic on and off on my etch system.
 
Old 09-07-2008, 09:20 AM   #3
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Original Poster
Rep: Reputation: 83
Hya,

Thanks for your reply. Yes, M (or m) works for many other controls, but not for capture. Space bar looks to select, however, microphone does not work....

Happy Penguins!
 
Old 09-07-2008, 02:50 PM   #4
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
You can press tab to see the capture sliders within alsamixer.
 
Old 09-08-2008, 06:00 AM   #5
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,436

Original Poster
Rep: Reputation: 83
Hya,

Thank you for your reply. Yes, however, tab key works to change Playback -> Capture -> All -> .... (functionally, same as Func keys).

For some reason, I reinstalled libasound2 package using aptitude, which solved partially my problem. A little bit more to go. I will post as soon as I sort things out.

Happy Penguins!
 
  


Reply

Tags
alsa, capture, volume


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Turn your launch bar into eye candy with wbar LXer Syndicated Linux News 0 03-21-2008 09:20 AM
Volume Control: Intel 82801DB-ICH4 (Alsa mixer) won't save volume levels. cayspekko Linux - Newbie 2 01-31-2008 12:17 AM
VLC Volume Bar in 10.3 swampdog2002 Suse/Novell 9 11-15-2007 12:07 PM
Turn off autocomplete in URL bar of Epiphany? General Linux - Software 0 05-02-2007 07:18 PM
KDE tool bar volume Surfmonkey Fedora 2 03-17-2004 11:01 PM


All times are GMT -5. The time now is 04:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration