LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
LinkBack Search this Thread
Old 02-12-2006, 06:56 PM   #1
gregben
LQ Newbie
 
Registered: Feb 2006
Location: San Diego, CA
Posts: 7

Rep: Reputation: 0
LFS livecd 6.1.1-3 eth0 setup (static ipv4)


Booted livecd 6.1.1-3 OK. Trying to set up eth0.
This is an ASUS mobo with Marvell Yukon ethernet chip.

I was able to manually 'modprobe sk98lin' to get the eth0 interface running.

I'm confused about properly setting up everything in /etc/*.
I followed chapter 7.12 in the stable book (online version).
Here's what my /etc/sysconf/network-devices/ifconfig.eth0/ipv4 looks like:
ONBOOT=yes
SERVICE=ipv4-static
IP=192.168.1.28
GATEWAY=192.168.1.1
PREFIX=24
BROADCAST=192.168.1.255

I set up /etc/hosts and /etc/resolv.conf too.

I get the following error when I run /etc/rc.d/init.d/network start:

/etc/rc.d/init.d/network: line 40: .: /etc/sysconfig/network-devices/ifconfig.eth0: is a directory

So, /etc/rc.d/init.d/network expects ifconfig.eth0 to be a file, not a directory. It appears
the LiveCD is somehow organized differently than the book. I couldn't find any LiveCD
specific docs on the linuxfromscratch.org site or via google. Perhaps there are docs
on the CD itself on proper setup procedure?
 
Old 02-14-2006, 07:20 AM   #2
ebonhand
LQ Newbie
 
Registered: Jan 2006
Location: Australia
Distribution: Linux From Scratch
Posts: 6

Rep: Reputation: 0
Hi there,

I had a look at the /etc/rc.d/init.d/network script on my LFS box (6.0) and the script is definitely expecting it to be a directory, not a file.. have you confirmed that your script is uncorrupted?

Perhaps you could paste the relevent section of your script here, so I can compare?

I've got static ip set up on my box, so if required we can compare notes.. mine's an earier version, but that shouldn't be of concern

regards,
David
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Own LFS LiveCD <100MB? rocknarl Linux From Scratch 1 10-13-2005 08:15 AM
LFS LiveCD 6.1-2 satimis Linux From Scratch 6 07-25-2005 09:32 PM
How do you set up a static IPv4-in-IPv6 tunnel? daveman Linux - Networking 1 11-16-2004 02:45 PM
howto delete existing static ip of ethernet(eth0)& reconf multiple ips on eth0 viveku Linux - Networking 2 02-02-2004 01:30 AM
howto delete static ip configured on eth0 & reconf multiple ip on one eth0(redhat8 viveku Linux - Networking 0 01-31-2004 10:40 AM


All times are GMT -5. The time now is 08:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration