LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 01-09-2013, 06:50 AM   #1
JnPson
LQ Newbie
 
Registered: Aug 2012
Location: Norrkoping, Sweden
Distribution: OpenSUSE 12.2
Posts: 6

Rep: Reputation: 0
MES5 in runlevel 3 stuck after starting mavisd. Can't change back to runlevel 5


I'm using MES5 and I changed runlevel in inittab from 5 to 3. Now MES is stuck after starting amavisd, and I can't login. I can change runlevel via SSH, but I'm curious why this is happening?

/Jon
 
Old 01-09-2013, 07:27 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,990
Blog Entries: 54

Rep: Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743
Does syslog or wherever Amavisd logs to show any clues?
 
Old 01-16-2013, 04:24 AM   #3
JnPson
LQ Newbie
 
Registered: Aug 2012
Location: Norrkoping, Sweden
Distribution: OpenSUSE 12.2
Posts: 6

Original Poster
Rep: Reputation: 0
I'm sorry it took me so long to answer you unSpawn.
I cannot read anything from the logs due to lack of knowledge. But I saw this when it ran with init 3:
Failed to register Razor. Try to run as root, su -amavis -s /bin/sh -c 'razor-admin -Register && razor-admin-discover'

I tried to run it but without success.

/Jon
 
Old 01-16-2013, 05:58 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,990
Blog Entries: 54

Rep: Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743Reputation: 2743
Quote:
Originally Posted by JnPson View Post
I cannot read anything from the logs due to lack of knowledge.
See http://logreporters.sourceforge.net/ (and Logwatch): should make reporting and interpreting what's reported easier.


Quote:
Originally Posted by JnPson View Post
su -amavis -s /bin/sh -c 'razor-admin -Register && razor-admin-discover'
Case matters and AFAIK "-register" should be lowercase. Read 'man razor-admin' then try
Code:
su -amavis -s /bin/sh -c 'razor-admin -d -create' 2>&1 | tee /tmp/razorcreate.txt
su -amavis -s /bin/sh -c 'razor-admin -d -register' 2>&1 | tee -a /tmp/razorcreate.txt
su -amavis -s /bin/sh -c 'razor-admin -d -discover' 2>&1 | tee -a /tmp/razorcreate.txt
The file "/tmp/razorcreate.txt" then holds a record of stdout and stderr of all three commands, provided you noticed the "-a" switch using 'tee' ;-p
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Getting a text console runlevel in Kubuntu 10.04 (Changing runlevel won't work) gregorian Linux - Newbie 4 09-05-2010 10:50 AM
[SOLVED] When change default runlevel to 4, tty1 got stuck and tty2-5 don't work ethereal1m Linux - Newbie 5 04-29-2010 01:34 AM
Problems starting runlevel 3 , redhat 7.3, "no more processes left in this runlevel" kiyoshi Linux - Software 1 06-25-2009 05:11 AM
Stuck in Runlevel 3 jaychamp Fedora 3 01-23-2006 01:05 PM
Soun Mixer absent in Runlevel 3 but present in Runlevel 5 debloxie Suse/Novell 1 01-18-2006 09:15 AM


All times are GMT -5. The time now is 01:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration