LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 02-23-2007, 01:37 PM   #1
fabmejia
LQ Newbie
 
Registered: Feb 2007
Location: Bogota, Colombia
Distribution: Linux Mint 15 X64, Mageia 2, Red Hat Enterprise, Centos 6.x
Posts: 20

Rep: Reputation: 0
Unhappy i can mount a nfs share from solaris into linux, but can't write to it


Hello everybody,
I have a solaris 8 box sharing via nfs 6 directories, and the clients are Red Hat Enterprise Linux AS release 3 (Taroon Update 8) with kernel 2.4.21-47, in these boxes i can mount the nfs share but when try to write to it, i got this:
#touch testing
touch: creating `testing': Permission denied (either with root or a normal user)
the configuration file in solaris 8 has multiple lines like this:

share -F nfs -o rw -d "description" /apps/dirname

in the linux box this is one line from fstab of how i am mounting the remote dir:
hostname:/remotedir /apps/localdir nfs rw,soft 0 0

what's wrong here? are there any known issues about nfs shares from solaris to linux?
Thanks
 
Old 02-24-2007, 11:28 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,507

Rep: Reputation: 360Reputation: 360Reputation: 360Reputation: 360
When you are root, this is the expected behavior. Otherwise, are the target permissions allowing you to create a file ?
 
Old 02-24-2007, 06:06 PM   #3
fabmejia
LQ Newbie
 
Registered: Feb 2007
Location: Bogota, Colombia
Distribution: Linux Mint 15 X64, Mageia 2, Red Hat Enterprise, Centos 6.x
Posts: 20

Original Poster
Rep: Reputation: 0
thankyou, reading about nfs i found that, , so i tried with a normal user, but i qet the same result, the permisions of the shared directories are set in the defaults of 755, then i triend also 775, but the only way i get it to work correctly is setting the permisions to the shared directory on the nfs server to 777...., and i donīt want it to be that way.
 
Old 02-25-2007, 01:37 AM   #4
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,507

Rep: Reputation: 360Reputation: 360Reputation: 360Reputation: 360
The 755 permissions still forbid the user to create a file, unless he/she is the directory owner.
 
Old 02-25-2007, 10:25 AM   #5
fabmejia
LQ Newbie
 
Registered: Feb 2007
Location: Bogota, Colombia
Distribution: Linux Mint 15 X64, Mageia 2, Red Hat Enterprise, Centos 6.x
Posts: 20

Original Poster
Rep: Reputation: 0
i will make more tests with the permissions this monday, but i still think that it is an issue mounting a solaris 8 nfs share in a linux redhat ES box..... i'll like to know what do you think about it.
 
Old 02-26-2007, 02:19 PM   #6
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,507

Rep: Reputation: 360Reputation: 360Reputation: 360Reputation: 360
I don't think so. From the clues you give there is nothing that looks unexpected to me.
 
Old 02-27-2007, 07:53 AM   #7
fabmejia
LQ Newbie
 
Registered: Feb 2007
Location: Bogota, Colombia
Distribution: Linux Mint 15 X64, Mageia 2, Red Hat Enterprise, Centos 6.x
Posts: 20

Original Poster
Rep: Reputation: 0
so there is no other solution than setting the shared directory to 777 permission, on the server?? i have set it that way but i don't like it very much ....
 
Old 02-27-2007, 08:47 AM   #8
rahulk
Member
 
Registered: Mar 2006
Posts: 110

Rep: Reputation: 16
Quote:
Originally Posted by fabmejia
so there is no other solution than setting the shared directory to 777 permission, on the server?? i have set it that way but i don't like it very much ....
See, when you do a NFS, the directory is owned by nfsnobody (NFS deamon) and hence 777 permission is needed since the remote server users are as good as other users in terms of permission.

If you dont want to have it like this way, then better use Samba for File sharing.
 
Old 02-27-2007, 11:26 AM   #9
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,507

Rep: Reputation: 360Reputation: 360Reputation: 360Reputation: 360
Quote:
Originally Posted by fabmejia
so there is no other solution than setting the shared directory to 777 permission, on the server?
This has nothing to do with NFS, you have the same "limitation" while using a local directory.
You may want to try setting the permissions on the mounted directory to 4777 to reduce user rights on other people's files.
Quote:
i have set it that way but i don't like it very much ....
As the directory is to be shared, I'm missing what you don't like in setting the permissions to allow proper access.

Last edited by jlliagre; 02-27-2007 at 11:45 AM.
 
Old 03-05-2007, 09:37 PM   #10
fabmejia
LQ Newbie
 
Registered: Feb 2007
Location: Bogota, Colombia
Distribution: Linux Mint 15 X64, Mageia 2, Red Hat Enterprise, Centos 6.x
Posts: 20

Original Poster
Rep: Reputation: 0
Thankyou

for all your replies and advice,all of them clarify to me some wrong concepts i had about file and dir permissions with NFS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't mount samba share and then write to the share calbazon Linux - Software 8 10-10-2010 01:35 AM
NFS mount of smb mount of windows share: permission denied problem :( Bagatur Linux - Networking 4 07-07-2009 11:34 AM
Solaris 10 can't mount a CentOS share ALUOp Linux - Networking 2 11-08-2008 06:32 AM
trouble with nfs mount on Solaris hak_uc Linux - Networking 2 10-26-2006 12:40 PM
nfs mount of solaris drive starkeylabs Linux - Networking 4 06-20-2003 10:16 AM


All times are GMT -5. The time now is 08:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration