LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 04-03-2011, 10:23 AM   #1
WzJazz
LQ Newbie
 
Registered: Apr 2011
Posts: 4

Rep: Reputation: 0
Depsolving problems php-mcrypt


I get the Cannot load mcrypt extension. Please check your PHP configuration. message from phpmyadmin so i tried thid


$sudo yum install php-mcrypt
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: mirror.fysik.dtu.dk
* base: mirror.fysik.dtu.dk
* extras: mirror.fysik.dtu.dk
* updates: mirror.fysik.dtu.dk
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.i386 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mcrypt
--> Finished Dependency Resolution
php-mcrypt-5.1.6-15.el5.centos.1.i386 from extras has depsolving problems
--> Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5.1.6-15.el5.centos.1.i386 (extras)
Error: Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5.1.6-15.el5.centos.1.i386 (extras)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

Can't figure out how to resolve this one. Any ideas?
 
Old 04-03-2011, 06:21 PM   #2
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 697

Rep: Reputation: 93
Basically it is saying that it can't find php-api version 20041225
which is needed by the latest version of php-mcrypt.

You could post a bug report for this, since the extras repository
should provide any dependencies that aren't provided by the base
repository.

Or you could wait a few days and hope that someone else reports it
and it gets fixed.
 
Old 04-04-2011, 01:14 AM   #3
WzJazz
LQ Newbie
 
Registered: Apr 2011
Posts: 4

Original Poster
Rep: Reputation: 0
Thats was what i figured out, hoped that there were some way to get around an old version dependency.

Thanks
 
Old 07-04-2011, 10:10 AM   #4
johnlaine
LQ Newbie
 
Registered: Jun 2011
Posts: 2

Rep: Reputation: Disabled
Hi,
I got the same message in phpmyadmin, "Cannot load mcrypt extension."
and when I tried to install it:

[root@ip-184-168-107-107 johnlaine]# yum install php-mcrypt
Loaded plugins: fastestmirror
Determining fastest mirrors
addons | 951 B 00:00
base | 2.1 kB 00:00
extras | 2.1 kB 00:00
turbopanel-base | 951 B 00:00
turbopanel-centos5 | 951 B 00:00
update | 1.9 kB 00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.i386 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mcrypt
--> Finished Dependency Resolution
php-mcrypt-5.1.6-15.el5.centos.1.i386 from extras has depsolving problems
--> Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5.1 .6-15.el5.centos.1.i386 (extras)
Error: Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5. 1.6-15.el5.centos.1.i386 (extras)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
[root@ip-184-168-107-107 johnlaine]#

I am very green and any help is appreciated.
Thanks
 
Old 07-04-2011, 12:50 PM   #5
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 697

Rep: Reputation: 93
Try running "yum install php-mycrpyt php-common" and see if that works.
 
Old 07-04-2011, 03:20 PM   #6
johnlaine
LQ Newbie
 
Registered: Jun 2011
Posts: 2

Rep: Reputation: Disabled
Thanks for the response carltm.
I installed the php from the webtatic repo, I found some info online that said I needed to enable it like this:
yum -y --enablerepo=webtatic install php-mcrypt
This seemed to have worked.
Does this seem correct to you?
Thanks again
 
Old 07-04-2011, 07:35 PM   #7
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 697

Rep: Reputation: 93
Yes, the webtatic repo has newer versions of php than what the
centos repos have. Apparently their packages have the dependencies
set up correctly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing php-mbstring (depsolving problems) Nitrofish Linux - Newbie 4 04-24-2010 01:09 AM
yum fails with fedora has depsolving problems szmarcek Linux - Software 2 06-25-2009 01:48 AM
php-mcrypt 5.1 source RPMs tmr_leon Linux - Software 0 11-27-2006 02:51 PM
php-mcrypt? nigeledge Linux - Software 0 10-03-2004 09:39 AM
php and mcrypt mayankjohri Linux - General 3 06-29-2002 04:20 AM


All times are GMT -5. The time now is 08:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration