LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 11-15-2007, 05:40 PM   #1
Roboam León López
LQ Newbie
 
Registered: Oct 2007
Location: México City
Posts: 10

Rep: Reputation: 0
Red face Can't find local node name in cluster.conf


Well I'm a newbie in clustering and I'm trying to set a 1 node cluster and I can't start cman, i get:
cman not started: Can't find local node name in cluster.conf /usr/sbin/cman_tool: aisexec daemon didn't start

my cluster.conf is:

?xml version="1.0"?>
<cluster name="kluster" config_version="1">

<cman expected_votes="1">
</cman>

<nodes>
<node name="server.gfs" votes="1">
<fence>
<method name="single">
<device name="human" ipaddr="192.168.1.53"/>
</method>
</fence>
</node>

</nodes>

<fence_devices>
<device name="human" agent="fence_manual"/>
</fence_devices>

</cluster>
I dissabled selinux and already check the permisions in /temp folder (777), can anyone hel me please???

Last edited by Roboam León López; 11-15-2007 at 05:42 PM.
 
Old 11-16-2007, 02:01 AM   #2
elcody02
Member
 
Registered: Jun 2007
Posts: 52

Rep: Reputation: 17
Is your cluster node server.gfs resolvable? Best way is to add the id and name to your /etc/hosts. I suppose you should add a line like as follows:

192.168.1.53 server.gfs


Then this should work.
 
Old 11-19-2007, 10:59 AM   #3
Roboam León López
LQ Newbie
 
Registered: Oct 2007
Location: México City
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks elcody02, I forgot to mencione that server.gfs is resolvable. In /etc/hosts I have:

# Do not remove the following line, or various programs
# that require network functionality will fail.
192.168.1.53 server.gfs server localhost.localdomain localhost
192.168.1.21 athlon1
127.0.0.1 localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6


And I don't have a clue why i can't start cman
 
Old 11-20-2007, 03:07 AM   #4
elcody02
Member
 
Registered: Jun 2007
Posts: 52

Rep: Reputation: 17
Ok. So next is to have a look at what syslog tells you when cman is started. Also the ccsd messages are important. Check if ccsd is running and what it tells you about quorum.

I'm not sure, but I remember having troubles with using nodenames with . in the name. Try to not use server.gfs. Instead use servergfs or something the like. But thats only a wild guess. I'm really not sure about that.

Have fun.
 
Old 11-22-2007, 01:38 PM   #5
Roboam León López
LQ Newbie
 
Registered: Oct 2007
Location: México City
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by elcody02 View Post
Ok. So next is to have a look at what syslog tells you when cman is started. Also the ccsd messages are important. Check if ccsd is running and what it tells you about quorum.

I'm not sure, but I remember having troubles with using nodenames with . in the name. Try to not use server.gfs. Instead use servergfs or something the like. But thats only a wild guess. I'm really not sure about that.

Have fun.
Thanks elcody02

I've tried changing the cluster name from server.gfs to servergfs and I also added "192.168.1.53 servergfs" to /etc/hosts file. But i keep geting the same response.

In /var/log/messages I don't have any line about cman, only lines of ccsd:
Nov 22 13:12:43 server ccsd[14345]: Starting ccsd 2.0.60:
Nov 22 13:12:43 server ccsd[14345]: Built: Mar 14 2007 08:17:44
Nov 22 13:12:43 server ccsd[14345]: Copyright (C) Red Hat, Inc. 2004 All rights reserved.
Nov 22 13:12:43 server ccsd[14345]: cluster.conf (cluster name = kluster, version = 1) found.
Nov 22 13:13:13 server ccsd[14345]: Unable to connect to cluster infrastructure after 30 seconds.
Nov 22 13:13:43 server ccsd[14345]: Unable to connect to cluster infrastructure after 60 seconds.
Nov 22 13:14:13 server ccsd[14345]: Unable to connect to cluster infrastructure after 90 seconds.


Any idea?
 
Old 11-23-2007, 12:18 PM   #6
Roboam León López
LQ Newbie
 
Registered: Oct 2007
Location: México City
Posts: 10

Original Poster
Rep: Reputation: 0
Cool

I used system-config-cluster to made a new cluster.conf file:
<?xml version="1.0" ?>
<cluster alias="kluster" config_version="3" name="kluster">
<fence_daemon post_fail_delay="0" post_join_delay="3"/>
<clusternodes>
<clusternode name="servergfs" nodeid="1" votes="1">
<fence/>
</clusternode>
</clusternodes>
<cman/>
<fencedevices>
<fencedevice agent="fence_manual" name="Yoyosaurio"/>
</fencedevices>
<rm>
<failoverdomains/>
<resources/>
</rm>
</cluster>


And it seems to work much better than the old cluster.conf but I still can't start cman, the last lines of /var/log/messages goes like this:
Nov 23 11:56:48 server openais[18649]: [SERV ] Initialising service handler 'openais CMAN membership service 2.01'
Nov 23 11:56:48 server openais[18649]: [CMAN ] CMAN 2.0.60 (built Mar 14 2007 08:17:48) started
Nov 23 11:56:48 server openais[18649]: [SYNC ] Not using a virtual synchrony filter.
Nov 23 11:56:48 server openais[18649]: [IPC ] ERROR: Could not bind AF_UNIX: Address already in use.
Nov 23 11:56:48 server openais[18649]: [MAIN ] AIS Executive exiting (-7).
Nov 23 11:56:48 server ccsd[18638]: Initial status:: Quorate
Nov 23 11:57:14 server ccsd[18638]: Unable to connect to cluster infrastructure after 30 seconds.


I think that the problem is someting to do with the address, but I'm clueless of how to solve it
 
Old 11-28-2007, 01:04 AM   #7
elcody02
Member
 
Registered: Jun 2007
Posts: 52

Rep: Reputation: 17
Hm, everything looks quite ok so far. What you'll need is the expected_votes="1" in cman.

But that didn't work before either. I haven't seen this before.
Hm, did you try to stop everything:

Quote:
service openais stop
check that no clusterservice is running
service openais start
Wild guess:
You could also try to setup a two node cluster by adding a second node to the cluster.conf. Where no second node is available. Perhaps that is a problem. Check for cman being something like this then:
Quote:
<cman two_node="1" expected_votes="2"/>
Hope you'll get a step further.
 
Old 11-29-2007, 12:42 PM   #8
Roboam León López
LQ Newbie
 
Registered: Oct 2007
Location: México City
Posts: 10

Original Poster
Rep: Reputation: 0
Lightbulb Solved

Well, I disabled a few daemons and also the firewall and it work pretty fine, thanks elcody02 for all your help. I don't know what configuration should I add to the iptables config, but that's a topic for a another post.

Last edited by Roboam León López; 11-29-2007 at 12:54 PM.
 
Old 11-30-2007, 02:12 AM   #9
elcody02
Member
 
Registered: Jun 2007
Posts: 52

Rep: Reputation: 17
Quote:
Originally Posted by Roboam León López View Post
Well, I disabled a few daemons and also the firewall and it work pretty fine, thanks elcody02 for all your help. I don't know what configuration should I add to the iptables config, but that's a topic for a another post.
Great to hear that everything is working now.

For iptables config you might want to have a look at the following URL:
http://www.open-sharedroot.org/faq/a...uster-software
 
Old 07-07-2008, 10:30 AM   #10
psteele555
LQ Newbie
 
Registered: Jun 2008
Distribution: RHEL 5.0
Posts: 24

Rep: Reputation: 15
Quote:
Originally Posted by Roboam León López View Post
Well, I disabled a few daemons and also the firewall and it work pretty fine, thanks elcody02 for all your help. I don't know what configuration should I add to the iptables config, but that's a topic for a another post.
I'm curious: which daemons did you disable, and how did you disable the firewall? Because I'm having the same problem.

I used iptables -F on my firewall and then ran the script at http://www.open-sharedroot.org/faq/a...uster-software (for RHEL 5).
 
Old 07-16-2009, 05:49 AM   #11
mohbrsu
LQ Newbie
 
Registered: Jul 2009
Posts: 13

Rep: Reputation: 0
RedHat Cluster Suite config

Hi, I'm trying to start ccsd service, but is showing, service is already running. If I try stop, it is showing, it is showing Unrecognized service
 
Old 07-17-2009, 07:27 AM   #12
elcody02
Member
 
Registered: Jun 2007
Posts: 52

Rep: Reputation: 17
What version of Red Hat an cluster are you using and what exactly is the output of the commands you issue?
 
Old 07-21-2009, 05:34 AM   #13
mohbrsu
LQ Newbie
 
Registered: Jul 2009
Posts: 13

Rep: Reputation: 0
Hi Elcody02, I'm using RHEL 5.2

# service ccsd start
unrecognized service
 
Old 07-22-2009, 03:09 AM   #14
elcody02
Member
 
Registered: Jun 2007
Posts: 52

Rep: Reputation: 17
The service cman does the whole job.

It's starting ccsd, aisexec, cman, joins the fencedomain starts qdisk (if needed).

So try to start cman and watch the logs very careful.
 
Old 10-20-2009, 05:18 PM   #15
jdang
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by Roboam León López View Post
Well, I disabled a few daemons and also the firewall and it work pretty fine, thanks elcody02 for all your help. I don't know what configuration should I add to the iptables config, but that's a topic for a another post.
Roboam,

Could you list the deamons you disabled?

Thanks,

Joe.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to SSH into cluster node by machine name !? nuro305 Linux - Networking 3 06-23-2006 10:41 PM
Update/upgrade cluster through one node? jford_oldman Debian 8 11-02-2005 07:09 PM
3 node Apache WebServer Linux Cluster youngclusterman Linux - Networking 12 01-29-2004 12:13 PM
cant ping a node in a cluster.. dogma Linux - Networking 3 05-21-2003 11:06 PM
how do I SSH into a cluster node? dogma Linux - Newbie 4 05-15-2003 04:31 PM


All times are GMT -5. The time now is 06:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration