LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 10-27-2007, 03:22 AM   #1
slackiz
LQ Newbie
 
Registered: Mar 2007
Posts: 6

Rep: Reputation: 0
Multiple applications accessing sound device


Multiple applications accessing sound device

Hi,

I am running kubuntu 7.10 (Gutsy) with kernel 2.6.22-14 and noticed that I can't have multiple applications using my sound device at the same time. The first application that uses the sound device will run properly, however any subsequent applications trying to access the sound device will give the following error (or similar):
Failed to open sound device /dev/dsp: Device or resource busy
Sound will not be available.
This behaviour is especially annoying in KDE since KDE based applications tend to lock the sound device even though they are not using it.

The reason why I think this is not a hardware problem is because applications running on windows do not exhibit the same behaviour. Does anyone have a clue how I can fix this problem? Many thanks.

Here is the snippet of the loaded sound modules:

> lsmod | grep snd
snd_hda_intel 263712 6
snd_pcm_oss 44672 0
snd_pcm 80388 3 snd_hda_intel,snd_pcm_oss
snd_mixer_oss 17664 2 snd_pcm_oss
snd_seq_dummy 4740 0
snd_seq_oss 33152 0
snd_seq_midi 9600 0
snd_rawmidi 25728 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_seq 53232 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 24324 3 snd_pcm,snd_seq
snd_seq_device 9228 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54660 17 snd_hda_intel,snd_pcm_oss,snd_pcm,snd_mixer_oss,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_de vice
soundcore 8800 2 snd
snd_page_alloc 11400 2 snd_hda_intel,snd_pcm

Cheers,

Hendrik
 
Old 10-27-2007, 07:43 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
Yes, the arts sound system that kde uses does tend to be selfish. One thing you can do is go into the kde control center >> sound and multimedia >> sound system and set the 'auto suspend' setting to about 3 seconds or so. This will force kde to give up control much faster and should drastically reduce the number of conflicts you have.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Buring Applications that Use Multiple Recorders pr0gr4mm3r Linux - Software 3 07-07-2007 08:52 PM
Internet accessing applications freezing LOLobo Linux - General 1 06-29-2007 07:10 PM
How do I find applications accessing Network? noobx2 Linux - Networking 2 11-17-2006 02:43 AM
Multiple NICs + Applications spartan263 Linux - Networking 1 09-03-2004 03:41 PM
Help about multiple display/sound device configuration Camion Linux - Newbie 1 05-27-2002 12:30 PM


All times are GMT -5. The time now is 05:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration