LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Multiple applications accessing sound device (http://www.linuxquestions.org/questions/linux-desktop-74/multiple-applications-accessing-sound-device-594953/)

slackiz 10-27-2007 03:22 AM

Multiple applications accessing sound device
 
Multiple applications accessing sound device

Hi,

I am running kubuntu 7.10 (Gutsy) with kernel 2.6.22-14 and noticed that I can't have multiple applications using my sound device at the same time. The first application that uses the sound device will run properly, however any subsequent applications trying to access the sound device will give the following error (or similar):
Failed to open sound device /dev/dsp: Device or resource busy
Sound will not be available.
This behaviour is especially annoying in KDE since KDE based applications tend to lock the sound device even though they are not using it.

The reason why I think this is not a hardware problem is because applications running on windows do not exhibit the same behaviour. Does anyone have a clue how I can fix this problem? Many thanks.

Here is the snippet of the loaded sound modules:

> lsmod | grep snd
snd_hda_intel 263712 6
snd_pcm_oss 44672 0
snd_pcm 80388 3 snd_hda_intel,snd_pcm_oss
snd_mixer_oss 17664 2 snd_pcm_oss
snd_seq_dummy 4740 0
snd_seq_oss 33152 0
snd_seq_midi 9600 0
snd_rawmidi 25728 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_seq 53232 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 24324 3 snd_pcm,snd_seq
snd_seq_device 9228 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54660 17 snd_hda_intel,snd_pcm_oss,snd_pcm,snd_mixer_oss,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_de vice
soundcore 8800 2 snd
snd_page_alloc 11400 2 snd_hda_intel,snd_pcm

Cheers,

Hendrik

David the H. 10-27-2007 07:43 AM

Yes, the arts sound system that kde uses does tend to be selfish. One thing you can do is go into the kde control center >> sound and multimedia >> sound system and set the 'auto suspend' setting to about 3 seconds or so. This will force kde to give up control much faster and should drastically reduce the number of conflicts you have.


All times are GMT -5. The time now is 05:37 AM.