LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-22-2006, 12:31 AM   #1
tomhanks
LQ Newbie
 
Registered: Aug 2006
Posts: 10

Rep: Reputation: 0
Unhappy Mplayer not working after Totem-xine isntall


hi, I have a strange problem. I'm using FC5 and had mplayer for video playback. after installing Totm-xine from one of the online repositories my mplayer stopped working.
Now whenever i rum gmplayer or mplayer command from a terminal it gives me following error"

gmplayer: error while loading shared libraries: /usr/lib/libavformat.so.50: cannot restore segment prot after reloc: Permission denied

When I checked the /usr/lib/libavformat.so.50 file it says that its a link and it doesn't allow me to set permissions for it.
plz help.
 
Old 08-23-2006, 10:40 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,851

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Were you trying to change permissions as root? If root owns it, only root can change permissions.

The command 'file /usr/lib/libavformat.so.50' will tell you what type of file this is. ( without the quotes ). If it is a link, run as root the command 'locate libavformat.so.50' without the quotes. You may get a message about the data base being more than 8 days old. Run the command as root 'updatedb' ( no quotes ). That will take a few minutes the first time. Then re-run the locate command. The system should list the path to all files called libavformat.so.50. Go to what ever path you find and adjust the permissions with chmod.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 Ubuntu problems - xine, mplayer, and totem issues KingSnake Linux - Software 7 11-29-2005 05:46 PM
Sound works perfect (incl Xine and Mplayer) but not in Totem elluva Linux - Software 0 02-05-2005 04:48 PM
XMMS, Xine, MPlayer and Totem don't work in KDE 3.2 sdr_ar Mandriva 6 12-30-2004 07:51 AM
Problems with WMV files in Mplayer/Xine/Totem DYNO Linux - Software 14 11-04-2004 06:00 AM
help!! xine, mplayer, totem display problems shinacalypse Linux - Software 12 12-12-2003 07:21 AM


All times are GMT -5. The time now is 03:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration