LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-07-2006, 09:54 AM   #1
Bamitola
Member
 
Registered: Aug 2006
Location: Nigeria
Posts: 39

Rep: Reputation: 15
Cool Mounting NTFS files


Working on my Linux partition i want to copy a file my windows partition,but i try all the command i could they never work.
I try this command :
mount -t vfat /dev /hda1 /mnt/windows

Which never work.
Later did a friend tells me i hae to configure my kernel to work with NTFS but i don't know how to do this.
Any help will be highly appreciated.
Thank you.
 
Old 09-07-2006, 10:38 AM   #2
Nathanael
Member
 
Registered: May 2004
Location: Karlsruhe, Germany
Distribution: debian, gentoo, os x (darwin), ubuntu
Posts: 940

Rep: Reputation: 32
you are trying to access a ntfs partition then
mount -t ntfs /dev/hda1 /mnt/windows
would be the right way of using mount (please note: there is no space between /dev and /hda1)

depending on your distro ntfs support is already included.

what error does mount give you?
 
Old 09-08-2006, 05:39 AM   #3
Bamitola
Member
 
Registered: Aug 2006
Location: Nigeria
Posts: 39

Original Poster
Rep: Reputation: 15
Thank you so much for that contribution,
I´ve used the command:
mount -t ntfs /dev/hda1 /mnt/windows
and yet i couldn´t find any file on my Linux,
i mean the folder windows.
But i discover on using the command ¨df¨ i got this:

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
23742884 4465744 18051620 20% /
/dev/hda6 101054 9856 85981 11% /boot
tmpfs 253964 0 253964 0% /dev/shm

So i use mount -t ntfs /dev/hda6 /mnt/windows,it gave me a sign as if it´s copied,on checking the windows folder,i couldn´t find anything there.

I´ll appreciate any help from you.
Thank you.

Last edited by Bamitola; 09-08-2006 at 05:43 AM.
 
Old 09-08-2006, 07:06 AM   #4
Nathanael
Member
 
Registered: May 2004
Location: Karlsruhe, Germany
Distribution: debian, gentoo, os x (darwin), ubuntu
Posts: 940

Rep: Reputation: 32
/mnt/windows has to exists of course before you can mount to it!!!
mkdir -p /mnt/windows

edit: man-pages are very useful - run: man mount (and rtfm)

Last edited by Nathanael; 09-08-2006 at 07:08 AM.
 
Old 09-08-2006, 07:09 AM   #5
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,847

Rep: Reputation: 128Reputation: 128
as root, type
Code:
 fdisk -l
then identify from that the parition which is formatted as ntfs, then type as you did above, only this time replace the /dev/hda1 with whatever the output of fdisk -l gives you as your ntfs partition. to see your files, you'll need to change directory into /mnt/windows, wherein you should find your ntfs files. you're best off mounting your ntfs drive as read-only as ntfs support is still not totally write-enabled. so your mount command will look something like:
Code:
mount /dev/hdX1 /mnt/windows -t ntfs -o ro
the -o ro bit makes the parition read-only. take a look at http://www.linuxquestions.org/questi...29#post2236629 where i went into excessive detail on mounting ntfs partitions.

Last edited by pwc101; 09-08-2006 at 07:11 AM.
 
Old 09-08-2006, 07:21 AM   #6
Bamitola
Member
 
Registered: Aug 2006
Location: Nigeria
Posts: 39

Original Poster
Rep: Reputation: 15
Cool

Yah thanks so much for this,i tried it,but it keeps complaining about an unknown filesystem.What do you think i can do next.
Here´s the result down here.


Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 6 48163+ de Dell Utility
/dev/hda2 * 7 3687 29567632+ 7 HPFS/NTFS
/dev/hda3 3688 9318 45231007+ f W95 Ext'd (LBA)
/dev/hda4 9319 9729 3301357+ db CP/M / CTOS / ...
/dev/hda5 6889 9318 19518943+ 7 HPFS/NTFS
/dev/hda6 3688 3700 104359+ 83 Linux
/dev/hda7 3701 6888 25607578+ 8e Linux LVM

Partition table entries are not in disk order
[root@tola ~]# mount /dev/hda6 /mnt/windows -t ntfs -o ro
mount: unknown filesystem type 'ntfs'
[root@tola ~]# mount /dev/hda7 /mnt/windows -t ntfs -o ro
mount: unknown filesystem type 'ntfs'
 
Old 09-08-2006, 07:25 AM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
If you're using Fedora Core 5, as suggested by some of your other threads, then you can get an NTFS kernel module RPM from www.linux-ntfs.org, install that and you'll have support for NTFS (presumably you'll still need to load the module with "modprobe ntfs" or similar.. see the instructions on the site), then you'll be able to mount the filesystem.
 
Old 09-08-2006, 07:27 AM   #8
Nathanael
Member
 
Registered: May 2004
Location: Karlsruhe, Germany
Distribution: debian, gentoo, os x (darwin), ubuntu
Posts: 940

Rep: Reputation: 32
i suggest you actually then try to mount the drives fdisk -l states to be ntfs...
(/dev/hda2 and /dev/hda5)
that could help a little !!
 
Old 09-08-2006, 07:41 AM   #9
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,847

Rep: Reputation: 128Reputation: 128
to save you some effort:

http://www.linux-ntfs.org/content/view/187 is where to find the rpms, and

http://www.linux-ntfs.org/content/view/127/63/ is how to enable your system to mount ntfs drives. read carefully!
 
Old 09-08-2006, 11:05 AM   #10
SkippyBoy
Member
 
Registered: Oct 2005
Distribution: Suse10.2
Posts: 65

Rep: Reputation: 15
Which distro are you using? Suse mounts NTFS drives automatically - but in read-only mode.

Everything I have read so far discourages writing to NTFS drives, but says it is possible using the tools mentioned above.

Another way is to create a FAT32 partition. Then you can share documents between Windows and linux without worrying about damaging the NTFS filesystem.
 
Old 09-11-2006, 06:22 AM   #11
Bamitola
Member
 
Registered: Aug 2006
Location: Nigeria
Posts: 39

Original Poster
Rep: Reputation: 15
Yes! I've check into this website: http://www.linux-ntfs.org/content/view/187
to get kernel download, but i got this message on my screen because thing was unable to install:
Malicious software can damage your computer or cause other harm.
DETAILS:
Package kernel-module ntfs-2.6.9-42.0.2. Elhugenmen - 2.1.20-0.rr.10.0.i686.rpm is not signed.
And please whats distro and how can i get information about it.

Whatelse do you think i can do?

Last edited by Bamitola; 09-11-2006 at 06:23 AM.
 
Old 09-11-2006, 06:36 AM   #12
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,847

Rep: Reputation: 128Reputation: 128
Your distro is the flavour of linux that you're using (it's short for distribtuion), for example Fedora, Slackware, Suse, Ubuntu, Debian etc.

edit: If you tell us which one you're using, we'll be better equipped to help you with your problem.

Last edited by pwc101; 09-11-2006 at 06:39 AM.
 
Old 09-12-2006, 09:17 AM   #13
Bamitola
Member
 
Registered: Aug 2006
Location: Nigeria
Posts: 39

Original Poster
Rep: Reputation: 15
I'm currently using Fedora Core 5.
Thank you.
 
Old 09-13-2006, 03:44 AM   #14
pwc101
Senior Member
 
Registered: Oct 2005
Location: UK
Distribution: Slackware
Posts: 1,847

Rep: Reputation: 128Reputation: 128
ok. what kernel are you using (type uname -r into a terminal)? do you have a single or two processors?
 
Old 09-13-2006, 11:22 AM   #15
svin
Newbie
 
Registered: Jun 2005
Location: India
Posts: 10

Rep: Reputation: 0
Dear Bamitola,

Are you trying to copy from windows to linux or from linux to windows? You cannot access linux from windows. You can however access windows drives from linux(both ntfs and vfat) and write to fat32 partitions.

Now assuming that you are trying to access windows from your FedoraCore 5, you first have to download software that reads ntfs partitions because Redhat and FedoraCore does not have ntfs reading facility.

When you login to linux, open a terminal and type uname -r command to know the kernel release. Now use uname -p to know your processor type. Once you have these two information go to http://www.linux-ntfs.org/content/view/187, (this page is for FedoraCore 5) to choose the rpm that supports your kernel and processor type.

Quote:
but i got this message on my screen because thing was unable to install:
Malicious software can damage your computer or cause other harm.
DETAILS:
Package kernel-module ntfs-2.6.9-42.0.2. Elhugenmen - 2.1.20-0.rr.10.0.i686.rpm is not signed.
Hey bro, how can you get this message? Did you try to install it from windows?
Login to linux, open a terminal and type rpm -iUvh <packagename.rpm>, where
<packagename.rpm> is the rpm file you downloaded. Once its installed you can access your ntfs partition upon mounting.

Now to mount first you should create a folder in /mnt, say /mnt/windows
To do that type mkdir /mnt/windows

You say fdisk -l gave you this,
Quote:
Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 6 48163+ de Dell Utility
/dev/hda2 * 7 3687 29567632+ 7 HPFS/NTFS
/dev/hda3 3688 9318 45231007+ f W95 Ext'd (LBA)
/dev/hda4 9319 9729 3301357+ db CP/M / CTOS / ...
/dev/hda5 6889 9318 19518943+ 7 HPFS/NTFS
/dev/hda6 3688 3700 104359+ 83 Linux
/dev/hda7 3701 6888 25607578+ 8e Linux LVM
and you are saying,
Quote:
[root@tola ~]# mount /dev/hda6 /mnt/windows -t ntfs -o ro
mount: unknown filesystem type 'ntfs'
[root@tola ~]# mount /dev/hda7 /mnt/windows -t ntfs -o ro
mount: unknown filesystem type 'ntfs'
hda6 and hda7 are linux partitions! How can you mount them as ntfs?

You should be typing hda2 and/or hda5 as:
mount -t ntfs /dev/hda2 /mnt/windows

If you do this you will definitely get access to your ntfs partition. This is valid for a single session. Before you logout you have to unmount the partition with:
umount /dev/hda2 OR umount /mnt/windows

If you want your ntfs partition to be automatically mounted each time you login you have to edit /etc/fstab file. But you first try this. Good Luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Copy files from NTFS to NTFS ThaHackBoy Linux - Hardware 2 05-21-2005 06:36 PM
Mounting NTFS Eagle101 Linux - General 2 12-13-2004 09:57 AM
Mounting NTFS amphibious Linux - Software 0 09-27-2003 10:49 PM
Mounting NTFS dibyendra Linux - Newbie 5 08-31-2003 09:52 PM
Mounting NTFS tspauld98 Linux - General 3 08-04-2002 02:46 AM


All times are GMT -5. The time now is 07:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration