Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 05-24-2010, 05:36 PM   #1
Registered: Oct 2008
Location: Mexico City
Distribution: Fedora
Posts: 65

Rep: Reputation: 15
How pass -ignoreABI to Xorg from GDM?

I successfully install nVidia drivers and prevent nouveau loads.

Almost all works fine, but when gdm try to start a X server fail with this message:

cat /var/log/Xorg.0.log |grep -e EE -e WW

[    88.641] (II) Loading extension MIT-SCREEN-SAVER
[    89.149] (EE) NVIDIA(0): This video driver ABI is not supported.
[    89.149] (EE) NVIDIA(0): Use the -ignoreABI option to override this check.
So, I manually start Xorg with the -ignoreABI and works fine.

Xorg :0 -ignoreABI
But I can't start Xorg from GDM, I try put

Section "ServerFlags"
 Option "IgnoreABI" "1" 
in /etc/X11/xorg.conf

also try put

command=/usr/bin/Xorg -ignoreABI
in /etc/gdm/custom.conf

But don't works, How can I pass the -ignoreABI argument to Xorg from GDM and start normally?

Finally, I found this bug.

So, I hope there is another way to pass arguments to Xorg from GDM, I don't want install kdm

Old 05-25-2010, 06:56 AM   #2
Senior Member
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,503

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
Here's the ServerFlags section of my xorg.conf file. Hope it helps
Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12).  This allows clients to receive these key
# events.
#    Option "DontVTSwitch"
# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...
        Option      "RandR" "on"
        Option      "AIGLX" "on"
        # added the following per
        #Option      "ignoreABI" "true"
Old 05-26-2010, 11:49 AM   #3
Registered: Oct 2008
Location: Mexico City
Distribution: Fedora
Posts: 65

Original Poster
Rep: Reputation: 15

I also try

Option      "ignoreABI" "true"
But don't works, It looks like more a problem of how GDM call Xorg inside the source-code, and the lack that can't load values from /etc/gdm/custom.conf

Here's my thread in FedoraForum

and the continuation:

Last edited by scmbg; 05-26-2010 at 11:58 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg/GDM - Errors+Warnings(SW 12.2) rc nai Slackware 2 12-13-2008 08:51 PM
gdm/xorg wont start android6011 Linux - Software 2 01-23-2007 07:49 PM
.xinitrc and .xsession not executing with GDM under Xorg kushalkoolwal Debian 11 02-07-2006 12:09 PM
unstable xorg with stable gdm kushalkoolwal Debian 7 02-04-2006 07:00 PM
how to configure KDE/KDM with xfree86 args like -ignoreABI kennwoods Red Hat 1 07-14-2004 12:55 PM

All times are GMT -5. The time now is 11:25 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration