LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 11-05-2012, 02:43 PM   #1
gecici90
LQ Newbie
 
Registered: May 2006
Distribution: Archlinux
Posts: 5

Rep: Reputation: 0
Gnome 3.6 Black screen after the last update


I've updated my systems, as usual both of my systems laptop and desktop.first laptop cant start gnome 3.6, it works by adding the initrd to the kernel line on grub config file.But i am not lucky for the desktop,

I've performed the actions for desktop again, but it doesnt work.After that i 've decided to migrate to the pure systemd by following the descriptions on wiki page.But it doesnt work yet.System goes well to the login screen without graphical desktop.The only problem for the multi-user.target is long login action.When i log into the system, it waits for aprox. 15-20 seconds, then login successfully completes.On the other hand, when i change the graphical.target with "systemctl isolate graphical.target" it starts the X, but only i can see is "black screen" with a clock mouse pointer.

Finally I've found the clue to fix it while searching the net on the following link

https://bbs.archlinux.org/viewtopic.php?pid=1187469

I've realized that polkit.service is not runnning for me too.I havent "polkitd" group.Then i've added the polkitd with 102 GID number to my /etc/group file but nothing changed and searched again /etc/group file for gdm.Yeah i got it all, the GDM group has the same gid,which is 102, with the polkitd.Then 'Ive removed the polkitd group from the /etc/group file, unistalled the gdm and polkit, then reinstalled gdm and checked the /etc/group file.It has 120 GID number, then reinstalled the polkit package, checked again the file.The polkit has 102 GID number.

After all when i reboot the system there is no waiting period for multi-user.target as i mentioned before.Then enable the graphical.target with the command

systemctl enable graphical.target

everything is fine now.I guess this is the SOLVED topic now

Last edited by gecici90; 11-07-2012 at 08:01 AM.
 
Old 11-07-2012, 05:02 AM   #2
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 718

Rep: Reputation: 102Reputation: 102
Lightbulb

Did you enable the log in manager via systemctl



systemctl start slim.service
systemctl enable slim.service




Replace "slim" with whatever manager you are using ( lxdm, gdm et cettera)
 
Old 11-07-2012, 07:59 AM   #3
gecici90
LQ Newbie
 
Registered: May 2006
Distribution: Archlinux
Posts: 5

Original Poster
Rep: Reputation: 0
I use gdm instead of slim.Yes i enabled the gdm.service via systemctl

systemctl enable gdm.service
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
After update i get black screen in xorg Bojevnik Suse/Novell 6 07-28-2009 07:36 AM
NVIDIA driver update fixes black screen issue em21701 Slackware 5 06-03-2008 11:18 PM
Sax2 Config Causes Black Screen After ATI Update Harpo Suse/Novell 4 06-13-2006 11:33 AM
black screen after starting gnome gcoleson Linux - Newbie 3 11-15-2005 03:27 PM
screen goes black in gnome pfaendtner Linux - Software 1 08-14-2004 06:55 AM


All times are GMT -5. The time now is 06:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration