LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-11-2007, 09:03 PM   #1
Four
Member
 
Registered: Aug 2005
Posts: 298

Rep: Reputation: 30
yum update fails for dependencies


Yum fails and I don't know why. I have tryed doing what people suggested to other users of a similar problem which was to uninstall mplayer, ffmpeg. I did that but still I can't do a yum update.

I would like to update fedora7.

Thanks
Code:
# yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package wine.i386 0:0.9.49-1.fc7 set to be updated
---> Package policycoreutils-gui.i386 0:2.0.16-15.fc7 set to be updated
---> Package wine-core.i386 0:0.9.49-1.fc7 set to be updated
---> Package fuse.i386 0:2.7.0-6.fc7 set to be updated
---> Package gnome-desktop.i386 0:2.18.3-4.fc7 set to be updated
---> Package elfutils-libelf.i386 0:0.131-1.fc7 set to be updated
---> Package system-config-printer.i386 0:0.7.74.4-1.fc7 set to be updated
---> Package util-linux.i386 0:2.13-0.54.1.fc7 set to be updated
---> Package nas.i386 0:1.9.1-2.fc7 set to be updated
---> Package totem-plparser.i386 0:2.18.3-1.fc7 set to be updated
---> Package libtirpc.i386 0:0.1.7-9.fc7 set to be updated
---> Package totem-mozplugin.i386 0:2.18.3-1.fc7 set to be updated
---> Package pidgin.i386 0:2.2.2-1.fc7 set to be updated
---> Package yelp.i386 0:2.18.1-8.fc7 set to be updated
---> Package libacl-devel.i386 0:2.2.39-6.fc7 set to be updated
---> Package fuse-libs.i386 0:2.7.0-6.fc7 set to be updated
---> Package gparted.i386 0:0.3.3-14.fc7 set to be updated
---> Package x264.i386 0:0.0.0-0.3.20070529.fc7 set to be updated
---> Package system-config-printer-libs.i386 0:0.7.74.4-1.fc7 set to be updated
---> Package openoffice.org-graphicfilter.i386 1:2.3.0-6.5.fc7 set to be updated
---> Package python.i386 0:2.5-15.fc7 set to be updated
---> Package tk.i386 1:8.4.13-6.fc7 set to be updated
---> Package udev.i386 0:116-3.fc7 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.6.4-61.fc7 set to be updated
---> Package link-grammar.i386 0:4.2.5-1.fc7 set to be updated
---> Package texinfo.i386 0:4.11-2.fc7 set to be updated
---> Package perl.i386 4:5.8.8-27.fc7 set to be updated
---> Package policycoreutils.i386 0:2.0.16-15.fc7 set to be updated
---> Package rpm-python.i386 0:4.4.2.2-2.fc7 set to be updated
---> Package SDL-devel.i386 0:1.2.12-1.fc7 set to be updated
---> Package gnutls.i386 0:1.6.3-2.fc7 set to be updated
---> Package mysql-libs.i386 0:5.0.45-1.fc7 set to be updated
---> Package cyrus-sasl.i386 0:2.1.22-8.fc7 set to be updated
---> Package net-snmp-libs.i386 1:5.4-16.fc7 set to be updated
---> Package linuxwacom.i386 0:0.7.6.4-3.fc7 set to be updated
---> Package wine-cms.i386 0:0.9.49-1.fc7 set to be updated
---> Package genisoimage.i386 0:1.1.6-6.fc7 set to be updated
---> Package perl-ExtUtils-MakeMaker.i386 0:6.30-27.fc7 set to be updated
---> Package groff.i386 0:1.18.1.4-7.fc7 set to be updated
---> Package curl-devel.i386 0:7.16.4-1.fc7 set to be updated
---> Package wine-ldap.i386 0:0.9.49-1.fc7 set to be updated
---> Package nss_ldap.i386 0:257-4.fc7 set to be updated
---> Package liberation-fonts.noarch 0:0.2-2.fc7 set to be updated
---> Package cyrus-sasl-lib.i386 0:2.1.22-8.fc7 set to be updated
---> Package tomcat5-servlet-2.4-api.i386 0:5.5.25-1jpp.1.fc7 set to be updated
---> Package fedora-usermgmt-default-fedora-setup.noarch 0:0.10-1.fc7 set to be updated
---> Package system-config-users.noarch 0:1.2.64-1.fc7 set to be updated
---> Package python-setuptools.noarch 0:0.6c7-1.fc7 set to be updated
---> Package cinelerra.i386 0:2.1-0.12.20070108.fc7 set to be updated
--> Processing Dependency: libavutil.so.49 for package: cinelerra
--> Processing Dependency: libpostproc.so.51 for package: cinelerra
--> Processing Dependency: libavcodec.so.51 for package: cinelerra
--> Processing Dependency: libfftw3.so.3 for package: cinelerra
--> Processing Dependency: libImath.so.4 for package: cinelerra
--> Processing Dependency: libHalf.so.4 for package: cinelerra
--> Processing Dependency: libmjpegutils-1.9.so.0 for package: cinelerra
--> Processing Dependency: libIlmImf.so.4 for package: cinelerra
--> Processing Dependency: libIex.so.4 for package: cinelerra
---> Package libdca.i386 0:0.0.5-1.fc7 set to be updated
---> Package acl.i386 0:2.2.39-6.fc7 set to be updated
---> Package foomatic.i386 0:3.0.2-47.2.fc7 set to be updated
---> Package cups.i386 1:1.2.12-8.fc7 set to be updated
---> Package cups-libs.i386 1:1.2.12-8.fc7 set to be updated
---> Package openssl.i686 0:0.9.8b-15.fc7 set to be updated
---> Package openoffice.org-writer.i386 1:2.3.0-6.5.fc7 set to be updated
---> Package system-config-date.noarch 0:1.9.5-1.fc7 set to be updated
---> Package openoffice.org-core.i386 1:2.3.0-6.5.fc7 set to be updated
---> Package perl-CPAN.i386 0:1.76_02-27.fc7 set to be updated
---> Package ncurses-devel.i386 0:5.6-9.20070812.fc7 set to be updated
---> Package fedora-usermgmt-shadow-utils.noarch 0:0.10-1.fc7 set to be updated
---> Package coreutils.i386 0:6.9-6.fc7 set to be updated
---> Package vixie-cron.i386 4:4.1-84.fc7 set to be updated
---> Package openldap-devel.i386 0:2.3.34-4.fc7 set to be updated
---> Package subversion.i386 0:1.4.4-1.fc7 set to be updated
---> Package python-devel.i386 0:2.5-15.fc7 set to be updated
---> Package cyrus-sasl-plain.i386 0:2.1.22-8.fc7 set to be updated
---> Package libattr-devel.i386 0:2.4.32-3.fc7 set to be updated
---> Package tetex-xdvi.i386 0:3.0-40.3.fc7 set to be updated
---> Package bwidget.noarch 0:1.8.0-2.fc7 set to be updated
---> Package perl-ExtUtils-Embed.i386 0:1.26-27.fc7 set to be updated
---> Package wine-nas.i386 0:0.9.49-1.fc7 set to be updated
---> Package dmraid.i386 0:1.0.0.rc14-4.fc7 set to be updated
---> Package curl.i386 0:7.16.4-1.fc7 set to be updated
---> Package usermode-gtk.i386 0:1.93-1.fc7 set to be updated
---> Package pango.i386 0:1.16.4-2.fc7 set to be updated
---> Package dbus-glib.i386 0:0.73-3.fc7 set to be updated
---> Package libICE-devel.i386 0:1.0.3-2.1.fc7 set to be updated
---> Package xorg-x11-xfs.i386 1:1.0.5-1.fc7 set to be updated
---> Package system-config-securitylevel.i386 0:1.7.0-6.fc7 set to be updated
---> Package qt.i386 1:3.3.8-7.fc7 set to be updated
---> Package samba-common.i386 0:3.0.28-0.fc7 set to be updated
---> Package gdb.i386 0:6.6-16.fc7 set to be updated
---> Package ncurses.i386 0:5.6-9.20070812.fc7 set to be updated
---> Package smartmontools.i386 1:5.37-3.3.fc7 set to be updated
---> Package evolution.i386 0:2.10.3-4.fc7 set to be updated
---> Package hal-cups-utils.i386 0:0.6.13-2.fc7 set to be updated
---> Package rpm.i386 0:4.4.2.2-2.fc7 set to be updated
---> Package qt4-x11.i386 0:4.3.2-4.fc7 set to be updated
---> Package fluxbox.i386 0:1.0.0-1.fc7 set to be updated
---> Package samba.i386 0:3.0.28-0.fc7 set to be updated
---> Package vnc-server.i386 0:4.1.2-19.fc7 set to be updated
---> Package libselinux.i386 0:2.0.14-10.fc7 set to be updated
---> Package python-libs.i386 0:2.5-15.fc7 set to be updated
---> Package netpbm.i386 0:10.35.32-2.fc7 set to be updated
---> Package xorg-x11-drv-nv.i386 0:2.1.3-1.fc7 set to be updated
---> Package libgcj.i386 0:4.1.2-27.fc7 set to be updated
---> Package tar.i386 2:1.15.1-28.fc7 set to be updated
---> Package elfutils.i386 0:0.131-1.fc7 set to be updated
---> Package elfutils-libelf-devel.i386 0:0.131-1.fc7 set to be updated
---> Package libselinux-devel.i386 0:2.0.14-10.fc7 set to be updated
---> Package wine-esd.i386 0:0.9.49-1.fc7 set to be updated
---> Package fast-user-switch-applet.i386 0:2.17.4-5.fc7 set to be updated
---> Package cpio.i386 0:2.6-28.fc7 set to be updated
---> Package openoffice.org-math.i386 1:2.3.0-6.5.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.23.8-34.fc7 set to be updated
---> Package gnome-python2-gtkhtml2.i386 0:2.14.3-7.fc7 set to be updated
---> Package libacl.i386 0:2.2.39-6.fc7 set to be updated
---> Package dhclient.i386 12:3.0.5-40.fc7 set to be updated
---> Package wpa_supplicant.i386 1:0.5.7-4.fc7 set to be updated
---> Package openldap.i386 0:2.3.34-4.fc7 set to be updated
---> Package openoffice.org-calc.i386 1:2.3.0-6.5.fc7 set to be updated
---> Package anthy.i386 0:9100d-1.fc7 set to be updated
---> Package vte.i386 0:0.16.9-1.fc7 set to be updated
---> Package ntfsprogs.i386 0:1.13.1-8.fc7 set to be updated
---> Package SDL.i386 0:1.2.12-1.fc7 set to be updated
---> Package wodim.i386 0:1.1.6-6.fc7 set to be updated
---> Package perl-devel.i386 4:5.8.8-27.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.10-2.fc7 set to be updated
---> Package audacity.i386 0:1.3.2-14.fc7.1 set to be updated
---> Package ekiga.i386 0:2.0.11-1.fc7 set to be updated
---> Package wine-tools.i386 0:0.9.49-1.fc7 set to be updated
---> Package ntfs-3g.i386 2:1.1120-1.fc7 set to be updated
---> Package libtheora.i386 0:1.0beta2-2.fc7 set to be updated
---> Package compat-wxGTK26.i386 0:2.6.4-0.7 set to be updated
---> Package kmod-ndiswrapper.i686 0:1.48-1.2.6.23.8_34.fc7 set to be updated
---> Package pykickstart.noarch 0:1.13-2.fc7 set to be updated
---> Package tetex-fonts.i386 0:3.0-40.3.fc7 set to be updated
---> Package opal.i386 0:2.2.11-1.fc7 set to be updated
---> Package libtiff.i386 0:3.8.2-8.fc7 set to be updated
---> Package openoffice.org-impress.i386 1:2.3.0-6.5.fc7 set to be updated
---> Package arts.i386 8:1.5.8-4.fc7 set to be updated
---> Package vnc-libs.i386 0:4.1.2-19.fc7 set to be updated
---> Package gnome-bluetooth-libs.i386 0:0.9.1-1.fc7 set to be updated
---> Package system-config-securitylevel-tui.i386 0:1.7.0-6.fc7 set to be updated
---> Package rsync.i386 0:2.6.9-3.fc7 set to be updated
---> Package xorg-x11-drv-amd.i386 0:0.0-22.20070625.fc7 set to be updated
---> Package cyrus-sasl-devel.i386 0:2.1.22-8.fc7 set to be updated
---> Package libselinux-python.i386 0:2.0.14-10.fc7 set to be updated
---> Package libsmbclient.i386 0:3.0.28-0.fc7 set to be updated
---> Package libdhcp6client.i386 0:0.10-44.fc7 set to be updated
---> Package qt4.i386 0:4.3.2-4.fc7 set to be updated
---> Package tetex-dvips.i386 0:3.0-40.3.fc7 set to be updated
---> Package libvolume_id.i386 0:116-3.fc7 set to be updated
---> Package vorbis-tools.i386 1:1.1.1.svn20070412-3.fc7 set to be updated
---> Package pwlib.i386 0:1.10.10-1.fc7 set to be updated
---> Package tomcat5-jsp-2.0-api.i386 0:5.5.25-1jpp.1.fc7 set to be updated
---> Package bind-libs.i386 31:9.4.2-1.fc7 set to be updated
---> Package ndiswrapper.i386 0:1.48-1.lvn7 set to be updated
---> Package wine-jack.i386 0:0.9.49-1.fc7 set to be updated
---> Package gthumb.i386 0:2.10.7-1.fc7 set to be updated
---> Package xclip.i386 0:0.10-1.fc7 set to be updated
---> Package smolt-firstboot.noarch 0:1.0-2.fc7 set to be updated
---> Package perl-Test-Harness.i386 0:2.56-27.fc7 set to be updated
---> Package python-urlgrabber.noarch 0:3.0.0-3.fc7 set to be updated
---> Package xvidcore.i386 0:1.1.3-2.fc7 set to be updated
---> Package totem.i386 0:2.18.3-1.fc7 set to be updated
---> Package gnome-bluetooth.i386 0:0.9.1-1.fc7 set to be updated
---> Package pirut.noarch 0:1.3.28-1.fc7 set to be updated
--> Processing Dependency: python-iniparse for package: pirut
---> Package tetex.i386 0:3.0-40.3.fc7 set to be updated
---> Package dbus-python.i386 0:0.82.3-1.fc7 set to be updated
---> Package libattr.i386 0:2.4.32-3.fc7 set to be updated
---> Package libsmbios-libs.i386 0:0.13.13-1.fc7 set to be updated
---> Package icedax.i386 0:1.1.6-6.fc7 set to be updated
---> Package popt.i386 0:1.10.2.2-2.fc7 set to be updated
---> Package smolt.noarch 0:1.0-2.fc7 set to be updated
---> Package tetex-IEEEtran.noarch 0:1.7.1-1.fc7 set to be updated
---> Package faad2.i386 0:2.5-2.fc7 set to be updated
---> Package gnome-python2-extras.i386 0:2.14.3-7.fc7 set to be updated
---> Package httpd.i386 0:2.2.6-1.fc7 set to be updated
---> Package netpbm-progs.i386 0:10.35.32-2.fc7 set to be updated
---> Package tzdata.noarch 0:2007j-1.fc7 set to be updated
---> Package libICE.i386 0:1.0.3-2.1.fc7 set to be updated
---> Package bind-utils.i386 31:9.4.2-1.fc7 set to be updated
---> Package hdparm.i386 0:7.7-1.fc7 set to be updated
---> Package libpng.i386 2:1.2.22-1.fc7 set to be updated
---> Package kasumi.i386 0:2.3-1.fc7 set to be updated
---> Package rpm-build.i386 0:4.4.2.2-2.fc7 set to be updated
---> Package libtiff-devel.i386 0:3.8.2-8.fc7 set to be updated
---> Package kernel.i686 0:2.6.23.8-34.fc7 set to be updated
---> Package procps.i386 0:3.2.7-16.1.fc7 set to be updated
---> Package timidity++.i386 0:2.13.2-4.fc7 set to be updated
--> Processing Dependency: timidity++-patches = 2.13.2-4.fc7 for package: timidity++
---> Package wine-capi.i386 0:0.9.49-1.fc7 set to be updated
---> Package xorg-x11-drv-nouveau.i386 0:2.1.3-1.fc7 set to be updated
---> Package libpng-devel.i386 2:1.2.22-1.fc7 set to be updated
---> Package xorg-x11-xtrans-devel.i386 0:1.0.3-2.1.fc7 set to be updated
---> Package rpm-libs.i386 0:4.4.2.2-2.fc7 set to be updated
---> Package usermode.i386 0:1.93-1.fc7 set to be updated
---> Package fedora-usermgmt.noarch 0:0.10-1.fc7 set to be updated
---> Package rpm-devel.i386 0:4.4.2.2-2.fc7 set to be updated
---> Package libpurple.i386 0:2.2.2-1.fc7 set to be updated
---> Package hpijs.i386 1:1.7.4a-6.fc7 set to be updated
---> Package selinux-policy.noarch 0:2.6.4-61.fc7 set to be updated
---> Package openssl-devel.i386 0:0.9.8b-15.fc7 set to be updated
---> Package apr-util.i386 0:1.2.10-1.fc7 set to be updated
---> Package libdvdnav.i386 0:4.1.1-2.fc7 set to be updated
---> Package gnome-python2-libegg.i386 0:2.14.3-7.fc7 set to be updated
---> Package attr.i386 0:2.4.32-3.fc7 set to be updated
---> Package nfs-utils.i386 1:1.1.0-4.fc7 set to be updated
---> Package gstreamer-plugins-good.i386 0:0.10.6-1.fc7 set to be updated
--> Processing Dependency: libwavpack.so.1 for package: gstreamer-plugins-good
---> Package wine-twain.i386 0:0.9.49-1.fc7 set to be updated
---> Package paps.i386 0:0.6.8-1.fc7 set to be updated
--> Processing Dependency: libpaps.so.0 for package: paps
---> Package flac.i386 0:1.2.1-1.fc7 set to be updated
---> Package iptstate.i386 0:2.2.1-1.fc7 set to be updated
--> Processing Dependency: libnetfilter_conntrack.so.1 for package: iptstate
---> Package elfutils-libs.i386 0:0.131-1.fc7 set to be updated
---> Package metacity.i386 0:2.18.5-2.fc7 set to be updated
---> Package yum-updatesd.noarch 0:3.2.7-2.fc7 set to be updated
---> Package tetex-latex.i386 0:3.0-40.3.fc7 set to be updated
---> Package openoffice.org-draw.i386 1:2.3.0-6.5.fc7 set to be updated
---> Package readahead.i386 1:1.4.1-3.fc7 set to be updated
---> Package samba-client.i386 0:3.0.28-0.fc7 set to be updated
---> Package perl-libs.i386 4:5.8.8-27.fc7 set to be updated
---> Package alsa-utils.i386 0:1.0.14-2.fc7 set to be updated
---> Package cyrus-sasl-md5.i386 0:2.1.22-8.fc7 set to be updated
---> Package rpcbind.i386 0:0.1.4-8.fc7 set to be updated
---> Package gettext.i386 0:0.16.1-9.fc7 set to be updated
---> Package swig.i386 0:1.3.33-1.fc7 set to be updated
---> Package yum.noarch 0:3.2.7-2.fc7 set to be updated
---> Package fedora-usermgmt-core.noarch 0:0.10-1.fc7 set to be updated
---> Package netpbm-devel.i386 0:10.35.32-2.fc7 set to be updated
---> Package info.i386 0:4.11-2.fc7 set to be updated
---> Package libdhcp4client.i386 12:3.0.5-40.fc7 set to be updated
---> Package pilot-link.i386 2:0.12.2-6.fc7 set to be updated
---> Package iptables-ipv6.i386 0:1.3.8-2.1.fc7 set to be updated
---> Package iptables.i386 0:1.3.8-2.1.fc7 set to be updated
---> Package libraw1394.i386 0:1.2.1-11.fc7 set to be updated
---> Package perl-Test-Simple.i386 0:0.62-27.fc7 set to be updated
---> Package dhcpv6_client.i386 0:0.10-44.fc7 set to be updated
--> Running transaction check
---> Package python-iniparse.noarch 0:0.2.2-2.fc7 set to be updated
---> Package fftw.i386 0:3.1.2-3.fc6 set to be updated
---> Package mjpegtools.i386 0:1.9.0-0.5.rc2.fc7 set to be updated
--> Processing Dependency: libquicktime.so.0 for package: mjpegtools
---> Package wavpack.i386 0:4.41-1.fc7 set to be updated
---> Package libnetfilter_conntrack.i386 0:0.0.81-1.fc7 set to be updated
--> Processing Dependency: libnfnetlink.so.0 for package: libnetfilter_conntrack
---> Package OpenEXR.i386 0:1.4.0a-3.fc6 set to be updated
--> Processing Dependency: libfltk.so.1.1 for package: OpenEXR
--> Processing Dependency: libfltk_gl.so.1.1 for package: OpenEXR
---> Package paps-libs.i386 0:0.6.8-1.fc7 set to be updated
---> Package ffmpeg-libs.i386 0:0.4.9-0.37.20070503.lvn7 set to be updated
--> Processing Dependency: libx264.so.54 for package: ffmpeg-libs
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Processing Dependency: libdts.so.0 for package: ffmpeg-libs
---> Package ffmpeg.i386 0:0.4.9-0.8.20070530.fc7 set to be updated
---> Package timidity++-patches.i386 0:2.13.2-4.fc7 set to be updated
--> Running transaction check
---> Package fltk.i386 0:1.1.8-0.3.r5750.fc7 set to be updated
---> Package libquicktime.i386 0:1.0.0-1.lvn7 set to be updated
--> Processing Dependency: libx264.so.54 for package: libquicktime
---> Package libnfnetlink.i386 0:0.0.30-1.fc7 set to be updated
---> Package ffmpeg-libs.i386 0:0.4.9-0.37.20070503.lvn7 set to be updated
--> Processing Dependency: libx264.so.54 for package: ffmpeg-libs
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Processing Dependency: libdts.so.0 for package: ffmpeg-libs
--> Finished Dependency Resolution
--> Running transaction check
---> Package libquicktime.i386 0:1.0.0-1.lvn7 set to be updated
--> Processing Dependency: libx264.so.54 for package: libquicktime
---> Package ffmpeg-libs.i386 0:0.4.9-0.37.20070503.lvn7 set to be updated
--> Processing Dependency: libx264.so.54 for package: ffmpeg-libs
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Processing Dependency: libdts.so.0 for package: ffmpeg-libs
---> Package kernel.i686 0:2.6.21-1.3194.fc7 set to be erased
--> Finished Dependency Resolution
Error: Missing Dependency: libx264.so.54 is needed by package ffmpeg-libs
Error: Missing Dependency: libx264.so.54 is needed by package libquicktime
Error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs
Error: Missing Dependency: libdts.so.0 is needed by package ffmpeg-libs
 
Old 12-12-2007, 01:30 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try
Code:
#yum remove ffmpeg-libs faad2 libx264 libquicktime libdts
After that run "yum update".

Another option would be to use the exclude flag e.g.
Code:
#yum update --exclude=ffmpeg-libs --exclude=faad2 --exclude=libx264 --exclude=libquicktime --exclude=libdts
 
Old 12-12-2007, 04:30 PM   #3
Four
Member
 
Registered: Aug 2005
Posts: 298

Original Poster
Rep: Reputation: 30
Now I get the following

Code:
# yum update --exclude=ffmpeg-libs --exclude=faad2 --exclude=libx264 --exclude=libquicktime --exclude=libdts
livna                     100% |=========================| 2.1 kB    00:00
fedora                    100% |=========================| 2.1 kB    00:00
updates                   100% |=========================| 2.3 kB    00:00
primary.sqlite.bz2        100% |=========================| 2.0 MB    00:10
freshrpms                 100% |=========================| 2.1 kB    00:00
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package wine.i386 0:0.9.49-1.fc7 set to be updated
---> Package policycoreutils-gui.i386 0:2.0.16-15.fc7 set to be updated
---> Package wine-core.i386 0:0.9.49-1.fc7 set to be updated
---> Package gnome-desktop.i386 0:2.18.3-4.fc7 set to be updated
---> Package elfutils-libelf.i386 0:0.131-1.fc7 set to be updated
---> Package system-config-printer.i386 0:0.7.74.4-1.fc7 set to be updated
---> Package util-linux.i386 0:2.13-0.54.1.fc7 set to be updated
---> Package nas.i386 0:1.9.1-2.fc7 set to be updated
---> Package totem-plparser.i386 0:2.18.3-1.fc7 set to be updated
---> Package libtirpc.i386 0:0.1.7-9.fc7 set to be updated
---> Package totem-mozplugin.i386 0:2.18.3-1.fc7 set to be updated
---> Package pidgin.i386 0:2.2.2-1.fc7 set to be updated
---> Package samba-client.i386 0:3.0.27a-0.fc7 set to be updated
---> Package yelp.i386 0:2.18.1-8.fc7 set to be updated
---> Package libsmbios-libs.i386 0:0.13.10-1.fc7 set to be updated
---> Package libacl-devel.i386 0:2.2.39-6.fc7 set to be updated
---> Package fuse-libs.i386 0:2.7.0-6.fc7 set to be updated
---> Package kernel.i686 0:2.6.23.1-21.fc7 set to be updated
---> Package gparted.i386 0:0.3.3-14.fc7 set to be updated
---> Package x264.i386 0:0.0.0-0.3.20070529.fc7 set to be updated
---> Package system-config-printer-libs.i386 0:0.7.74.4-1.fc7 set to be updated
---> Package python.i386 0:2.5-15.fc7 set to be updated
---> Package tk.i386 1:8.4.13-6.fc7 set to be updated
---> Package qt4.i386 0:4.3.2-4.fc7 set to be updated
---> Package link-grammar.i386 0:4.2.5-1.fc7 set to be updated
---> Package texinfo.i386 0:4.11-2.fc7 set to be updated
---> Package perl.i386 4:5.8.8-27.fc7 set to be updated
---> Package policycoreutils.i386 0:2.0.16-15.fc7 set to be updated
---> Package rpm-python.i386 0:4.4.2.2-2.fc7 set to be updated
---> Package tzdata.noarch 0:2007i-1.fc7 set to be updated
---> Package SDL-devel.i386 0:1.2.12-1.fc7 set to be updated
---> Package gnutls.i386 0:1.6.3-2.fc7 set to be updated
---> Package mysql-libs.i386 0:5.0.45-1.fc7 set to be updated
---> Package net-snmp-libs.i386 1:5.4-16.fc7 set to be updated
---> Package linuxwacom.i386 0:0.7.6.4-3.fc7 set to be updated
---> Package wine-cms.i386 0:0.9.49-1.fc7 set to be updated
---> Package genisoimage.i386 0:1.1.6-6.fc7 set to be updated
---> Package perl-ExtUtils-MakeMaker.i386 0:6.30-27.fc7 set to be updated
---> Package groff.i386 0:1.18.1.4-7.fc7 set to be updated
---> Package rpcbind.i386 0:0.1.4-8.fc7 set to be updated
---> Package curl-devel.i386 0:7.16.4-1.fc7 set to be updated
---> Package wine-ldap.i386 0:0.9.49-1.fc7 set to be updated
---> Package liberation-fonts.noarch 0:0.2-2.fc7 set to be updated
---> Package bind-utils.i386 31:9.4.2-1.fc7 set to be updated
---> Package tomcat5-servlet-2.4-api.i386 0:5.5.25-1jpp.1.fc7 set to be updated
---> Package fedora-usermgmt-default-fedora-setup.noarch 0:0.10-1.fc7 set to be updated
---> Package system-config-users.noarch 0:1.2.64-1.fc7 set to be updated
---> Package netpbm.i386 0:10.35.32-1.fc7 set to be updated
---> Package python-setuptools.noarch 0:0.6c7-1.fc7 set to be updated
---> Package cinelerra.i386 0:2.1-0.12.20070108.fc7 set to be updated
--> Processing Dependency: libavutil.so.49 for package: cinelerra
--> Processing Dependency: libpostproc.so.51 for package: cinelerra
--> Processing Dependency: libavcodec.so.51 for package: cinelerra
--> Processing Dependency: libfftw3.so.3 for package: cinelerra
--> Processing Dependency: libImath.so.4 for package: cinelerra
--> Processing Dependency: libHalf.so.4 for package: cinelerra
--> Processing Dependency: libmjpegutils-1.9.so.0 for package: cinelerra
--> Processing Dependency: libIlmImf.so.4 for package: cinelerra
--> Processing Dependency: libIex.so.4 for package: cinelerra
---> Package libdca.i386 0:0.0.5-1.fc7 set to be updated
---> Package acl.i386 0:2.2.39-6.fc7 set to be updated
---> Package foomatic.i386 0:3.0.2-47.2.fc7 set to be updated
---> Package cups.i386 1:1.2.12-8.fc7 set to be updated
---> Package cups-libs.i386 1:1.2.12-8.fc7 set to be updated
---> Package openssl.i686 0:0.9.8b-15.fc7 set to be updated
---> Package system-config-date.noarch 0:1.9.5-1.fc7 set to be updated
---> Package openoffice.org-impress.i386 1:2.3.0-6.4.fc7 set to be updated
---> Package perl-CPAN.i386 0:1.76_02-27.fc7 set to be updated
---> Package samba.i386 0:3.0.27a-0.fc7 set to be updated
---> Package ncurses-devel.i386 0:5.6-9.20070812.fc7 set to be updated
---> Package fedora-usermgmt-shadow-utils.noarch 0:0.10-1.fc7 set to be updated
---> Package vixie-cron.i386 4:4.1-84.fc7 set to be updated
---> Package openldap-devel.i386 0:2.3.34-4.fc7 set to be updated
---> Package subversion.i386 0:1.4.4-1.fc7 set to be updated
---> Package python-devel.i386 0:2.5-15.fc7 set to be updated
---> Package nss_ldap.i386 0:257-3.fc7 set to be updated
---> Package libattr-devel.i386 0:2.4.32-3.fc7 set to be updated
---> Package coreutils.i386 0:6.9-5.fc7 set to be updated
---> Package openoffice.org-graphicfilter.i386 1:2.3.0-6.4.fc7 set to be updated---> Package tetex-xdvi.i386 0:3.0-40.3.fc7 set to be updated
---> Package bwidget.noarch 0:1.8.0-2.fc7 set to be updated
---> Package perl-ExtUtils-Embed.i386 0:1.26-27.fc7 set to be updated
---> Package SDL.i386 0:1.2.12-1.fc7 set to be updated
---> Package wine-nas.i386 0:0.9.49-1.fc7 set to be updated
---> Package dmraid.i386 0:1.0.0.rc14-4.fc7 set to be updated
---> Package curl.i386 0:7.16.4-1.fc7 set to be updated
---> Package usermode-gtk.i386 0:1.93-1.fc7 set to be updated
---> Package pango.i386 0:1.16.4-2.fc7 set to be updated
---> Package dbus-glib.i386 0:0.73-3.fc7 set to be updated
---> Package libICE-devel.i386 0:1.0.3-2.1.fc7 set to be updated
---> Package system-config-securitylevel.i386 0:1.7.0-6.fc7 set to be updated
---> Package qt.i386 1:3.3.8-7.fc7 set to be updated
---> Package gdb.i386 0:6.6-16.fc7 set to be updated
---> Package ncurses.i386 0:5.6-9.20070812.fc7 set to be updated
---> Package smartmontools.i386 1:5.37-3.3.fc7 set to be updated
---> Package evolution.i386 0:2.10.3-4.fc7 set to be updated
---> Package openoffice.org-core.i386 1:2.3.0-6.4.fc7 set to be updated
---> Package hal-cups-utils.i386 0:0.6.13-2.fc7 set to be updated
---> Package rpm.i386 0:4.4.2.2-2.fc7 set to be updated
---> Package qt4-x11.i386 0:4.3.2-4.fc7 set to be updated
---> Package fluxbox.i386 0:1.0.0-1.fc7 set to be updated
---> Package vnc-server.i386 0:4.1.2-19.fc7 set to be updated
---> Package openoffice.org-math.i386 1:2.3.0-6.4.fc7 set to be updated
---> Package netpbm-progs.i386 0:10.35.32-1.fc7 set to be updated
---> Package openoffice.org-draw.i386 1:2.3.0-6.4.fc7 set to be updated
---> Package libselinux.i386 0:2.0.14-10.fc7 set to be updated
---> Package python-libs.i386 0:2.5-15.fc7 set to be updated
---> Package gnome-bluetooth-libs.i386 0:0.9.1-1.fc7 set to be updated
---> Package ndiswrapper.i386 0:1.48-1.lvn7 set to be updated
---> Package libgcj.i386 0:4.1.2-27.fc7 set to be updated
---> Package tar.i386 2:1.15.1-28.fc7 set to be updated
---> Package elfutils.i386 0:0.131-1.fc7 set to be updated
---> Package elfutils-libelf-devel.i386 0:0.131-1.fc7 set to be updated
---> Package libsmbclient.i386 0:3.0.27a-0.fc7 set to be updated
---> Package libselinux-devel.i386 0:2.0.14-10.fc7 set to be updated
---> Package fuse.i386 0:2.7.0-6.fc7 set to be updated
---> Package fast-user-switch-applet.i386 0:2.17.4-5.fc7 set to be updated
---> Package cpio.i386 0:2.6-28.fc7 set to be updated
---> Package gnome-python2-gtkhtml2.i386 0:2.14.3-7.fc7 set to be updated
---> Package libacl.i386 0:2.2.39-6.fc7 set to be updated
---> Package dhclient.i386 12:3.0.5-40.fc7 set to be updated
---> Package wpa_supplicant.i386 1:0.5.7-4.fc7 set to be updated
---> Package openldap.i386 0:2.3.34-4.fc7 set to be updated
---> Package pirut.noarch 0:1.3.23-1.fc7 set to be updated
--> Processing Dependency: python-iniparse for package: pirut
---> Package anthy.i386 0:9100d-1.fc7 set to be updated
---> Package vte.i386 0:0.16.9-1.fc7 set to be updated
---> Package ntfsprogs.i386 0:1.13.1-8.fc7 set to be updated
---> Package selinux-policy.noarch 0:2.6.4-57.fc7 set to be updated
---> Package wodim.i386 0:1.1.6-6.fc7 set to be updated
---> Package perl-devel.i386 4:5.8.8-27.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.10-2.fc7 set to be updated
---> Package audacity.i386 0:1.3.2-14.fc7.1 set to be updated
---> Package ekiga.i386 0:2.0.11-1.fc7 set to be updated
---> Package wine-tools.i386 0:0.9.49-1.fc7 set to be updated
---> Package ntfs-3g.i386 2:1.1120-1.fc7 set to be updated
---> Package libtheora.i386 0:1.0beta2-2.fc7 set to be updated
---> Package compat-wxGTK26.i386 0:2.6.4-0.7 set to be updated
---> Package kmod-ndiswrapper.i686 0:1.48-1.2.6.23.8_34.fc7 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.23.8-34.fc7 for package: kmod-ndiswrapper
---> Package pykickstart.noarch 0:1.13-2.fc7 set to be updated
---> Package tetex-fonts.i386 0:3.0-40.3.fc7 set to be updated
---> Package opal.i386 0:2.2.11-1.fc7 set to be updated
---> Package libtiff.i386 0:3.8.2-8.fc7 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.6.4-57.fc7 set to be updated
---> Package arts.i386 8:1.5.8-4.fc7 set to be updated
---> Package vnc-libs.i386 0:4.1.2-19.fc7 set to be updated
---> Package system-config-securitylevel-tui.i386 0:1.7.0-6.fc7 set to be updated
---> Package openoffice.org-calc.i386 1:2.3.0-6.4.fc7 set to be updated
---> Package rsync.i386 0:2.6.9-3.fc7 set to be updated
---> Package xorg-x11-drv-amd.i386 0:0.0-22.20070625.fc7 set to be updated
---> Package libselinux-python.i386 0:2.0.14-10.fc7 set to be updated
---> Package libdhcp6client.i386 0:0.10-44.fc7 set to be updated
---> Package readahead.i386 1:1.4.1-3.fc7 set to be updated
---> Package vorbis-tools.i386 1:1.1.1.svn20070412-3.fc7 set to be updated
---> Package pwlib.i386 0:1.10.10-1.fc7 set to be updated
---> Package tomcat5-jsp-2.0-api.i386 0:5.5.25-1jpp.1.fc7 set to be updated
---> Package bind-libs.i386 31:9.4.2-1.fc7 set to be updated
---> Package wine-jack.i386 0:0.9.49-1.fc7 set to be updated
---> Package gthumb.i386 0:2.10.7-1.fc7 set to be updated
---> Package samba-common.i386 0:3.0.27a-0.fc7 set to be updated
---> Package xclip.i386 0:0.10-1.fc7 set to be updated
---> Package smolt-firstboot.noarch 0:1.0-2.fc7 set to be updated
---> Package python-urlgrabber.noarch 0:3.0.0-3.fc7 set to be updated
---> Package xvidcore.i386 0:1.1.3-2.fc7 set to be updated
---> Package totem.i386 0:2.18.3-1.fc7 set to be updated
---> Package gnome-bluetooth.i386 0:0.9.1-1.fc7 set to be updated
---> Package xorg-x11-drv-nv.i386 0:2.1.3-1.fc7 set to be updated
---> Package tetex.i386 0:3.0-40.3.fc7 set to be updated
---> Package libattr.i386 0:2.4.32-3.fc7 set to be updated
---> Package openoffice.org-writer.i386 1:2.3.0-6.4.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.23.1-21.fc7 set to be updated
---> Package icedax.i386 0:1.1.6-6.fc7 set to be updated
---> Package popt.i386 0:1.10.2.2-2.fc7 set to be updated
---> Package smolt.noarch 0:1.0-2.fc7 set to be updated
---> Package tetex-IEEEtran.noarch 0:1.7.1-1.fc7 set to be updated
---> Package gnome-python2-extras.i386 0:2.14.3-7.fc7 set to be updated
---> Package httpd.i386 0:2.2.6-1.fc7 set to be updated
---> Package libICE.i386 0:1.0.3-2.1.fc7 set to be updated
---> Package hdparm.i386 0:7.7-1.fc7 set to be updated
---> Package kasumi.i386 0:2.3-1.fc7 set to be updated
---> Package rpm-build.i386 0:4.4.2.2-2.fc7 set to be updated
---> Package libtiff-devel.i386 0:3.8.2-8.fc7 set to be updated
---> Package procps.i386 0:3.2.7-16.1.fc7 set to be updated
---> Package timidity++.i386 0:2.13.2-4.fc7 set to be updated
--> Processing Dependency: timidity++-patches = 2.13.2-4.fc7 for package: timidity++
---> Package wine-capi.i386 0:0.9.49-1.fc7 set to be updated
---> Package xorg-x11-drv-nouveau.i386 0:2.1.3-1.fc7 set to be updated
---> Package libpng-devel.i386 2:1.2.22-1.fc7 set to be updated
---> Package xorg-x11-xtrans-devel.i386 0:1.0.3-2.1.fc7 set to be updated
---> Package rpm-libs.i386 0:4.4.2.2-2.fc7 set to be updated
---> Package usermode.i386 0:1.93-1.fc7 set to be updated
---> Package fedora-usermgmt.noarch 0:0.10-1.fc7 set to be updated
---> Package rpm-devel.i386 0:4.4.2.2-2.fc7 set to be updated
---> Package libpurple.i386 0:2.2.2-1.fc7 set to be updated
---> Package hpijs.i386 1:1.7.4a-6.fc7 set to be updated
---> Package openssl-devel.i386 0:0.9.8b-15.fc7 set to be updated
---> Package apr-util.i386 0:1.2.10-1.fc7 set to be updated
---> Package libdvdnav.i386 0:4.1.1-2.fc7 set to be updated
---> Package gnome-python2-libegg.i386 0:2.14.3-7.fc7 set to be updated
---> Package attr.i386 0:2.4.32-3.fc7 set to be updated
---> Package nfs-utils.i386 1:1.1.0-4.fc7 set to be updated
---> Package gstreamer-plugins-good.i386 0:0.10.6-1.fc7 set to be updated
--> Processing Dependency: libwavpack.so.1 for package: gstreamer-plugins-good
---> Package wine-twain.i386 0:0.9.49-1.fc7 set to be updated
---> Package pilot-link.i386 2:0.12.2-6.fc7 set to be updated
---> Package iptstate.i386 0:2.2.1-1.fc7 set to be updated
--> Processing Dependency: libnetfilter_conntrack.so.1 for package: iptstate
---> Package elfutils-libs.i386 0:0.131-1.fc7 set to be updated
---> Package metacity.i386 0:2.18.5-2.fc7 set to be updated
---> Package yum-updatesd.noarch 0:3.2.7-2.fc7 set to be updated
---> Package tetex-latex.i386 0:3.0-40.3.fc7 set to be updated
---> Package tetex-dvips.i386 0:3.0-40.3.fc7 set to be updated
---> Package wine-esd.i386 0:0.9.49-1.fc7 set to be updated
---> Package perl-Test-Harness.i386 0:2.56-27.fc7 set to be updated
---> Package perl-libs.i386 4:5.8.8-27.fc7 set to be updated
---> Package alsa-utils.i386 0:1.0.14-2.fc7 set to be updated
---> Package gettext.i386 0:0.16.1-9.fc7 set to be updated
---> Package libpng.i386 2:1.2.22-1.fc7 set to be updated
---> Package yum.noarch 0:3.2.7-2.fc7 set to be updated
---> Package netpbm-devel.i386 0:10.35.32-1.fc7 set to be updated
---> Package fedora-usermgmt-core.noarch 0:0.10-1.fc7 set to be updated
---> Package info.i386 0:4.11-2.fc7 set to be updated
---> Package libdhcp4client.i386 12:3.0.5-40.fc7 set to be updated
---> Package flac.i386 0:1.2.1-1.fc7 set to be updated
---> Package iptables-ipv6.i386 0:1.3.8-2.1.fc7 set to be updated
---> Package iptables.i386 0:1.3.8-2.1.fc7 set to be updated
---> Package libraw1394.i386 0:1.2.1-11.fc7 set to be updated
---> Package perl-Test-Simple.i386 0:0.62-27.fc7 set to be updated
---> Package dhcpv6_client.i386 0:0.10-44.fc7 set to be updated
--> Running transaction check
---> Package fftw.i386 0:3.1.2-3.fc6 set to be updated
---> Package mjpegtools.i386 0:1.9.0-0.5.rc2.fc7 set to be updated
--> Processing Dependency: libquicktime.so.0 for package: mjpegtools
---> Package python-iniparse.noarch 0:0.2.2-2.fc7 set to be updated
---> Package wavpack.i386 0:4.41-1.fc7 set to be updated
---> Package libnetfilter_conntrack.i386 0:0.0.81-1.fc7 set to be updated
--> Processing Dependency: libnfnetlink.so.0 for package: libnetfilter_conntrack---> Package kmod-ndiswrapper.i686 0:1.48-1.2.6.23.8_34.fc7 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.23.8-34.fc7 for package: kmod-ndiswrapper
---> Package OpenEXR.i386 0:1.4.0a-3.fc6 set to be updated
--> Processing Dependency: libfltk.so.1.1 for package: OpenEXR
--> Processing Dependency: libfltk_gl.so.1.1 for package: OpenEXR
---> Package ffmpeg-libpostproc.i386 0:0.4.9-0.8.20070530.fc7 set to be updated
---> Package ffmpeg.i386 0:0.4.9-0.8.20070530.fc7 set to be updated
---> Package timidity++-patches.i386 0:2.13.2-4.fc7 set to be updated
--> Running transaction check
---> Package fltk.i386 0:1.1.8-0.3.r5750.fc7 set to be updated
---> Package mjpegtools.i386 0:1.9.0-0.5.rc2.fc7 set to be updated
--> Processing Dependency: libquicktime.so.0 for package: mjpegtools
---> Package libnfnetlink.i386 0:0.0.30-1.fc7 set to be updated
---> Package kmod-ndiswrapper.i686 0:1.48-1.2.6.23.8_34.fc7 set to be updated
--> Processing Dependency: kernel-i686 = 2.6.23.8-34.fc7 for package: kmod-ndiswrapper
filelists.sqlite.bz2      100% |=========================| 6.4 MB    01:02
filelists.sqlite.bz2      100% |=========================| 4.4 MB    00:20
--> Finished Dependency Resolution
--> Running transaction check
---> Package mjpegtools.i386 0:1.9.0-0.5.rc2.fc7 set to be updated
--> Processing Dependency: libquicktime.so.0 for package: mjpegtools
---> Package kmod-ndiswrapper.i686 0:1.48-1.2.6.23.8_34.fc7 set to be installed
--> Processing Dependency: kernel-i686 = 2.6.23.8-34.fc7 for package: kmod-ndiswrapper
---> Package kernel.i686 0:2.6.21-1.3194.fc7 set to be erased
--> Finished Dependency Resolution
Error: Missing Dependency: libquicktime.so.0 is needed by package mjpegtools
Error: Missing Dependency: kernel-i686 = 2.6.23.8-34.fc7 is needed by package kmod-ndiswrapper

Thanks
 
Old 12-12-2007, 05:38 PM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Just add those packages to the exclude section e.g.
Code:
#yum yum update --exclude=ffmpeg-libs --exclude=faad2 --exclude=libx264 --exclude=libquicktime --exclude=libdts --exclude=kernel --exclude=kmod-ndiswrapper
 
Old 12-12-2007, 10:12 PM   #5
Four
Member
 
Registered: Aug 2005
Posts: 298

Original Poster
Rep: Reputation: 30
I ran the following and it worked:

Code:
yum update --exclude=ffmpeg-libs --exclude=faad2 --exclude=libx264 --exclude=libquicktime --exclude=libdts --exclude=kernel --exclude=kmod-ndiswrapper --exclude=mjpegtools --exclude=cinelerra
One interesting thing is during the end I got the following messages:

Code:
ts_done name in te is alsa-utils should be gettext
  Cleanup   : swig                         ##################### [444/456] 
ts_done name in te is gettext should be swig
  Cleanup   : openoffice.org-core          ##################### [445/456] 
ts_done name in te is swig should be openoffice.org-core
  Cleanup   : fedora-usermgmt-core         ##################### [446/456] 
ts_done name in te is openoffice.org-core should be fedora-usermgmt-core
  Cleanup   : netpbm-devel                 ##################### [447/456] 
ts_done name in te is fedora-usermgmt-core should be netpbm-devel
  Cleanup   : info                         ##################### [448/456] 
ts_done name in te is netpbm-devel should be info
  Cleanup   : libdhcp4client               ##################### [449/456] 
ts_done name in te is info should be libdhcp4client
  Cleanup   : flac                         ##################### [450/456] 
ts_done name in te is libdhcp4client should be flac
  Cleanup   : iptables-ipv6                ##################### [451/456] 
ts_done name in te is flac should be iptables-ipv6
  Cleanup   : iptables                     ##################### [452/456] 
ts_done name in te is iptables-ipv6 should be iptables
  Cleanup   : libraw1394                   ##################### [453/456] 
ts_done name in te is iptables should be libraw1394
  Cleanup   : perl-Test-Simple             ##################### [454/456] 
ts_done name in te is libraw1394 should be perl-Test-Simple
  Cleanup   : dhcpv6_client                ##################### [455/456] 
ts_done name in te is perl-Test-Simple should be dhcpv6_client
There were way more of those messages this is just a sample. What do those messages mean?

Also what should I do about the rest of the packages that were excluded?
 
Old 12-13-2007, 12:05 AM   #6
dralnux
LQ Newbie
 
Registered: Dec 2007
Posts: 2

Rep: Reputation: 0
yes just add those packages
 
Old 12-13-2007, 03:35 AM   #7
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
The messages appear to be from the clean up script. I think an error happened somewhere during the clean up process, but I don't think its anything to worry about.
 
Old 12-13-2007, 04:02 PM   #8
Decepticon22
Member
 
Registered: Sep 2004
Posts: 32

Rep: Reputation: 15
Hi there,

I am having the same problem and I was wondering if the suggestion made by reddaz would work for me. I and attempting this as root by the way, thyxs.

D22-


[root@deepblue ~]# yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
"
"
"
--> Processing Conflict: rsyslog conflicts syslog-ng
--> Finished Dependency Resolution
Error: Missing Dependency: kdegraphics-libs = 7:3.5.8-7.fc8 is needed by package kdegraphics-extras
Error: Missing Dependency: libkmultipage.so.0 is needed by package kdegraphics-extras
Error: rsyslog conflicts with syslog-ng
[root@d22 ~]#
 
Old 12-13-2007, 04:56 PM   #9
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
What is the output of doing
Code:
$rpm -qa | grep -i syslog
 
Old 12-14-2007, 07:49 AM   #10
Decepticon22
Member
 
Registered: Sep 2004
Posts: 32

Rep: Reputation: 15
syslog-ng-2.0.5-1.fc8
 
Old 12-14-2007, 10:08 AM   #11
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Can you try running "yum upgrade". Do you have the same errors?
 
Old 12-14-2007, 10:26 AM   #12
Decepticon22
Member
 
Registered: Sep 2004
Posts: 32

Rep: Reputation: 15
Well I sorta jumped the gun and did a removal of the problem child apps by doing a yum remove. I then reran yum and got no errors. However it looks like I'll be swicthing to RHEL 5.1 now so this is a mute point to a degree.
The information and fix you provided was right on so I'll remember it in the event I run into this type of problem again. Thanks for you help reddaz! You da man!


D22-
 
Old 12-15-2007, 04:45 PM   #13
Four
Member
 
Registered: Aug 2005
Posts: 298

Original Poster
Rep: Reputation: 30
After searching I finally managed to do a yum update without excluding anything but libdca which This place will explain about libdca. In summery: According to the link there are some incompatibility issue with the libdca rpm provided by fresh rpms and to solve (which also worked for me) remove libdca. Install what you need and just make sure you don't install libdca from freshrpm but its fine from the other repository.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Update YUM Fails sajdutt Linux - Software 7 03-09-2009 10:37 PM
Excluding dependencies from yum update paddyjoy Linux - Newbie 2 05-18-2006 05:45 PM
Yum Update - Error: Missing Dependencies? gandalf2041 Fedora 8 09-07-2005 07:07 PM
yum fails dependencies? belorion Fedora 0 11-13-2004 05:04 PM
yum cannot resolve dependencies to update peregrine2 Linux - Software 0 07-19-2004 10:42 AM


All times are GMT -5. The time now is 01:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration