Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 10-29-2008, 01:03 AM   #1
LQ Newbie
Registered: Jan 2007
Location: India
Distribution: Ubuntu 10.04
Posts: 16

Rep: Reputation: 0
windows drive mount problem in fedora 9

I have two HDD (sda,sdb) installed in my system. sda has four windows partition as one NTFS and three FAT32. sdb has two linux partition one ext3 and one swap and two windows FAT32 partition.

I've ntfs3g installed and two partition got recognized by linux (one NTFS and one FAT32 in sda). Though I didn't got any entry in fstab (I guess ntfs3g has made that entry somewhere else). Now I've tried to mount two FAT32 partition with RW option. I've mounted those drives but write permission is not granted. Here's how my fstab looks like:

UUID=1e6b0838-6ccb-41d9-978b-197fd7e7325e /                       ext3    defaults        1 1
tmpfs              /dev/shm                tmpfs   defaults        0 0
devpts             /dev/pts                devpts  gid=5,mode=620  0 0
sysfs              /sys                    sysfs   defaults        0 0
proc               /proc                   proc    defaults        0 0
/dev/sdb1          /media/CODES		   vfat	   auto,rw,exec	   0 0
/dev/sda5	   /media/MULTIMEDIA	   vfat	   auto,rw,exec	   0 0	
UUID=59889045-d45c-4d47-8e53-5e07547731f3 swap  swap   defaults    0 0
vfat entries I've made and you can see there's no entry for one NTFS and FAT32 partition which has been automatically mounted by the OS and those drives are write enabled. The drives I've mounted (CODES,MULTIMEDIA) is not write enabled.

Here's how my disk pattern looks like:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa499a499

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        3976    31937188+   7  HPFS/NTFS
/dev/sda2            3977       16709   102277822+   f  W95 Ext'd (LBA)
/dev/sda3           16710       19456    22065277+   c  W95 FAT32 (LBA)
/dev/sda5            3977       10363    51303546    b  W95 FAT32
/dev/sda6           10364       16709    50974213+   b  W95 FAT32

Disk /dev/sdb: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa4e5a4e5

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        2511    20169576    c  W95 FAT32 (LBA)
/dev/sdb2            2512        5019    20145510    f  W95 Ext'd (LBA)
/dev/sdb3            5020        9750    38001757+  83  Linux
/dev/sdb4            9751       10011     2096482+  82  Linux swap / Solaris
/dev/sdb5            2512        5019    20145478+   b  W95 FAT32
Old 10-29-2008, 01:10 AM   #2
Registered: Aug 2006
Location: London
Distribution: Debian, Kubuntu
Posts: 572

Rep: Reputation: 75
Try adding 'umask=0' to the options section on fat32 volumes' lines. See it it helps after reboot.
Old 10-29-2008, 04:54 AM   #3
LQ Newbie
Registered: Jan 2007
Location: India
Distribution: Ubuntu 10.04
Posts: 16

Original Poster
Rep: Reputation: 0
That worked. Thank you.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount windows drive davholla Linux - General 15 01-01-2010 10:59 PM
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
windows partition mount problem in Fedora 8 vatzcar Fedora 3 06-12-2008 11:55 AM
Set up rsync to mirror mount on Windows Server to mount point on 2nd internal drive MoMule Linux - Server 4 04-13-2007 09:34 PM
mount to a windows drive jmarsh Linux - Networking 3 10-28-2003 10:49 AM

All times are GMT -5. The time now is 10:16 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration