LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 11-03-2010, 10:00 AM   #1
redh
LQ Newbie
 
Registered: Oct 2010
Posts: 5

Rep: Reputation: 0
Question SAMBA PDC in CentOS


:: Configuration smb.conf
vi /etc/nsswitch.conf

~~~~~[ change on this line : ]~~~~

hosts: files wins dns

~~~~~~~~~~~~~~~~

[root@centos ~]# vi /etc/samba/smb.conf

~~~~~[ configuration like this : ]~~~~



[global]
workgroup = pdc
netbios name = samba
encrypt passwords = Yes

; security level
security = user

; the domain and local master browser
domain logons = Yes
os level = 65
preferred master = Yes
domain master = Yes
local master = yes
wins support = yes
username map = /etc/samba/smbusers
name resolve order = wins bcast hosts

; automatically maps the home directory of the user
logon drive = q:

; loglevel
log level = 3

; users configure
add user script = /usr/sbin/useradd -m %u
delete user script = /usr/sbin/userdel -r %u
add group script = /usr/sbin/groupadd %g
delete group script = /usr/sbin/groupdel %g
add user to group script = /usr/sbin/usermod -G %g %u
add machine script = /usr/sbin/useradd -s /bin/false -d /var/lib/nobody/ %u
idmap uid = 15000-20000
idmap gid = 15000-20000

; sync smb passwords
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUnix\spassword:* %n\n *retype\snew\sUnix\spassword: %n\n .
passwd chat debug = yes
unix password sync = yes

; necessary share for domain controller
[netlogon]
path = /home/samba/netlogon
admin users = Administrator
valid users = %U
read only = no

; home configuration
[homes]
comment = Home
valid users = %S
read only = No
browseable = No

; profile configuration
[profile]
path = /home/samba/profiles
valid users = %U
create mode = 0600
directory mode = 0700
writable = Yes
browsable = No

; share directory for all users
[allusers]
path = /home/shares/users
valid users = @users
force group = users
create mask = 0660
directory mask = 0771
writable = yes


: Make directory for Samba users

[root@centos ~]# mkdir -p /home/samba/netlogon
[root@centos ~]# mkdir -p /home/samba/profiles
[root@centos ~]# chown -R root:users /home/samba/
[root@centos ~]# chmod -R 755 /home/samba/
[root@centos ~]# mkdir -p /home/shares/users
[root@centos ~]# chown -R root:users /home/shares/users/
[root@centos ~]# chmod -R 775 /home/shares/users/

:: Make user system for login Samba

[root@centos ~]# useradd test -n -g users
[root@centos ~]# passwd test
Changing password for user test.
New UNIX password: [userpassword]
Retype new UNIX password: [userpassword]
passwd: all authentication tokens updated successfully.

:: Add and enable Samba users

[root@centos ~]# smbpasswd -a test
New SMB password: [passworduser]
Retype new SMB password: [passworduser]
[root@centos ~]# smbpasswd -e test
Enabled user test.
[root@centos ~]# smbpasswd -a root
New SMB password: [rootpasswordsamba]
Retype new SMB password: [rootpasswordsamba]
[root@centos ~]# smbpasswd -e root
Enabled user root.

:: Starting Samba service

[root@centos ~]# /etc/init.d/smb start
Starting SMB services: [ OK ]
Starting NMB services: [ OK ]

:: Enable Samba service on booting

[root@centos ~]# chkconfig –add smb
[root@centos ~]# chkconfig –level 345 smb on


...........................................................
service SMB and NMB are UP
checked the smb with "testparm"
load smb config files from /etc/samba/smb.conf
processing section "[netlogon]"
processing section "[home]"
WARNING: No path in service home - making it unavailable!
NOTE: Service home is flagged unavailable.
processing section "[allusers]"
Loaded services file OK.
Server role: ROLE_DOMAIN_PDC

------------------------------------
In service definition
[global]
....
...
..
[netlogon]
....
...

[home]
comment = Home
valid users = %S
read only = No
browseable = No
available = No

please help me out
 
Old 11-04-2010, 07:59 PM   #2
mesiol
Member
 
Registered: Nov 2008
Location: Lower Saxony, Germany
Distribution: CentOS, RHEL, Solaris 10, AIX, HP-UX
Posts: 731

Rep: Reputation: 137Reputation: 137
Hi,

not sure if there is a question. But the warning is self explainating

WARNING: No path in service home - making it unavailable!
NOTE: Service home is flagged unavailable.
processing section "[allusers]"

Add
Code:
path=SOME_WHERE_IN_MY_FILESYSTEM
to the Home section and the warning will be away.
 
Old 11-04-2010, 08:51 PM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,154

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
[homes] share is special whereas users home directories are automatically created for each user. It appears that [home] should actually be [homes].
 
Old 11-04-2010, 09:05 PM   #4
jerry21locke
LQ Newbie
 
Registered: Oct 2010
Posts: 3

Rep: Reputation: 0
You just hava to put a path to your home and check it of it is flagged because it cannot access your home if it is flagged.

Last edited by jerry21locke; 11-18-2010 at 07:37 PM.
 
Old 09-05-2013, 11:12 AM   #5
ktmariappan
LQ Newbie
 
Registered: Mar 2011
Posts: 6

Rep: Reputation: 1
WARNING: No path in service home - making it unavailable

Hi,

Please check if every line start from either # or ;.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS multi-homed: samba not work as PDC rotondo Linux - Server 1 07-21-2010 11:01 PM
CentOS PDC worm5252 Linux - Server 1 12-14-2009 10:08 PM
Centos 5.3 and Samba -- PDC joining XP clients nightmare brollyson Linux - Server 2 06-26-2009 05:05 PM
OK I am new to this. Need help with Centos and Samba PDC alwayslearning Linux - Newbie 0 04-02-2008 09:57 AM
samba pdc trust with windows 2003 server pdc samba_pk Linux - Networking 1 06-08-2007 02:22 AM


All times are GMT -5. The time now is 05:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration