LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 11-18-2004, 10:39 AM   #1
beatupbilly
Member
 
Registered: Jan 2004
Location: Pinr Lake, GA
Distribution: Slackware, LinuxMint, FreeBSD, Xandros, CentOS, Fedora Core, RedHat, Chakra, etc etc
Posts: 215

Rep: Reputation: 30
permissions glitch


I have an external hard drive(ntfs) and I can only access it through root. I tried changing the permissions(chmod 777 Backup(name of the drive)) It claims it is succesfully changed but permissions when I check are still set to 500. when I try to change permissions through gui it says I can't change permissions on a read-only disk(because it is ntfs). Buuut, I never set permissions to root on the drive to begin with. What is going on? It is a removable disk and this shouldn't happen. Driving me crazy. Recommendations?
 
Old 11-18-2004, 11:16 AM   #2
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
Perhaps you should look at your fstab file first (/etc/fstab). I have an ntfs partition (not external) and here is my entry in that file for it.
Code:
/dev/hda1   /mnt/windows   ntfs    users,owner,ro,umask=000 0 0
You probably won't be able to get 777 as your permissions. Since it is NTFS you'll probably just get 555 (which is read and execute for all) unless you are using one of the projects that allows full NTFS reading.
 
Old 11-18-2004, 11:30 AM   #3
beatupbilly
Member
 
Registered: Jan 2004
Location: Pinr Lake, GA
Distribution: Slackware, LinuxMint, FreeBSD, Xandros, CentOS, Fedora Core, RedHat, Chakra, etc etc
Posts: 215

Original Poster
Rep: Reputation: 30
here is my etc/fstab. Not sure where to change permissions here. my dev's are mounted at sda, sda1, sda2:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/1 / ext3 defaults 1 1
LABEL=/boot1 /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
LABEL=SWAP-hda2 swap swap defaults 0 0
/dev/sda2 /media/Backup_2 ntfs pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0
/dev/sda1 /media/Backup ntfs pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0
/dev/hdb /media/cdrom auto pamconsole,fscontext=system_u:object_r:removable_t,ro,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0
 
Old 11-18-2004, 11:45 AM   #4
beatupbilly
Member
 
Registered: Jan 2004
Location: Pinr Lake, GA
Distribution: Slackware, LinuxMint, FreeBSD, Xandros, CentOS, Fedora Core, RedHat, Chakra, etc etc
Posts: 215

Original Poster
Rep: Reputation: 30
Nevermind I just added your user script to mine and it works now! Thanks!
 
Old 11-18-2004, 11:51 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
For non-linux file systems, you can't use the chmod command on the mounted partition. Instead, the same information needs to be included in the mount command. Read the man mount before selecting the options that you want to use.

You can for instance, make yourself the owner (user) of the partition with the uid= options. So if your user number is 501, then using the option 'uid=501' will give you access. Also setting the group ownership with the 'gid=' option will allow you to control who may read files on the drive.
Because linux doesn't normally have write support for NTFS drives, using the 'fmask=' option for regular files and the 'dmask' option for directories makes more sense then using the 'file creation mask' since you won't be creating files on this parition in linux.

One final thing I should mention about the 'uid' and 'gid' options. You can use your username and groupname respectively. So if your userID is 501 and your username is 'beatupbilly', then the options: uid=beatupbilly,gid=users will make you the owner of the partition, and the group ownership is assigned to the 'users' group. This is what you would do instead of using the command chown beatupbilly:users /media/Backup.
 
Old 12-03-2004, 07:31 PM   #6
jeopardyracing
Member
 
Registered: Sep 2003
Posts: 175

Rep: Reputation: 30
Mount Samba Shares on Mac

Maybe you can help me understand this problem: unless I am logged in as roon, even though I specify the username there directories on my Mac's Samba shares that can't be read or written. Only resources with "other" permissions can be read or written on the Mac.

I strongly suspect the following is the reason: while the username is the same on both machines, my primary username = UID 1000 in Knoppix (hard drive installed) but UID 501 on the Mac! I think that when I am logged in as root in KNoppix this distinction doesn't matter, but when when I am in the user account, the Knoppix PC isn't concerned that the username is the same on the Mac's files, it looks at the numeric UID and bases its permissions on that. But shouldn't it ignore the Mac's file permissions? Despite my having dmask=777 and fmask=777 in the fstab entry the Mac's directory permissions seem to govern. Any ideas as to why my dmask and fmask aren't working? I also tried umask=000 in a shell script and encountered the same problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install 1 m/c ok 2nd m/c glitch Mad Malc Debian 2 08-08-2005 02:53 AM
Knode Glitch SnowSurfAir Linux - Software 0 11-29-2004 07:55 PM
LQ Search glitch ppuru LQ Suggestions & Feedback 9 09-02-2004 09:31 AM
Is it a glitch? qulnxsh Linux - Software 1 04-28-2003 02:58 AM
a small glitch jayraj Linux - General 2 10-28-2002 03:32 AM


All times are GMT -5. The time now is 12:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration