LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-01-2004, 10:56 PM   #1
Joe47
Member
 
Registered: Dec 2002
Location: San Diego California
Distribution: Fedora Core 6
Posts: 64

Rep: Reputation: 15
lame mp3 encoding under Grip


I have Grip version 3.0.7 in Fedora Core 1. I downloaded lame but am still mot able to make mp3 files. Grip
rips but does not encode. . I really want to do this with Grip
not under the command line. Thanks
 
Old 05-01-2004, 11:13 PM   #2
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
what are your settings now (in grip config tab)?
 
Old 05-01-2004, 11:18 PM   #3
Joe47
Member
 
Registered: Dec 2002
Location: San Diego California
Distribution: Fedora Core 6
Posts: 64

Original Poster
Rep: Reputation: 15
I am using lame as my encoder & grip cdparinoia as my ripper.
 
Old 05-01-2004, 11:30 PM   #4
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
can you encode with lame from the command line? are you getting any error messages? how do you know it's not encoding? more info would probably help.
 
Old 05-02-2004, 01:59 AM   #5
Joe47
Member
 
Registered: Dec 2002
Location: San Diego California
Distribution: Fedora Core 6
Posts: 64

Original Poster
Rep: Reputation: 15
I don't know how to encode from the command line
I am not getting any error messages
All the files I generate when I rip & encode at the same time with Grip
are the same size no matter what the orgional cd track was.
I e-mailed a mp3 file from my Windows XP partition & it played on xmms with no problems.
None of the mp3 files I produce from Grip will play on that player, the player does nothing.
Under the encoder tab:
encoder command line: -h -b%b%w%m
encoder file format: ~/mp3/%A/%d/%n.mp3
It says lame is located @ /usr/bin/lame I manually looked for it there & found it.
I even tried e-mailing the mp3 files generated by Grip to my Windows XP partition
they would not play on that player.
 
Old 05-02-2004, 02:16 AM   #6
Joe47
Member
 
Registered: Dec 2002
Location: San Diego California
Distribution: Fedora Core 6
Posts: 64

Original Poster
Rep: Reputation: 15
http://www.nostatic.org/grip/doc/ar01s03.html#id2807954
I hope I did this correctly the above is an image from Grip the encode bar never when
I use lame unlike whe I use ogg & it does. Thanks for listening Joe47
 
Old 05-02-2004, 12:52 PM   #7
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
i think grip uses lame by default, and it looks like you have lame, so it *should* be working. (though "what should be" and "what is" are often two different things. ) let's go step by step.

first, rip a song from a CD. that should make a .wav file.

next, try to encode the .wav file from the command line. i believe the basic command is:

lame <file-to-encode.wav> <file-that-will-end-up-encoded.mp3>

(make sure you're in the directory of the .wav file, or add the directory path to the lame command.)

then we'll see if that works or not, or gives an error message.
 
Old 05-03-2004, 12:00 AM   #8
Joe47
Member
 
Registered: Dec 2002
Location: San Diego California
Distribution: Fedora Core 6
Posts: 64

Original Poster
Rep: Reputation: 15
A ripped .wav file encoded using lame in the command line.
So it does not seem to be lame.
 
Old 05-03-2004, 12:18 AM   #9
Joe47
Member
 
Registered: Dec 2002
Location: San Diego California
Distribution: Fedora Core 6
Posts: 64

Original Poster
Rep: Reputation: 15
synaptical
I just wanted to say thank you for your help Joe47
 
Old 05-03-2004, 01:04 PM   #10
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
the more i think about it, the more i wonder if this has anything to do with RH/Fedora licensing issues with mp3. i didn't think it would affect grip, but maybe it does.

a few suggestions:

- encode to .ogg instead
- encode with lame from command line
- remove fedora lame and grip .rpms and re-install from source
- ask if anyone has more distro-specific info at the Fedora forum

i hope you get it resolved, i really love using grip.
 
Old 05-06-2004, 01:58 AM   #11
Joe47
Member
 
Registered: Dec 2002
Location: San Diego California
Distribution: Fedora Core 6
Posts: 64

Original Poster
Rep: Reputation: 15
Do you think removing Grip & Lame would help & then reinstalling them ?
 
Old 05-27-2004, 10:28 PM   #12
wsims
LQ Newbie
 
Registered: May 2004
Distribution: Fedora Core 2
Posts: 4

Rep: Reputation: 0
Here is what I did which seemed to work. I am running Grip 3.07 on Fedora Core 2 so it should be similar to your situation. I do not believe that lame was installed by default and I suspect that it has something to do with patent or copyright issues. Had I thought about it I could have checked by typing 'lame -help' at the command prompt, but instead I just asumed that it was missing and downloaded lame from following location:

http://lame.sourceforge.net/download/download.html

I placed it in my home directory (/usr/local would probably have been better), unpacked and installed it with the commands:

tar xzvf lame-3.96.tar.gz
cd lame-3.96
./configure
make
su root
make install

Within Grip on the config tab I selected the encode menu and changed the encoder to 'lame'. The other options are as follows:

Encoder executable: /usr/local/bin/lame
Encoder command line: -h -b %b %w %m
Encode file format: ~/mp3/%A_%d_%n.mp3 (this puts in in a single directory called mp3 with no subdirectories)

It seems to work fine now. Good luck!

I do like ogg compression better and even went and purchased a HipZip for $40 thinking it would support that format. I haven't had any success yet so I am switching back to the bad ole MP3 format.
 
Old 07-26-2004, 08:45 AM   #13
silverstormboy
Member
 
Registered: Apr 2003
Location: Singapore
Distribution: Ubuntu 7.10 Gutsy
Posts: 32

Rep: Reputation: 15
Hi Wsims, Thank you very much for your post.

I have the same problem with ripperx and grip. I cant rip the CD to mp3. only after I installed manually lame following your instruction below, then it works both, ripperx and grip. Im using Debian anyway.

Thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grip/Lame MP3 Problem programx Linux - Software 4 11-26-2005 10:27 AM
mp3 isn't ripping in grip on fedora core 3 with lame installed dr_zayus69 Linux - Hardware 6 07-05-2005 10:00 AM
Problems encoding .mp3 using Grip 3.1.4 kyrthira Linux - Software 3 11-06-2004 08:08 AM
encoding using Grip+lame minm Linux - Software 4 08-09-2004 01:25 PM
encoding mp3 files with grip in Fedora Core 1 Joe47 Fedora 1 04-18-2004 05:09 AM


All times are GMT -5. The time now is 08:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration