LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 09-03-2006, 08:20 PM   #1
hitlar
LQ Newbie
 
Registered: Nov 2005
Location: muzaffarpur
Posts: 27

Rep: Reputation: 15
is another file for display instead of xorg.conf


is xorg.conf responsible for measuring the complete behaviour of screen at boot time, if any other file then which. My default depth 24 & mode 1024*768. when i boot system sometime desktop screen doesn't fit into moniter space area therfore see all desktop by mouse move up & down, left & right . My xorg.conf is

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LG StudioWorks 55i"
DisplaySize 280 210
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 54.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel Corporation 82865G Integrated Graphics Controller"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 09-07-2006, 08:23 PM   #2
hollywoodb
Member
 
Registered: Aug 2003
Location: Minnesota, U.S.A.
Distribution: Debian, openSUSE
Posts: 400

Rep: Reputation: 30
your xorg.conf looks fine to me, so I'm not sure why you're getting this behaviour.

One thing you can do is add
Code:
xrandr -s 1024x768
to your desktop's startup programs, which will set the display resolution to 1024x768 everytime your desktop (be it KDE/Gnome/XFCE/etc) starts.


Every once in a while I find a game that changes the screen resolution and doesn't change it back on exit, leaving me with the behaviour you described. Is it possible something else is running that would mess up your resolution?

Last edited by hollywoodb; 09-07-2006 at 08:25 PM.
 
Old 09-07-2006, 11:05 PM   #3
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
change

VertRefresh 50.0 - 90.0

to

VertRefresh 60.0

That'll fix it (probably)
 
Old 09-08-2006, 09:31 PM   #4
hitlar
LQ Newbie
 
Registered: Nov 2005
Location: muzaffarpur
Posts: 27

Original Poster
Rep: Reputation: 15
Hi hollywoodb i doning this behaviour due display error comes in desktop, when display mode select 85 refresh rate automatically after boot then desktop doesn't fit into moniter area after then i can't perform any work & my job hampered. by default my option is 1024*768 at 60 hz but it select sometimes 1024*768 at 85 hz. in diaplay dialoug refresh rate show only one option either 85 or 60 hz then how will change . no any option at that time except reboot & wait util it trues(e.g. select default mode).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Display (xorg.conf Settings) slash587 Linux - Software 3 02-20-2006 11:25 PM
/etc/X11/xorg.conf and KDE display don't match garyozzy Slackware 14 01-02-2006 02:59 PM
xorg.conf for Laptop & external display. Riddick Linux - Software 11 12-03-2005 04:24 PM
Need xorg.conf for 1280x800 Compaq R3000Z display Gates1026 Linux - Laptop and Netbook 6 03-26-2005 08:09 AM
Altering xorg.conf to change mice doesn't work or disables display alex_denner Linux - Laptop and Netbook 3 02-06-2005 07:10 PM


All times are GMT -5. The time now is 09:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration