LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 02-06-2005, 08:14 AM   #1
alex_denner
LQ Newbie
 
Registered: Nov 2004
Posts: 6

Rep: Reputation: 0
Altering xorg.conf to change mice doesn't work or disables display


I have a bit of a problem. I have a Synaptics Touchpad installed in my laptop, but I want to use a standard PS/2 mouse instead. I posted a query on how to do this; and was directed to another thread (that I can't post a link to; I need to post more posts!).

So, I followed the instructions and nothing happened. After reading through several more posts and trying out the various suggestions within (below) the most benign effect was to disable the pointer on the screen; so that it was immovable by either the touchpad or the PS/2. The slightly more worring thing that happened with other alterations was that the display simply blacked out after getting to the startup bit with Fedora Core 3, where most of the Runlevel 5 stuff loads (normally) in the graphical display. This is without me changing anything in the display sections of xorg.conf.

Something odd is that I think my system knows the PS/2 mouse is there, it just won't do anything. Whether my computer is working normally with the touchpad, whether both are disabled, or whether the display goes, I think this is true; my laptop is running laptop-mode and, whenever I jiggle the PS/2 mouse, the hard drive spins-up if it is an idle state despite there being no pointer movement.

What I've tried with xorg.conf...
* I tried changing /dev/input/mice to /dev/input/mouse and /dev/mouse0 (all are present) under the mouse0 InputDevice section (did nothing)

* I changed, under ServerLayout, the settings from "disabled" to "AlwaysCore" to "CorePointer" for mouse0 and Synaptics, in different combinations: some combinations froze the pointer (e.g. both to "CorePointer"); some disabled the display (e.g. mouse0 to "CorePointer" + Synaptics to "disabled"). I should point out that I've tried using the settings given in various threads on LinuxQuestions and obtained via web-searches, and none of them have worked

* when I still had the Synaptics package installed, I tried setting "TouchpadOff" to "Yes" and "GuestMouseOff" to "No"; this disabled the display

Other things...
* I have uninstalled the Synaptics package that includes synclient; and altered the xorg.conf file by placing #s in front of all references to it. The touchpad now seems to be using the standard drivers. If I need to re-install it to get things to work right, I will.

* I have tried using system-config-mouse, and swapping drivers (from whatever to the standard two-button PS/2 option with three-button emulation), but this does nothing.

* I cannot simply disable my touchpad in BIOS, as my system does not support this option.

My laptop is a Compaq Presario 1200XL-122, running Red Hat Fedora Core 3 (kernal v. 2.6.9-1.667).

I hope someone can help,
alex_denner.

Here's my xorg.conf file as it currently stands...
Code:
# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen         "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
#	InputDevice    "Synaptics" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
#	Load  "synaptics"
	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "gb"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

#Section "InputDevice"
#	Identifier  "Synaptics"
#	Driver      "synaptics"
#	Option	    "Device" "/dev/input/mice"
#	Option	    "Protocol" "auto-dev"
#	Option	    "Emulate3Buttons" "yes"
#	Option      "SHMConfig" "on"
#	Option      "TouchpadOff" "yes"
#	Option      "GuestMouseOff" "no"
#EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Unknown monitor"
	HorizSync    31.5 - 37.9
	VertRefresh  50.0 - 70.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "trident"
	VendorName  "Videocard vendor"
	BoardName   "Trident CyberBlade (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
 
Old 02-06-2005, 03:08 PM   #2
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
You may want to try the "Auto" setting for the "Protocol". In my xorg.conf file, it mentions something to this effect.

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

# Option "Protocol" "Auto"

# The available mouse protocols types that you can set below are:
# Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
# Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
# MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
# ThinkingMouse ThinkingMousePS/2 Xqueue

I also have a laptop with the synaptics touchpad and mine is set to "PS/2". This works for the touchpad, the little joysticky thing, and a mouse plugged into the PS/2 port. Additionally, I have a sym link from /dev/mouse -> /dev/psaux. I am not running FC3, but I am running on the 2.6 kernel.
 
Old 02-06-2005, 07:50 PM   #3
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Only way I could get the toucpad and mouse to work when both are present was to recompile the kernel with ps/2 as a module rather than compiled into the kernel and modprobe psmouse in rc.local. Possible a bit extreme and someone got a better answer but it worked for me.
 
Old 02-06-2005, 08:10 PM   #4
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
IMPS/2 can sometimes wreak havoc with laptops. try PS/2 instead:

Code:
Section "InputDevice"

# Identifier and driver

    Identifier "Mouse0"
    Driver     "mouse" 
    Option "Protocol"    "PS/2"
    Option "Device"      "/dev/psaux"
    Option "ZAxisMapping"      "4 5"

p.s. keep Mouse0 (or whatever name you're using) as CorePointer in the ServerLayout section, and only have one mouse entry there, at least until you have it working (ie., keep InputDevice Synaptics commented out).

Last edited by synaptical; 02-06-2005 at 08:16 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3 keyboard layouts in xorg.conf doesn't work VMM Linux - Newbie 3 11-10-2009 06:43 PM
xorg.conf for Laptop & external display. Riddick Linux - Software 11 12-03-2005 05:24 PM
Use 2 Mice with xorg? nicedreams Linux - General 3 10-24-2005 12:26 AM
Need xorg.conf for 1280x800 Compaq R3000Z display Gates1026 Linux - Laptop and Netbook 6 03-26-2005 09:09 AM
How to correctly change resolutions under fedora core 2 with xorg.conf? Braveheart1980 Linux - General 8 10-08-2004 07:44 PM


All times are GMT -5. The time now is 01:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration