LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 06-12-2007, 08:45 AM   #1
JoeLinux117
Member
 
Registered: Mar 2007
Location: Miami, FL
Posts: 30

Rep: Reputation: 15
Firefox Cookies Option Unchecks Itself on Fedora 7 or FC6


To Anyone Willing To Help:

I'm currently running Fedora 7 (2.6.21) on an Intel-based laptop (i686) with Firefox 2.0.0.4. I'm having an issue where, in the Preferences dialog in Firefox, I have to constantly re-check the "Accept cookies from sites" checkbox in order to log in to pages on the web (including this one), because it randomly (or, seemingly random) unchecks itself. I haven't heard of anyone else having this problem before (maybe once, but with no solution). It is very annoying to keep re-checking the box everytime I want to login somewhere, or having to re-login when the box unchecks itself and I lose the session cookies for certain sites. This started happening when I upgraded to kernel 2.6.20 on FC6, and has been happening ever since.

Because it began happening concurrently with the upgrade to the 2.6.20 kernel, I am led to believe that a certain system setting (or settings) has changed that changes my Firefox preferences back to original. So far, the "Accept cookies from sites" option is the only one that I have noticed. Someone please help!

--Joe
 
Old 06-13-2007, 01:54 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Basically, everyone leaves that unchecked. Instead you set the website in "exceptions". This is the preferred way to do this, because of the ubiquity of malicious cookies.

Thus I feel somewhat uneasy at the thought of helping you accept cookies globally. Similarly, you should be running the noscript extension.
 
Old 06-14-2007, 12:54 PM   #3
JoeLinux117
Member
 
Registered: Mar 2007
Location: Miami, FL
Posts: 30

Original Poster
Rep: Reputation: 15
What's The Difference?

I always leave the box unchecked. My problem was that the other day I was going through an unnamed corporation's website, and after I logged in and was doing some tasks that I needed at the moment it was redirecting me through different domains, and I needed the tasks done immediately. So, instead of taking the time to add all of the different domains to the "Exceptions" section, and/or accepting cookies on the fly for every different domain, I instead checked the box (because I knew the sites I was going through were safe) so that I could get my job done as soon as humanly possible (because the need was incredibly immediate).

The problem here is that it kept unchecking itself, and I didn't ask it to. I don't care if it's unsafe and I shouldn't do that, 99.9% of the time I don't. The issue is that I am seeing an action being performed that I didn't ask my system to do (unchecking the box), and I don't want that to happen.

Quite frankly, the fact that you think this operation is unsafe is irrelevant to my problem. Microsoft thinks that disabling my firewall in Windows XP is unsafe, but I certainly do it anyway, and I could care less if Microsoft disagrees.

Thank you for your concern about my safety, Simon Bridge, but I still would like to figure out why this is happening, and how to fix it.

--Joe
 
Old 06-15-2007, 06:23 AM   #4
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
OK... fairynuff.

Looking around says that this is not something that gets complained about.
Experimenting shows that this isn't happening to me using Firefox 2.0.0.4 under Ubuntu Feisty.

What is the "keep until" setting?
Have you tried "ask me every time"?

Check other privacy settings, do you have you private history cleared when you close FF? (Not that it should matter.)

However, unable to duplicate the effect means cannot usefully help. If you can get it to happen repeatedly, then a survey of the settings can shed light... or is their a page which resets the setting when you visit.
 
Old 06-15-2007, 12:26 PM   #5
JoeLinux117
Member
 
Registered: Mar 2007
Location: Miami, FL
Posts: 30

Original Poster
Rep: Reputation: 15
Well, funny you should mention the "culprit webpage". In fact, I've noticed that this happens at random mostly, but for some reason unknown to me, it also unchecks itself every time I am on www.gnome-look.org and I happen to go to the 2nd (or 3rd, 4th, 5th, etc.) page of results. Very weird. Maybe I should just accept this behavior and move on, lol.

--Joe
 
Old 06-29-2007, 11:32 PM   #6
kuripot
LQ Newbie
 
Registered: Feb 2007
Posts: 1

Rep: Reputation: 0
I had the same problem using firefox (bon echo) 2.0.0.4 on Archlinux. Cookies were always off on restart resulting in me having to re-login to many sites. You might want to check your extensions to see if you have one that manipulates cookies in any way. I solved my problem by disabling an extension called Stealthier. Disabled it and cookies are back on! If you go into the preferences for Stealthier you can uncheck the cookies option if you want to keep Stealthier enabled. Hope this works for you!
 
  


Reply

Tags
checkbox, cookies, firefox, mozilla, preferences


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Google Not Installing Third Party Cookies -- It's Firefox ... LXer Syndicated Linux News 0 01-24-2006 11:03 PM
Where does lynx or firefox store cookies? stormrider_may Linux - Software 3 01-23-2006 06:00 PM
Konqueror / FireFox Cookies Vampir3 Linux - Software 4 12-16-2005 06:49 PM
modifying cookies in firefox pepisfree Linux - Software 2 08-25-2004 05:35 AM
mozilla firefox and cookies wrongman Linux - Software 1 05-11-2004 06:03 AM


All times are GMT -5. The time now is 09:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration