LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-13-2006, 11:18 PM   #1
panchito25
LQ Newbie
 
Registered: Dec 2006
Location: Illinois
Distribution: FEDORA CORE 6
Posts: 10

Rep: Reputation: 0
Fedora Core 6 halts after installation and restart


Hi everyone,

I am a new member of this forum and I would like to share a problem after installing Fedora Core 6 on my Pentium 4 computer. Here are the details:

1. Succesfull boot from media (CD-R ISO images)
2. All media passed "Media Test"
3. Succesfull installation of Fedora Core 6 (I intalled basic packages; in other words, only disk 1 and disc 2)
4. Installation was performed on a Pentium 4 2.8GHz, 800 MGhz FSB, HT processor, 1 GB DDR333 RAM, 160GB Hard Disk, audio card, nvidia graphics card, optical mouse, generic keyboard, and D-link PCI wireless card.
5. After the installation, the installer program asks to reboot.
6. The computer boots to Fedora. A screen showing details appears.
7. Everything seams to go well until the system halts after the following line: starting sshd [ok]
starting sendmail


I tried 5 times to install Fedora in my computer, but this issue occurs everytime at the same line. What is happening or what am I doing wrong? I also notice that anaconda installs kernel i586 instead of i686. How can I solve this problem?

There is also the following error while starting Fedora (first boot, at the screen that shows all the detail ):

FATAL: Error incerting acpi_cpufreq(/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device

Any thought regarding this error? The Bios program on my computer has many options to enable or disable CPU features such as HT, Stepping, Frequency, etc. Perhaps I have to disable something here?

I hope I gave as much detail as I could regarding the problem I am having installing Fedora. I am very frustrated and I really appreciate any help. Thanks in advance for your colaboration.

Francisco
 
Old 12-14-2006, 01:44 AM   #2
jlo_sandog
Member
 
Registered: Jul 2005
Location: USA
Distribution: F10 (x86_64)
Posts: 549

Rep: Reputation: 31
Add acpi=off to your boot loader. The kernel issue is answered here
http://fedoraproject.org/wiki/Bugs/FC6Common
 
Old 12-14-2006, 11:19 PM   #3
panchito25
LQ Newbie
 
Registered: Dec 2006
Location: Illinois
Distribution: FEDORA CORE 6
Posts: 10

Original Poster
Rep: Reputation: 0
Dear Friend,

Many thanks for your quick answer. However, I am afraid I'm going to need more help. I am not very Knowledgeable about Linux, except a course I had to take in college about Red Hat 7.2. So excuse my ignorance. How do I edit the boot loader GRUB to add acpi=off? Do I have to edit it before installing Fedora Core 6 or after it has been installed and first time booted? Regarding the fix for the kernel; I read the article, but I have no clue where to start from. Could you be so kind to let me know where can I find the steps please?

Thanks again for you help, and have a great day!

Francisco
Linux rock! :-)
 
Old 12-15-2006, 06:56 AM   #4
live_dont_exist
Member
 
Registered: Aug 2004
Location: India
Distribution: Redhat 9.0,FC3,FC5,FC10
Posts: 257

Rep: Reputation: 30
Hi Panchito,
I think what jlo_sanddog meant was to add the line
acpi=off into the file /etc/grub.conf

Grub is a Linux bootloader and each time Linux boots it looks into /etc/grub.conf. Adding acpi=off into this file will stop acpi drivers from loading up at start up.

However you might want to try this out.

The starting Sendmail problem is a very common problem and specially frustrating for new users . I've seen machines hang for even more than 5 minutes at sendmail. Sendmail is a service installed by default on most Linux systems. Follow this to disable sendmail:

1.Get to the bootloader screen where you come to the Fedora Core 6 screen where you hit Enter and proceed and Linux starts booting up.

2.Select the menu and hit "a".

3.Now hit spacebar and type "single" and hit "Enter"

4.Linux will boot up into and eventually give you something like bash#

5.Type chkconfig sendmail off and hit enter

6.Hit Ctrl + D till Linux reboots

Post back if something works after doing this or if you need more help.All the best.

Cheers
Arvind
 
Old 12-15-2006, 02:10 PM   #5
panchito25
LQ Newbie
 
Registered: Dec 2006
Location: Illinois
Distribution: FEDORA CORE 6
Posts: 10

Original Poster
Rep: Reputation: 0
Dear friend Arvind,

Many thanks for your response. I'll follow the steps you suggested and I'll let you know if it works. However, it is still necessary to edit GRUB (acpi=off)? I so, do I edit it after installation or before it? It might be a stupid question, but I am fairly new to the Linux world. I am a Windows user, but I am tired of its unstable kernel.

Francisco
Latino Linux
 
Old 12-17-2006, 12:15 AM   #6
live_dont_exist
Member
 
Registered: Aug 2004
Location: India
Distribution: Redhat 9.0,FC3,FC5,FC10
Posts: 257

Rep: Reputation: 30
You might want to try what I suggested before putting acpi=off. If what I said doesnt work then acpi=off might be needed.

Keep posting whenever you get stuck.

Cheers
Arvind
 
Old 01-07-2007, 06:37 PM   #7
nperrins
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Rep: Reputation: 0
Hi Guys,

Just thought my experiences might be of interest.

I see this same hang of sendmail when I've set up a Fedora 5 ... after I have changed the network card(s) or if I change the network settings on the cards.

The system can be made to go in by choosing the interactive startup and not starting up the network cards. Everything works fine - even sendmail.

So, the next thing I tried was reconfiguring the network cards (probe for the mac addresses and try setting up with static IPs etc.). Set up the routing and check with netstat -r. Everything appears fine. Reboot. Exactly the same problem!

Next, I go through the whole thing again and check the ifcfg files (/etc/sysconfig/networking/devices). Nothing untowards. Still the same problem on reboot.

I didn't want to lose sendmail, but I don't really need it, so I turn it off. Bingo, everything boots up quickly, the start up says eth0 and eth1 came up....but the ethernet cards are not activated. (Why, I have no idea. I tried configuring and rebooting twice).

So, I thought I'd get clever with it. I added the line '/etc/rc.d/init.d/network restart' into my rc.local file. What do you know, everything starts quickly and just as it is about to get to the GUI login, the rc.local kicks in and everything comes to a grinding halt again. (Things like Konsole take about 2 minutes to come up).

I'm not a newbie (you've probably guessed) but I'm not an old-hand either. It really smells to me that the kernel does not like having the network cards changed. Some security thing or configuration file somewhere? (Oh forgot to mention, Ipsec and SELinux are both off - I use an IPtables firewall and turning this off has no effect).

What would be nice, would be to try and re-install my network cards but for the life of me, I cannot find a "Hardware" icon on Fedora Core 5. Is there one? Is there a command-line method? kudzu seemed to do nothing.

This is the first real problem I've had with RedHat/Fedora in years. I did see someone suggested re-installing sendmail. I don't buy this, my sendmail is disabled and the underlying problem still exists. The only other answer I saw was Fedora Core 6. Seems drastic to me.
 
Old 01-08-2007, 11:06 AM   #8
panchito25
LQ Newbie
 
Registered: Dec 2006
Location: Illinois
Distribution: FEDORA CORE 6
Posts: 10

Original Poster
Rep: Reputation: 0
Hi everyone!

I was out of town for the Holydays and didn't have much time to post anything; sorry about that.

Arvid, your suggestion didn't work and after trying several times to install Fedora Core6, I decided to quit the installation. I am a NEWBIE in the Linux world, so I need to investigate and read more literature about it before I decide to install Linux again.

As per nperrins post, it seems like the "Sendmail" issue is not just occurring on Fedora Core6, but also on Fedora Core5. Any comments??

Somebody suggested me to try Suse linux. Any suggestions?? I have all the 5 FEDORA CORE6 CDs, and would hate to waste them if I can't use them. Any help or advise would be really appreciate it.

Francisco

 
Old 01-31-2007, 07:34 AM   #9
johnnylinux
LQ Newbie
 
Registered: Jul 2006
Posts: 7

Rep: Reputation: 0
Smile swicth off internet connection

try switching u modem off. i had this problem installing fedora 6 on a few computers. if it boots up then use a terminal to disable it. don't give up!!
 
Old 02-01-2007, 07:50 PM   #10
panchito25
LQ Newbie
 
Registered: Dec 2006
Location: Illinois
Distribution: FEDORA CORE 6
Posts: 10

Original Poster
Rep: Reputation: 0
I don't have a modem but a wireless pci card. The main problem is on the "sendmail" line. Somebody suggested to edit GRUB and add acpi=off. HOwever, I have no clue how to do it. Please advise.

Francisco
 
Old 02-01-2007, 08:58 PM   #11
scm86
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora Core 5 2.6.16-1.2133_FC5smp
Posts: 96

Rep: Reputation: 15
I have had a similar problem, actually it seems like the same exact one. Started when I upgraded (via yum) to 2.6.17 kernel under FC5, and continued on a vanilla install of FC6.

Never really figured out what it was, but booting into the older kernel worked on FC5. For FC6, I chose the Xen option, and I am running FC6 right now, and gkrellm tells me its been that way for 9 days 12 hrs straight.

If you are willing to re-reinstall FC6, I would be curious if this works for you as well.

As for the acpi thing, shamelessly stolen from FedoraForum.org:

Code:
1) Boot with your Fedora Core Installation CD 1.

2) Type "linux rescue" at the prompt.

3) Answer the questions about keyboard and language.

4) Tell the rescue mode to use your proper partition to mount (the one that you want to get booted into)

Choose Continue

(Don't choose Cancel or Read Only) because you want to edit grub.conf

5) When you come to the console prompt type:

sh-2.05# chroot /mnt/sysimage

6) Edit your grub.conf with nano, type:

sh-2.05# nano /boot/grub/grub.conf
At the end of the line that mentions vmlinuz, append the acpi=off . Then save, exit, remove cd, reboot. Might not be a bad idea to procure a rabbits foot or cross your fingers.
If you don't know how to use nano, do: man nano first.

Hope that one of these helps,

Scott McNeely
 
Old 02-02-2007, 09:02 AM   #12
johnnylinux
LQ Newbie
 
Registered: Jul 2006
Posts: 7

Rep: Reputation: 0
hi! to disable sendmail do the the following:

1. Boot up your computer
2. When the blue screen appears (grub), hit Enter
3. Press the 'a' button, then space bar. Now type 'single' and hit the enter button
4. bash# will appear. Now type:

chkconfig sendmail off

5 Crt + D will reboot your system.

This worked for me!!
 
Old 02-02-2007, 10:41 AM   #13
panchito25
LQ Newbie
 
Registered: Dec 2006
Location: Illinois
Distribution: FEDORA CORE 6
Posts: 10

Original Poster
Rep: Reputation: 0
Ok, I'll go ahead and give it a try following your suggestions scm86 and johnnylinux. I'll post any errors or problems I'll come across with. Many thanks for your help.

Francisco

 
Old 02-02-2007, 12:59 PM   #14
scm86
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora Core 5 2.6.16-1.2133_FC5smp
Posts: 96

Rep: Reputation: 15
Just in case it does work, let us know too. This serves two purposes, one, it lets others see the fix, two, if the xen thing is what fixes it, maybe we can compare specs on our systems and see whats goin on.

Scott McNeely
 
Old 02-02-2007, 06:00 PM   #15
panchito25
LQ Newbie
 
Registered: Dec 2006
Location: Illinois
Distribution: FEDORA CORE 6
Posts: 10

Original Poster
Rep: Reputation: 0
Success guys!! appending acpi=off and senmail off fixed the problem. I append sendmail off first and then acpi=off. Fedora booted and is now working!! The question now is how do I configure my graphics card, sound card, and pci wireless card.

Detail are below:

Graphics: Nvidia GeforceFX 5600
Sound card: 5.1 channel CMI 8738 chipset
Wireless: DWL-G510

Many thanks to all of you for your help.

Francisco
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can you restart sound in Fedora Core 6? natewlew Fedora 5 10-24-2009 10:48 PM
NIC Inactive when I restart my Fedora Core 5 computer maheshmahajan Linux - Networking 1 08-24-2006 09:46 AM
can I stop an install and restart it? Fedora core 2 joehappy Fedora - Installation 2 01-12-2006 10:03 AM
Fedora Core 2 wont restart Scoobsky Linux - Software 7 11-03-2005 12:39 PM
Fedora Core network install halts on signal 15 alke Fedora - Installation 1 02-15-2004 12:37 PM


All times are GMT -5. The time now is 09:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration