LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-28-2006, 07:16 PM   #1
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Rep: Reputation: 30
Can you restart sound in Fedora Core 6?


Is there a way to reload the sound system in FC6? I have always had trouble with my sound card. It doesn't matter what Distro I use. Sometimes I have to reload or restart alsa a couple of times before my sound will work. I can't find an alsasound in /etc/init.d. Is there a script I could put in there or is there another way to restart the sound system?
 
Old 10-28-2006, 11:26 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 327Reputation: 327Reputation: 327Reputation: 327
To reset a hardware device manually, you need to remove and re-install the driver. This can be done dynamically on the modular Fedora kernel. Take a look at /etc/modprobe.conf for the sound driver. There will usually be an entry like:

alias snd-card-0 snd-intel8x0

To reset the driver then:

modprobe -r snd-intel8x0
modprobe snd-intel8x0
 
Old 10-29-2006, 01:01 AM   #3
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Thanks for getting me started but I did that and when I try to play a song with amarok it says "xine was unable to initialize any audio drivers.".

Here is my /etc/modprobe.conf
Quote:
alias eth0 ne2k-pci
alias snd-card-0 snd-ens1371
options snd-card-0 index=0
options snd-ens1371 index=0
remove snd-ens1371 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-ens1371
Here is what I did:
Quote:
[root@localhost init.d]# /sbin/modprobe -r snd-ens1371
[root@localhost init.d]# /sbin/modprobe snd-ens1371
Here is what I get from dmesg:
Quote:
cannot find the slot for index 0 (range 0-0)
ENS1371: probe of 0000:00:0d.0 failed with error -12
gameport: kgameportd exiting
cannot find the slot for index 0 (range 0-0)
ENS1371: probe of 0000:00:0d.0 failed with error -12
When I start my computer I always know when my sound doesn't work when my gnome sound has a red x and says "microphone muted". When I right click and select preferences I only have an option for my usb mic.
Thanks for your help!
 
Old 10-29-2006, 09:15 AM   #4
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 327Reputation: 327Reputation: 327Reputation: 327
It's seems like flaky/non-spec compatible hardware. You can try unloading and reloading until it works, Or just pick up a new sound card for $10 and disable your onboard sound in the BIOS.
 
Old 10-29-2006, 12:11 PM   #5
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Its a sound blaster pci. I don't have any onboard sound. I understand what your saying but I have always got it to work before. On FC5 I used a ccrma kernel and it install an alsasound in the /etc/init.d. I don't think they make one for FC6.
 
Old 10-24-2009, 10:48 PM   #6
pr0t0s
LQ Newbie
 
Registered: Oct 2009
Posts: 2

Rep: Reputation: 2
Cool modprobe trick worked! thanks. accept a forloop in return:)

Quote:
Originally Posted by macemoneta View Post
To reset a hardware device manually, you need to remove and re-install the driver. This can be done dynamically on the modular Fedora kernel. Take a look at /etc/modprobe.conf for the sound driver. There will usually be an entry like:

alias snd-card-0 snd-intel8x0

To reset the driver then:

modprobe -r snd-intel8x0
modprobe snd-intel8x0
Wonderful Idea! this worked for me. I had multiple aliases for sound on my Fedora Core 10 system. Some for alsa, some oss. So I just wrote a small for loop to reset all.

for i in `seq 13`; do modprobe -r sound-service-*-${i}; done
for i in `seq 13`; do modprobe sound-service-*-${i}; done

By the way, my origial issue was the my sound would go off after 1-2 days of system staying up (who shuts down a linux system). A reboot would get the sound back, it was really irritating to not get sound every now and then.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 5 with Sound Blaster NX USB driver fails to sound maybi7 Linux - Hardware 1 10-26-2006 03:31 PM
NIC Inactive when I restart my Fedora Core 5 computer maheshmahajan Linux - Networking 1 08-24-2006 09:46 AM
can I stop an install and restart it? Fedora core 2 joehappy Fedora - Installation 2 01-12-2006 10:03 AM
Fedora Core 2 wont restart Scoobsky Linux - Software 7 11-03-2005 12:39 PM
Sound Card on Fedora Core 2 only playing test sound silverado0103 Linux - Hardware 0 07-29-2004 03:23 PM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration