LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 07-18-2007, 02:50 PM   #1
Ezplan
Member
 
Registered: Dec 2003
Location: MA
Distribution: CentOS 5, Linux Mint
Posts: 58
Blog Entries: 1

Rep: Reputation: 15
Disable network from rescue


I have 2 nics on the motherboard, only 1 configured. I'm having trouble booting and it seems to crash when starting networking. I want to disable networking from starting during normal boot. I can get to "linux rescue" from the Fedora Core 6 install disk. How would I make changes to the normal boot to prevent network from starting while in rescue?

BTW - I'm pretty sure it's the nic because when going into linux rescue it asks if I want to start networking. If I answer "yes" then rescue crashes. If I answer "no" rescue starts and functions fine.

Thanks for any help!
 
Old 07-18-2007, 04:16 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by Ezplan
I have 2 nics on the motherboard, only 1 configured. I'm having trouble booting and it seems to crash when starting networking. I want to disable networking from starting during normal boot. I can get to "linux rescue" from the Fedora Core 6 install disk. How would I make changes to the normal boot to prevent network from starting while in rescue?

BTW - I'm pretty sure it's the nic because when going into linux rescue it asks if I want to start networking. If I answer "yes" then rescue crashes. If I answer "no" rescue starts and functions fine.

Thanks for any help!
Well if only using the one nic the easiest solution is going into the BIOS and disabling the nic that is not being used alternatively when having chosen the not start from the rescue mode put the module that is used by the second one in either the hotplug or udev blacklists respectively depending on which of those you use and it should not be loaded during your normal boot.
 
Old 07-19-2007, 12:16 PM   #3
Ezplan
Member
 
Registered: Dec 2003
Location: MA
Distribution: CentOS 5, Linux Mint
Posts: 58
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Thanks for the reply!

I ended up cd'ing from the "rescue prompt" to /mnt/sysimage where the rescue CD mounts the existing linux unstall. Then cd to /etc/sysconfig/networking/devices and edited the ifcfg-eth0 and ifcfg-eth1 files to read "ONBOOT=no". Then to /etc/sysconfig/network-scripts and did the same edit to the ifcfg-ethX files there.

Exited the rescue mode an upon re-boot I was able to get in to the linux installation. Checked the network settings and sure enough both devices were inactive.

Thanks again!
 
  


Reply

Tags
at, boot, linux


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot Fedora Rescue CD over Network theooze Fedora - Installation 2 10-26-2006 02:45 PM
enable/disable network card blackzone Linux - Networking 5 07-05-2006 10:24 PM
How to disable network-build? drmjh Linux - Networking 1 07-24-2005 10:22 AM
disable network connection on boot hraposo Debian 1 10-22-2004 11:02 AM
how do i disable my network card ? lenseboy Linux - Networking 2 07-03-2004 01:31 PM


All times are GMT -5. The time now is 09:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration