LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-07-2004, 04:50 PM   #1
madian
LQ Newbie
 
Registered: Aug 2003
Location: dubai
Posts: 2

Rep: Reputation: 0
alsa mixer


first i want to thank you all
i have a problem with alsa configuration
every time the channels is muted at startup , i have change that and do the
/usr/sbin/alsactl store
but it is muted back every time
 
Old 02-07-2004, 07:51 PM   #2
deloptes
Member
 
Registered: Feb 2004
Location: AT
Distribution: debian etch and SUSE 10.2
Posts: 123

Rep: Reputation: 15
What was important to do is run after installation from the shell following lines - that actually unmuted the alsa-driver
# amixer set Master 100 unmute
# amixer set PCM 100 unmute
# amixer

starting alsamixer didn't unmute

now after this I added some stuff like this below in /etc/modules.conf (Oh, my god, debians conf area! Don't warry it worked!)
I got the output from another program called alsaconf (you find it under $PREFIX/sbin)
If you have devfs (i.e. distros like mandrake and redhat use it as far as I know), then there are different files to modify, consult the docs.

#
## ALSA portion
alias snd-card-0 snd-emu10k1
## If you have more than one, add:
## alias snd-card-1 snd-intel8x0
## alias snd-card-2 snd-ens1370
## OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

I think it's better to start experimenting with kernel higher than 2.5 as alsa can be compiled from within the kernel

Hope I could help
 
Old 02-08-2004, 06:48 AM   #3
madian
LQ Newbie
 
Registered: Aug 2003
Location: dubai
Posts: 2

Original Poster
Rep: Reputation: 0
thanks ,but i have unmuted the card with gnome alsa mixer
and it works fine the only problem is every startup it is muted again and i have to use the mixer every day
 
Old 02-08-2004, 04:18 PM   #4
riddlebox80
CL volunteer
 
Registered: Jul 2002
Location: illinois
Distribution: Collegelinux and Libranet
Posts: 105

Rep: Reputation: 15
I have the same problem, everytime I boot I have to unmute with alsamixer I cannot even find the sound icon for kde?
 
Old 02-08-2004, 08:07 PM   #5
deloptes
Member
 
Registered: Feb 2004
Location: AT
Distribution: debian etch and SUSE 10.2
Posts: 123

Rep: Reputation: 15
I think I experienced the same I had to enable alsastartup

# ln -s /etc/init.d/alsasound /etc/rc2.d/S20malsa
# ln -s /etc/init.d/alsasound /etc/rc5.d/S20malsa
# ln -s /etc/init.d/alsasound /etc/rc6.d/K20malsa
# ln -s /etc/init.d/alsasound /etc/rc0.d/K20malsa

If you still have this problem you have to add to your alsa startup skript following

# amixer set Master 100 unmute
# amixer set PCM 100 unmute
Only if the above doesn't succeed on its own:
# amixer set Center 100 unmute
# amixer set Surround 100 unmute
Test the sound:
# aplay $KDEDIR/share/sounds/pop.wav // (pop.wav is part of KDE)

let me know if it helped

r3gards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i ajdust my alsa mixer and every time i reboot my pc the mixer change what to do ? SlackwareMan Linux - Newbie 1 07-30-2004 01:39 AM
ALSA Mixer subaruwrx Slackware 1 07-24-2004 07:13 AM
what mixer for sound without alsa? tomcat22 Slackware 3 06-04-2004 03:54 AM
i'm having with Alsa mixer , please help if you don't mind .. HeRCuLeSX Linux - Hardware 3 01-14-2004 09:11 AM
Installing ALSA mixer leeman_s Linux - Newbie 1 10-05-2003 04:06 PM


All times are GMT -5. The time now is 07:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration