LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   alsa mixer (http://www.linuxquestions.org/questions/fedora-35/alsa-mixer-143426/)

madian 02-07-2004 04:50 PM

alsa mixer
 
first i want to thank you all
i have a problem with alsa configuration
every time the channels is muted at startup , i have change that and do the
/usr/sbin/alsactl store
but it is muted back every time

deloptes 02-07-2004 07:51 PM

What was important to do is run after installation from the shell following lines - that actually unmuted the alsa-driver
# amixer set Master 100 unmute
# amixer set PCM 100 unmute
# amixer

starting alsamixer didn't unmute

now after this I added some stuff like this below in /etc/modules.conf (Oh, my god, debians conf area! Don't warry it worked!)
I got the output from another program called alsaconf (you find it under $PREFIX/sbin)
If you have devfs (i.e. distros like mandrake and redhat use it as far as I know), then there are different files to modify, consult the docs.

#
## ALSA portion
alias snd-card-0 snd-emu10k1
## If you have more than one, add:
## alias snd-card-1 snd-intel8x0
## alias snd-card-2 snd-ens1370
## OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

I think it's better to start experimenting with kernel higher than 2.5 as alsa can be compiled from within the kernel

Hope I could help

madian 02-08-2004 06:48 AM

thanks ,but i have unmuted the card with gnome alsa mixer
and it works fine the only problem is every startup it is muted again and i have to use the mixer every day

riddlebox80 02-08-2004 04:18 PM

I have the same problem, everytime I boot I have to unmute with alsamixer I cannot even find the sound icon for kde?

deloptes 02-08-2004 08:07 PM

I think I experienced the same I had to enable alsastartup

# ln -s /etc/init.d/alsasound /etc/rc2.d/S20malsa
# ln -s /etc/init.d/alsasound /etc/rc5.d/S20malsa
# ln -s /etc/init.d/alsasound /etc/rc6.d/K20malsa
# ln -s /etc/init.d/alsasound /etc/rc0.d/K20malsa

If you still have this problem you have to add to your alsa startup skript following

# amixer set Master 100 unmute
# amixer set PCM 100 unmute
Only if the above doesn't succeed on its own:
# amixer set Center 100 unmute
# amixer set Surround 100 unmute
Test the sound:
# aplay $KDEDIR/share/sounds/pop.wav // (pop.wav is part of KDE)

let me know if it helped

r3gards


All times are GMT -5. The time now is 02:29 AM.