LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 12-15-2006, 03:51 AM   #1
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 707
Blog Entries: 1

Rep: Reputation: 32
Post pppoe internet can ping external IP,but resolving NAT DNS fails


Hello,
I use Debian Etch,apt-pinned with unstable and experimental repos.yesterday onwards,when i try my adsl to connect,it shows connected.but when i try on my web browser (iceweasel2),or pinging www.linuxquestions.org,itfails,though i can ping IP addresses of any sites on www.
i tried/checked /etc/resolv.conf for dns server for ISP entries;it is there.checked firewall rules(iptables,tried flushing rules too).looked ifconfig for eth0 and lo and both are working with ppp0 as the internet connxn.i tried "route del default" and "route add default ppp0"-that also not able to solve my problem.So I assumed some problem with DNS server of ISP.But Now as I can Browse Internet with Ubuntu Edgy-it seems to me that My Debian Install have some problem resolving DNS,as well as NAT.so please Help!
Code:
prakash@ubuntu:~$ sudo ifconfig 
Password:
eth0      Link encap:Ethernet  HWaddr 00:15:89:92:91:64  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::214:85ff:fe98:9864/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:810 errors:0 dropped:0 overruns:0 frame:0
          TX packets:853 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:357523 (349.1 KiB)  TX bytes:118033 (115.2 KiB)
          Interrupt:201 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:100 (100.0 b)  TX bytes:100 (100.0 b)

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:59.93.20.100  P-t-P:59.93.0.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:734 errors:0 dropped:0 overruns:0 frame:0
          TX packets:773 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:336733 (328.8 KiB)  TX bytes:96059 (93.8 KiB)

Last edited by deepclutch; 12-15-2006 at 03:59 AM.
 
Old 12-15-2006, 05:07 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Post the output of your /sbin/route command. I'm wondering is you have a restrictive netmask which only allows changes in the last 2 or 3 octets.
 
Old 12-15-2006, 09:20 AM   #3
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 707
Blog Entries: 1

Original Poster
Rep: Reputation: 32
Smile

Here is the o/p of route:
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
59.93.0.1       *               255.255.255.255 UH    0      0        0 ppp0
localnet        *               255.255.255.0   U     0      0        0 eth0
default         *               0.0.0.0         U     0      0        0 ppp0
 
Old 12-15-2006, 06:17 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
I think that the line for your gateway should look like:
Code:
default         59.93.0.1       0.0.0.0         UG    0      0        0 ppp0
I use a cable modem and have a NAT router, so I assign the router's IP address as the gateway Address ( "gw 192.168.1.1" in the route command ). The 255.255.255.255 netmask just looks bizarre to me, but it turns out to be correct. I'm glad I don't have DSL.

I think that you left out the "gw 59.93.0.1" argument to the route command. You need to delete your old default route and include the gateway argument when you setup the default gateway route.
 
Old 12-17-2006, 05:09 AM   #5
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 707
Blog Entries: 1

Original Poster
Rep: Reputation: 32
Talking suddenly dsl is up ?

I am working with my ubuntu for few days.so today only i checked debian for net.now it is working! SO...Self Healing power of Debian
here is the o/p of /sbin/route
Code:
prakash@etch:~$ /sbin/route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
59.93.0.1       0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0
anyways i've tinkered with my adsl router Huaewei MT 880 web interface @ 192.168.1.1

Last edited by deepclutch; 12-17-2006 at 05:12 AM.
 
Old 12-24-2006, 11:44 AM   #6
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 707
Blog Entries: 1

Original Poster
Rep: Reputation: 32
Solved.it is actually a problem with iptables.so removed and reinstalled.
 
Old 02-26-2008, 09:16 AM   #7
fhleung
Member
 
Registered: Aug 2004
Distribution: Fedora, Debian
Posts: 355

Rep: Reputation: 30
ip route

Quote:
I think that the line for your gateway should look like:

Code:
default         59.93.0.1       0.0.0.0         UG    0      0        0 ppp0

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:59.93.20.100  P-t-P:59.93.0.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:734 errors:0 dropped:0 overruns:0 frame:0
          TX packets:773 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:336733 (328.8 KiB)  TX bytes:96059 (93.8 KiB)
The following is the ip route output:
59.93.0.1 dev ppp0 proto kernel scope link src 59.93.20.100
192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.2
169.254.0.0/16 dev eth0 scope link
127.0.0.0/8 dev lo scope link
default via 192.168.1.1 dev ppp0

line for gateway can be chaged by
ip route change default via address dev ppp0


The address should be the inet addr or P-t-P ? I am using a DSL modem. Please help.
 
Old 02-28-2008, 05:24 AM   #8
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 707
Blog Entries: 1

Original Poster
Rep: Reputation: 32
^addr is inet . for ur thing,disable/remove "network-manager" if installed.p-t-p is the n/w range.
 
Old 02-29-2008, 05:31 AM   #9
fhleung
Member
 
Registered: Aug 2004
Distribution: Fedora, Debian
Posts: 355

Rep: Reputation: 30
Thanks for ur respond, u read very "carefully"
 
  


Reply

Tags
dns, nat, pppoe


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
default gateway not set by PPPoE, can't ping internet rproffit Linux - Networking 3 12-17-2007 06:29 AM
ping failures resolve external public dns/ip address dkeller626 Linux - Networking 2 06-29-2006 10:20 PM
LAN/ADSL Router ping working but DNS ping fails R N Ghosh Linux - Networking 1 01-13-2006 08:44 AM
Can ping the gateway but not the DNS or the Internet. boyish Linux - Networking 3 04-20-2005 05:20 AM
/etc/hosts resolving before DNS resolving ? markraem Linux - Networking 4 11-02-2003 05:54 AM


All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration