LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-03-2004, 08:26 PM   #1
gyost
LQ Newbie
 
Registered: Aug 2004
Posts: 14

Rep: Reputation: 0
no keyboard or mouse in X


I just installed Debian 3.0 woody and everything works fine untill I launch X. KDE starts up just fine, but I lose all keyboard and mouse input. I have to ssh from my other machine and kill the x server before I can continue working. I have a standard 104 key ps2 keyboard and mouse.

Any Ideas?

Thanks!
 
Old 08-03-2004, 08:32 PM   #2
andymadigan
Member
 
Registered: Aug 2004
Location: Rochester, NY
Distribution: Debian Sid
Posts: 59

Rep: Reputation: 15
This might work

keyb/mouse is configured with the xfree86-server package, you might try:
Code:
dpkg-reconfigure xfree86-server
And go through the config again.
 
Old 08-03-2004, 08:34 PM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Re: no keyboard or mouse in X

Quote:
Originally posted by gyost
I just installed Debian 3.0 woody and everything works fine untill I launch X. KDE starts up just fine, but I lose all keyboard and mouse input. I have to ssh from my other machine and kill the x server before I can continue working. I have a standard 104 key ps2 keyboard and mouse.

Any Ideas?

Thanks!
Try using dpkg-reconfigure xserver-xfree86 and make sure that your have the proper settings selected. If it does not work then can you post your /etc/X11/XF86Config-4 and /var/log/XFree86.0.log note you may have to split this file to get under the posting limit.
 
Old 08-03-2004, 08:34 PM   #4
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 49
what kernel?
Any error messages?

Did you configure X?

#apt-get install x-window-system discover mdetect read-edid

#dpkg-reconfigure xserver-xfree86

reboot
 
Old 08-03-2004, 09:49 PM   #5
gyost
LQ Newbie
 
Registered: Aug 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by macondo
what kernel?
Any error messages?

Did you configure X?

#apt-get install x-window-system discover mdetect read-edid

#dpkg-reconfigure xserver-xfree86

reboot
I tried all of this, same results

I have a M$ PS/2 Natural Keyboard (no fancy buttons like volume control/web browsing) and a Logitech Marble Mouse USB (plugged into the USB-PS/2 adapter)


XF86Config-4:

### BEGIN DEBCONF SECTION
# XF86Config-4 (XFree86 server configuration file) generated by dexconf, the
# Debian X Configuration tool, using values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# If you want your changes to this file preserved by dexconf, only make changes
# before the "### BEGIN DEBCONF SECTION" line above, and/or after the
# "### END DEBCONF SECTION" line below.
#
# To change things within the debconf section, run the command:
# dpkg-reconfigure xserver-xfree86
# as root. Also see "How do I add custom sections to a dexconf-generated
# XF86Config or XF86Config-4 file?" in /usr/share/doc/xfree86-common/FAQ.gz.

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "pex5"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
Load "xie"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
EndSection

#Section "InputDevice"
# Identifier "Generic Mouse"
# Driver "mouse"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/input/mice"
# Option "Protocol" "ImPS/2"
#EndSection

Section "Device"
Identifier "Nvidia TNT M64"
Driver "nv"
BusID "AGP:01:00:0"
VideoRam 32768
EndSection

Section "Monitor"
Identifier "Dell P991"
HorizSync 30-107
VertRefresh 48-120
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Nvidia TNT M64"
Monitor "Dell P991"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
# InputDevice "Generic Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

### END DEBCONF SECTION
 
Old 08-03-2004, 09:51 PM   #6
gyost
LQ Newbie
 
Registered: Aug 2004
Posts: 14

Original Poster
Rep: Reputation: 0
/var/log/XFree86.0.log


This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs)

XFree86 Version 4.1.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.6.3-bk2 i686 [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Tue Aug 3 21:40:50 2004
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Dell P991"
(**) | |-->Device "Nvidia TNT M64"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(WW) No FontPath specified. Using compiled-in default.
(WW) The directory "/usr/X11R6/lib/X11/fonts/CID/" does not exist.
Entry deleted from font path.
(==) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/S$
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(WW) Cannot open APM
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.4
XFree86 XInput driver : 0.2
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,7190 card 0000,0000 rev 03 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,7191 card 0000,0000 rev 03 class 06,04,00 hdr 01
(II) PCI: 00:07:0: chip 8086,7110 card 0000,0000 rev 02 class 06,01,00 hdr 80
(II) PCI: 00:07:1: chip 8086,7111 card 0000,0000 rev 01 class 01,01,80 hdr 00
(II) PCI: 00:07:2: chip 8086,7112 card 0000,0000 rev 01 class 0c,03,00 hdr 00
(II) PCI: 00:07:3: chip 8086,7113 card 0000,0000 rev 02 class 06,80,00 hdr 00
(II) PCI: 00:0b:0: chip 125d,1969 card 1014,0165 rev 01 class 04,01,00 hdr 00
(II) PCI: 00:0e:0: chip 10ec,8139 card 1799,5000 rev 10 class 02,00,00 hdr 00
(II) PCI: 01:00:0: chip 10de,002d card 10de,0001 rev 15 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x88 (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0x80100000 - 0x820fffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0x82200000 - 0x860fffff (0x3f00000) MX[B]
(II) Bus -1: bridge is at (0:7:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) NVidia Riva Ultra 64 rev 21, Mem @ 0x81000000/24, 0x84000000/$
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
[0] -1 0 0x82100000 - 0x821fffff (0x100000) MX[B]E
[1] -1 0 0xe0000000 - 0xffffffff (0x20000000) MX[B]E
[2] -1 0 0x80100000 - 0x8010ffff (0x10000) MX[B](B)
[3] -1 0 0x84000000 - 0x85ffffff (0x2000000) MX[B](B)
[4] -1 0 0x81000000 - 0x81ffffff (0x1000000) MX[B](B)
[5] -1 0 0x00008000 - 0x000080ff (0x100) IX[B]E
[6] -1 0 0x00008840 - 0x0000887f (0x40) IX[B]E
[7] -1 0 0x00008800 - 0x000088ff (0x100) IX[B]E
[8] -1 0 0x000084c0 - 0x000084ff (0x40) IX[B]E
[9] -1 0 0x00008480 - 0x000084ff (0x80) IX[B]E
[10] -1 0 0x00008400 - 0x000084ff (0x100) IX[B]E
[11] -1 0 0x00008880 - 0x000088ff (0x80) IX[B]E
[12] -1 0 0x000088c0 - 0x000088ff (0x40) IX[B]E
(II) PCI I/O resource overlap reduced 0x00008800 from 0x000088ff to 0x0000883f
(II) PCI I/O resource overlap reduced 0x00008480 from 0x000084ff to 0x000084bf
(II) PCI I/O resource overlap reduced 0x00008400 from 0x000084ff to 0x0000847f
(II) PCI I/O resource overlap reduced 0x00008880 from 0x000088ff to 0x000088bf
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0x82100000 - 0x821fffff (0x100000) MX[B]E
[1] -1 0 0xe0000000 - 0xffffffff (0x20000000) MX[B]E
[2] -1 0 0x80100000 - 0x8010ffff (0x10000) MX[B](B)
[3] -1 0 0x84000000 - 0x85ffffff (0x2000000) MX[B](B)
[4] -1 0 0x81000000 - 0x81ffffff (0x1000000) MX[B](B)
[5] -1 0 0x00008000 - 0x000080ff (0x100) IX[B]E
[6] -1 0 0x00008840 - 0x0000887f (0x40) IX[B]E
[7] -1 0 0x00008800 - 0x0000883f (0x40) IX[B]E
[8] -1 0 0x000084c0 - 0x000084ff (0x40) IX[B]E
[9] -1 0 0x00008480 - 0x000084bf (0x40) IX[B]E
[10] -1 0 0x00008400 - 0x0000847f (0x80) IX[B]E
[11] -1 0 0x00008880 - 0x000088bf (0x40) IX[B]E
[12] -1 0 0x000088c0 - 0x000088ff (0x40) IX[B]E
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x82100000 - 0x821fffff (0x100000) MX[B]E
[6] -1 0 0xe0000000 - 0xffffffff (0x20000000) MX[B]E
[7] -1 0 0x80100000 - 0x8010ffff (0x10000) MX[B](B)
[8] -1 0 0x84000000 - 0x85ffffff (0x2000000) MX[B](B)
[9] -1 0 0x81000000 - 0x81ffffff (0x1000000) MX[B](B)
[10] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[11] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[12] -1 0 0x00008000 - 0x000080ff (0x100) IX[B]E
[13] -1 0 0x00008840 - 0x0000887f (0x40) IX[B]E
[14] -1 0 0x00008800 - 0x0000883f (0x40) IX[B]E
[15] -1 0 0x000084c0 - 0x000084ff (0x40) IX[B]E
[16] -1 0 0x00008480 - 0x000084bf (0x40) IX[B]E
[17] -1 0 0x00008400 - 0x0000847f (0x80) IX[B]E
[18] -1 0 0x00008880 - 0x000088bf (0x40) IX[B]E
[19] -1 0 0x000088c0 - 0x000088ff (0x40) IX[B]E
 
Old 08-03-2004, 09:52 PM   #7
gyost
LQ Newbie
 
Registered: Aug 2004
Posts: 14

Original Poster
Rep: Reputation: 0
/var/log/XFree86.0.log continued......



(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.1.9
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Reloading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "pex5"
(II) Loading /usr/X11R6/lib/modules/extensions/libpex5.a
(II) Module pex5: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension X3D-PEX
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension RECORD
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
(II) Module speedo: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Speedo
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "vbe"
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "xie"
(II) Loading /usr/X11R6/lib/modules/extensions/libxie.a
(II) Module xie: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension XIE
(II) LoadModule: "nv"
(II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.o
(II) Module nv: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.1
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.2
(II) NV: driver for NVIDIA chipsets: RIVA128, RIVATNT, RIVATNT2,
RIVATNT2 (A), RIVATNT2 (B), RIVATNT2 (Ultra), RIVATNT2 (Vanta),
RIVATNT2 M64, RIVATNT2 (Integrated), GeForce 256, GeForce DDR,
Quadro, GeForce2 GTS, GeForce2 GTS (rev 1), GeForce2 ultra,
Quadro 2 Pro, GeForce2 MX, GeForce2 MX DDR, Quadro 2 MXR,
GeForce 2 Go, GeForce3, GeForce3 (rev 1), GeForce3 (rev 2),
GeForce3 (rev 3)
(II) Primary Device is: PCI 01:00:0
GeForce3 (rev 3)
(II) Primary Device is: PCI 01:00:0
(--) Chipset RIVATNT2 M64 found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x82100000 - 0x821fffff (0x100000) MX[B]E
[6] -1 0 0xe0000000 - 0xffffffff (0x20000000) MX[B]E
[7] -1 0 0x80100000 - 0x8010ffff (0x10000) MX[B](B)
[8] -1 0 0x84000000 - 0x85ffffff (0x2000000) MX[B](B)
[9] -1 0 0x81000000 - 0x81ffffff (0x1000000) MX[B](B)
[10] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[11] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[12] -1 0 0x00008000 - 0x000080ff (0x100) IX[B]E
[13] -1 0 0x00008840 - 0x0000887f (0x40) IX[B]E
[14] -1 0 0x00008800 - 0x0000883f (0x40) IX[B]E
[15] -1 0 0x000084c0 - 0x000084ff (0x40) IX[B]E
[16] -1 0 0x00008480 - 0x000084bf (0x40) IX[B]E
[17] -1 0 0x00008400 - 0x0000847f (0x80) IX[B]E
[18] -1 0 0x00008880 - 0x000088bf (0x40) IX[B]E
[19] -1 0 0x000088c0 - 0x000088ff (0x40) IX[B]E
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x82100000 - 0x821fffff (0x100000) MX[B]E
[6] -1 0 0xe0000000 - 0xffffffff (0x20000000) MX[B]E
[7] -1 0 0x80100000 - 0x8010ffff (0x10000) MX[B](B)
[8] -1 0 0x84000000 - 0x85ffffff (0x2000000) MX[B](B)
[9] -1 0 0x81000000 - 0x81ffffff (0x1000000) MX[B](B)
[10] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[11] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[12] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[15] -1 0 0x00008000 - 0x000080ff (0x100) IX[B]E
[16] -1 0 0x00008840 - 0x0000887f (0x40) IX[B]E
[17] -1 0 0x00008800 - 0x0000883f (0x40) IX[B]E
[18] -1 0 0x000084c0 - 0x000084ff (0x40) IX[B]E
[19] -1 0 0x00008480 - 0x000084bf (0x40) IX[B]E
[20] -1 0 0x00008400 - 0x0000847f (0x80) IX[B]E
[21] -1 0 0x00008880 - 0x000088bf (0x40) IX[B]E
[22] -1 0 0x000088c0 - 0x000088ff (0x40) IX[B]E
[23] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[24] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
 
Old 08-03-2004, 09:53 PM   #8
gyost
LQ Newbie
 
Registered: Aug 2004
Posts: 14

Original Poster
Rep: Reputation: 0
finally the end of the log file .....



(II) Setting vga for screen 0.
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R6/lib/modules/linux/libint10.a
(II) NV(0): Initializing int10
(II) NV(0): Primary V_BIOS segment is: 0xc000
(--) NV(0): Chipset: "RIVATNT2 M64"
(**) NV(0): Depth 24, (--) framebuffer bpp 32
(==) NV(0): RGB weight 888
(==) NV(0): Default visual is TrueColor
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(==) NV(0): Using HW cursor
(--) NV(0): Linear framebuffer at 0x84000000
(--) NV(0): MMIO registers at 0x81000000
(**) NV(0): VideoRAM: 32768 kBytes
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Reloading /usr/X11R6/lib/modules/libddc.a
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Loading /usr/X11R6/lib/modules/libi2c.a
(II) Module i2c: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.2.0
ABI class: XFree86 Video Driver, version 0.4
(II) NV(0): I2C bus "DDC" initialized.
(II) NV(0): I2C device "DDC:ddc2" registered.
(II) NV(0): I2C device "DDC:ddc2" removed.
(==) NV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) NV(0): Dell P991: Using hsync range of 30.00-107.00 kHz
(II) NV(0): Dell P991: Using vrefresh range of 48.00-120.00 Hz
(II) NV(0): Clock range: 12.00 to 350.00 MHz
(II) NV(0): Not using default mode "1856x1392" (hsync out of range)
(II) NV(0): Not using default mode "1920x1440" (hsync out of range)
(--) NV(0): Virtual size is 1280x1024 (pitch 1280)
(**) NV(0): Default mode "1280x1024": 157.5 MHz, 91.1 kHz, 85.0 Hz
(II) NV(0): Modeline "1280x1024" 157.50 1280 1344 1504 1728 1024 1025 1028 1$
(**) NV(0): Default mode "1024x768": 94.5 MHz, 68.7 kHz, 85.0 Hz
(II) NV(0): Modeline "1024x768" 94.50 1024 1072 1168 1376 768 769 772 808 +$
(**) NV(0): Default mode "800x600": 56.3 MHz, 53.7 kHz, 85.1 Hz
(II) NV(0): Modeline "800x600" 56.30 800 832 896 1048 600 601 604 631 +hsyn$
(**) NV(0): Default mode "640x480": 36.0 MHz, 43.3 kHz, 85.0 Hz
(II) NV(0): Modeline "640x480" 36.00 640 696 752 832 480 481 484 509 -hsync$
(++) NV(0): DPI set to (100, 100)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.1
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0x84000000 - 0x85ffffff (0x2000000) MX[B]
[1] 0 0 0x81000000 - 0x81ffffff (0x1000000) MX[B]
[2] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[3] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[4] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[5] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[6] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[7] -1 0 0x82100000 - 0x821fffff (0x100000) MX[B]E
[8] -1 0 0xe0000000 - 0xffffffff (0x20000000) MX[B]E
[9] -1 0 0x80100000 - 0x8010ffff (0x10000) MX[B](B)
[10] -1 0 0x84000000 - 0x85ffffff (0x2000000) MX[B](B)
[11] -1 0 0x81000000 - 0x81ffffff (0x1000000) MX[B](B)
[12] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B](OprD)
[13] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B](OprD)
[14] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B](OprD)
[15] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[16] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[17] -1 0 0x00008000 - 0x000080ff (0x100) IX[B]E
[18] -1 0 0x00008840 - 0x0000887f (0x40) IX[B]E
[19] -1 0 0x00008800 - 0x0000883f (0x40) IX[B]E
[20] -1 0 0x000084c0 - 0x000084ff (0x40) IX[B]E
[21] -1 0 0x00008480 - 0x000084bf (0x40) IX[B]E
[22] -1 0 0x00008400 - 0x0000847f (0x80) IX[B]E
[23] -1 0 0x00008880 - 0x000088bf (0x40) IX[B]E
[24] -1 0 0x000088c0 - 0x000088ff (0x40) IX[B]E
[25] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
[26] 0 0 0x000003c0 - 0x000003df (0x20) IS[B](OprU)
(==) NV(0): Write-combining range (0x84000000,0x2000000)
(II) NV(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
8x8 mono pattern filled rectangles
Indirect CPU to Screen color expansion
Solid Lines
Scanline Image Writes
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
32 256x256 slots
16 512x512 slots
(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(**) Option "dpms"
(**) NV(0): DPMS enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
PEXExtensionInit: Couldn't open default PEX font file Roman_M
(II) Keyboard "Generic Keyboard" handled by legacy driver
(**) Option "Protocol" "PS/2"
(**) Configured Mouse: Protocol: "PS/2"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/psaux"
(==) Configured Mouse: Buttons: 3
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)








THANK YOU!!!!
 
Old 08-03-2004, 09:57 PM   #9
gyost
LQ Newbie
 
Registered: Aug 2004
Posts: 14

Original Poster
Rep: Reputation: 0
kernel problem

This could be the big indicator of my status.

uname -a
Linux debian 2.2.20-idepci

I guess I need to tackle that whole kernel upgrade thing
 
Old 08-03-2004, 10:14 PM   #10
andymadigan
Member
 
Registered: Aug 2004
Location: Rochester, NY
Distribution: Debian Sid
Posts: 59

Rep: Reputation: 15
odd

Just a bit of coincidence, I'm using the exact same keyboard and mouse as you are (except w/o the PS/2 adapter).
 
Old 08-03-2004, 10:21 PM   #11
gyost
LQ Newbie
 
Registered: Aug 2004
Posts: 14

Original Poster
Rep: Reputation: 0
so i guess i'll try upgrading the kernel (following this guide:
http://www.desktop-linux.net/debkernel.htm )

....but

apt-cache search kernel-source | grep 2.6

yields no results. Should I add something to /etc/apt/source.list? This is what I currently have:


deb http://ftp.us.debian.org/debian/ stable main non-free contrib
deb-src http://ftp.us.debian.org/debian/ stable main non-free contrib
deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free
deb-src http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

deb http://security.debian.org/ stable/updates main contrib non-free
 
Old 08-04-2004, 03:00 AM   #12
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
You don't necessarily need to install 2.6.x kernel, 2.4.x kernels should support USB devices just fine.

I think you can simply do "apt-get install kernel-image-2.4.18-386". Or if you've got a better processor than the very early pentium (Pentium Pro, Celeron, Pentium II, Pentium III or Pentium IV), grab kernel-image-2.4.18-686 instead.

If you want 2.6.x kernel, you need to first dist-upgrade from stable to testing or unstable.
 
Old 08-04-2004, 11:53 AM   #13
andymadigan
Member
 
Registered: Aug 2004
Location: Rochester, NY
Distribution: Debian Sid
Posts: 59

Rep: Reputation: 15
try upgrading

I have used the MS Natural Keyboard and the Logitech Marble Trackball w/PS2 as far back as v2.0 of the kernel, but try upgrading the kernel, it might fix it.
 
Old 08-04-2004, 03:26 PM   #14
gyost
LQ Newbie
 
Registered: Aug 2004
Posts: 14

Original Poster
Rep: Reputation: 0
upgraded to 2.4.18-686, still no luck
 
Old 08-04-2004, 04:09 PM   #15
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I still don't have a clue why your keyboard and mouse don't work in X. You say that you have them "plugged into the USB-PS/2 adapter", which makes me think that the problem may be USB related -- but, then again, your keyboard apparently works in console.

Check if you've got discover and hotplug installed ("dpkg -l | grep discover", "dpkg -l | grep hotplug"). If not, you could try installing them and see if that helps.

Also, you could install fluxbox. If the same problem exists in fluxbox too, then we can rule out the possibility that the problem is KDE related.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PS/2 Keyboard and Mouse king_kilr Linux - Hardware 1 11-22-2005 02:23 PM
No Keyboard and mouse Ahmed Slackware - Installation 7 09-22-2005 08:23 AM
Mouse and Keyboard mtecknology Linux - Hardware 1 06-22-2005 03:14 PM
How to use keyboard as mouse lukecolb Linux - Newbie 3 12-15-2004 03:18 AM
USB mouse, keyboard, hid, console mouse problems jqcaducifer Linux - General 1 08-05-2003 09:43 AM


All times are GMT -5. The time now is 11:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration