LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-09-2005, 04:30 PM   #1
Wireless-G-DSL
Newbie
 
Registered: Apr 2005
Distribution: KANOTIX 2005-02
Posts: 13

Rep: Reputation: 0
KNOPPIX 3.8.1 Problem with knoppix-installer


KNOPPIX 3.8.1 Problem with knoppix-installer

I got the iso file off of www.distrowatch.com , I notice two problems with this version one that knoppix-installer is broken , the lilo does not install on mbr right anymore , no problems with 3.7 , also formating and install takes longer than it should on a 81GB drive , also error message from lilo saying that parts of the kernel missing etc.. type messages
 
Old 04-09-2005, 11:45 PM   #2
youmolo
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian
Posts: 2

Rep: Reputation: 0
Strange. I downloaded knoppix 3.8 and the installer works perfectly. i got mine through bittorrent
 
Old 04-10-2005, 12:29 AM   #3
Wireless-G-DSL
Newbie
 
Registered: Apr 2005
Distribution: KANOTIX 2005-02
Posts: 13

Original Poster
Rep: Reputation: 0
I also download the 3.8 off of bittorrent but I am not talking about 3.8 but the new 3.8.1 , the 3.8 installed fine its their update that does not install fine, I only thing about 3.8 old ver. I did not like was that the dvd drives were failing to be found under mnt and / which pointed to the drives but would not load them problem with its dev I think

In knoppix 3.8.1 , the only thing lilo does on bootup is

li
and it basicly locks up on loading lilo
For 3.8.1 I download the iso not from bittorrent but from the link from distrowatch , and used wget to fetch the iso

Last edited by Wireless-G-DSL; 04-10-2005 at 12:34 AM.
 
Old 04-10-2005, 02:33 AM   #4
youmolo
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian
Posts: 2

Rep: Reputation: 0
i see... im not having problems with the dvd drives in 3.8 though

as for the lilo problem, try http://rhlufaq.nllgg.nl/DOCS/boot7.html

hope tat helps
 
Old 04-13-2005, 05:03 PM   #5
patitoconejita
Member
 
Registered: Nov 2004
Location: Winnipeg, MB
Distribution: Debian
Posts: 42

Rep: Reputation: 15
It looks like I'm seeing the same problems Wireless-G-DSL describes with Knoppix 3.8 after upgrading from 3.6

Lilo does not update the MBR correctly, as on boot-up I keep seeing the previous options and knoppix can't find many modules and other things. It is strange, as knoppix-installer finishes saying that knoppix was successfully installed to hd.

When trying to update lilo manually with 'lilo' or 'liloconfig', I receive an error message, whose first lines are:

/proc/misc: No entry for device-mapper found
Is device-mapper driver missing from kernel?
/dev/mapper/control: open failed: no such device
Failure to communicate with kernel device-mapper driver
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Program Installer in Knoppix royalred Linux - General 4 10-24-2005 04:04 AM
knoppix 3.9 live installer wdavis65 Linux - Newbie 14 09-16-2005 02:11 PM
knoppix hd installer not working Anubis Linux - Distributions 1 07-04-2005 03:39 PM
Debian Vs. Knoppix Installer. rvijay Debian 3 02-21-2005 06:20 PM
Knoppix-installer problem TheRiddler Debian 5 02-02-2004 10:06 AM


All times are GMT -5. The time now is 07:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration