Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 08-27-2004, 07:32 PM   #1
Registered: Aug 2001
Location: Hong Kong, China
Distribution: CentOS, Red Hat, Mandrake, Debian
Posts: 88

Rep: Reputation: 15
Question How to switch to Gnome under console?

Thx for all,

Now, after I run "dpkg-reconfigure xserver-xfree86" (Haven't run the apt-get install discover mdetect read-edid before on this step) to reconfigure the X again,
the X-Windows worked, but still have some problems appeared, it is the GDM, now after I enter "startx" , it show me the X Windows is KDE, not is the Gnome, for some personal reason, I like the Gnome more than KDE, I want to switch from KDE to Gnome, how to?

I try reboot the system, after that, it pop up a box that told me, my X Windows have problems, and the GDM now is disable auto, and then bring me to the text base console, but after I enter startx again, it bring me to the KDE again, I then logout, enter "gdm", it show me the gdm is running, I try it again and again, include reconfigure the X Windows, still not solve can't switch to Gnome problems and the GDM pop up error, I don't understand why, since it can bring me to the KDE, it is mean my X Windows can work yet

here are my setting file of XF86Config-4

# XF86Config-4 (XFree86 X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4 > /var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86
Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
Load "xtt"
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Section "Device"
Identifier "nVidia GeForce4 MX 440 AGP 8x"
Driver "nv"
Section "Monitor"
Identifier "Sony SDM-HS73"
HorizSync 28-49
VertRefresh 43-72
Option "DPMS"
Section "Screen"
Identifier "Default Screen"
Device "nVidia GeForce4 MX 440 AGP 8x"
Monitor "Sony SDM-HS73"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024"
SubSection "Display"
Depth 4
Modes "1280x1024"
SubSection "Display"
Depth 8
Modes "1280x1024"
SubSection "Display"
Depth 15
Modes "1280x1024"
SubSection "Display"
Depth 16
Modes "1280x1024"
SubSection "Display"
Depth 24
Modes "1280x1024"
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
Section "DRI"
Mode 0666
Old 08-27-2004, 08:09 PM   #2
Senior Member
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 52
try this as root, with your favorite editor edit

/home/your_user_name/.xsession (if you use a (xgk)dm


/home/your_user_name/.xinitrc (if you use startx)
and add the line:

exec gnome-session

save and exit


try again

Last edited by macondo; 08-27-2004 at 08:16 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Switch from X to console wizard7423 Programming 13 12-29-2004 10:11 AM
Cant switch to console from X sepppel Linux - Newbie 2 07-18-2004 01:57 PM
Can't switch to virtual console (from gnome) NumbThumb Linux - Newbie 14 01-11-2004 12:51 PM
Can't switch to virtual console (from gnome) NumbThumb Red Hat 3 01-10-2004 08:47 AM
how to switch to console login? miica Linux - Newbie 5 10-30-2003 11:45 PM

All times are GMT -5. The time now is 02:04 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration