LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-21-2007, 07:40 PM   #226
perro84
LQ Newbie
 
Registered: Sep 2007
Posts: 2

Rep: Reputation: 0
Easily upgrade Feisty to 2.6.22-10 Kernel


To upgrade Feisty kernel to 2.6.22-10 follow this tutorial: Upgrade Ubuntu Kernel to 2.6.22-10
 
Old 10-27-2007, 04:22 PM   #227
The PIT
Member
 
Registered: Nov 2005
Posts: 99

Rep: Reputation: 16
Server cannot be found

Try this http://www.justubuntu.com/install_2_6_22-10_ubuntu

Last edited by The PIT; 10-27-2007 at 04:24 PM.
 
Old 01-24-2008, 05:59 PM   #228
mikieboy
Member
 
Registered: Apr 2004
Location: Warrington, Cheshire, UK
Distribution: Linux Mint 12 LXDE
Posts: 555

Rep: Reputation: 33
I've compiled the 2.6.22 kernel using the instructions from this sticky to get the Debian boot logo. The kernel boots OK but part way through the boot process the text suddenly shifts to the right of the screen so that it disappears off the end and reappears on left hand side leaving a wide gap up the middle of the screen. Anyone know what causes this? I'm using a SIS integrated graphics chip.
BTW, this happens regardless of what resolution I set at vga=x on the kernel line in /grub/menu.lst

Also, I have googled but can't find an answer to the following question:

What does "ywrap,mtrr" do in the cheatcode "video=vesafb:ywrap,mtrr vga=788"?
 
Old 01-25-2008, 07:26 AM   #229
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Original Poster
Rep: Reputation: 54
Wow, I had forgotten about this post...It has been a while since I have been on LQ.

Here is what ywrap does (it is supposed to speed up scrolling as I understand it):
Quote:
vesafb does not enable scrollback buffering as a default. You will need to pass to the kernel the option to enable it. Use video=vesa:ypan or video=vesa:ywrap to activate it. Both does the same thing, but in different ways. ywrap is a lot faster than ypan but may not work on slightly broken VESA 2.0 graphic cards. ypan is slower than ywrap but a lot more compatible. This option is only present in kernel 2.1.116 and above. Earlier kernels did not have the ability to allow scrollback buffering in vesafb.
The mtrr explanation is:
Quote:
If your processor (on Intel platforms) supports MTRRs, enable this. It speeds up memory copies between the processor and the graphic card, but not strictly necessary. You can of course, do this after you have the console device working.
Those quotes are from: the framebuffer HOWTO: http://tldp.org/HOWTO/Framebuffer-HOWTO-5.html

For the main part of your question about the text shifting to the right, I am not sure what causes that. I run Ubuntu now on all my computers and I have observed a similar thing when booting up in text mode without usplash. At the very end of th boot process, the last few lines are shifted over to the right. Each line appears shifted more than the next, so that it appears to be scrolling to the right. I just never investigated it to try and find out a cause.
 
Old 03-21-2008, 12:33 AM   #230
propofol
Member
 
Registered: Nov 2007
Location: Seattle
Distribution: Debian Wheezy & Jessie; Ubuntu
Posts: 260

Rep: Reputation: 50
Question 2.6.24 kernel compile: make-kpkg error bad permissions 2755

I am trying to compile a custom 2.6.24 kernel for Debian Sid "The Debian Way" using:
make-kpkg --initrd --append-to-version=-xx kernel_image

This results in the following error:
dpkg-deb: control directory has bad permissions 2755 (must be >=0755 and <=0775)

I would appreciate it if anyone could tell me how to fix the problem.

Regards,
Stefan
 
Old 03-21-2008, 07:36 AM   #231
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Original Poster
Rep: Reputation: 54
Quote:
Originally Posted by propofol View Post
I am trying to compile a custom 2.6.24 kernel for Debian Sid "The Debian Way" using:
make-kpkg --initrd --append-to-version=-xx kernel_image

This results in the following error:
dpkg-deb: control directory has bad permissions 2755 (must be >=0755 and <=0775)

I would appreciate it if anyone could tell me how to fix the problem.

Regards,
Stefan
The error message is referring to a permissions problem. I've not seen this particular error myself, but it should be fixed by changing permissions. I assume the "control directory" referred to in the error message is the directory in which you are compiling the kernel image. Try changing the permissions of that directory using chmod. Something like
Code:
chmod 755 <name>
Where <name> is the name of the directory. It should change permissions to 0755 as suggested by the error message. Hopefully that works.
 
Old 03-22-2008, 12:46 AM   #232
propofol
Member
 
Registered: Nov 2007
Location: Seattle
Distribution: Debian Wheezy & Jessie; Ubuntu
Posts: 260

Rep: Reputation: 50
Unhappy

Thanks for the reply.

I did a:
chmod 775 ./linux-source-2.6.24
however I still get the same error. I am not sure what the "control directory" part refers to.

Regards,
Stefan
 
Old 03-22-2008, 02:49 PM   #233
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Original Poster
Rep: Reputation: 54
Quote:
Originally Posted by propofol View Post
Thanks for the reply.

I did a:
chmod 775 ./linux-source-2.6.24
however I still get the same error. I am not sure what the "control directory" part refers to.

Regards,
Stefan
Try doing this to the directory that dpkg builds the kernel image in. Normally that is /usr/src You might also try /usr/src/linux I'm not sure why permissions of the directory should be a problem. As I said, I have never seen that particular error before. Are you following the "guide" I wrote at the start of this thread? In that case, the kernel source should be unpacked in /usr/src/linux-source-2.6.24 and should be symbolically linked to /usr/src/linux
 
Old 03-23-2008, 12:47 AM   #234
propofol
Member
 
Registered: Nov 2007
Location: Seattle
Distribution: Debian Wheezy & Jessie; Ubuntu
Posts: 260

Rep: Reputation: 50
Thanks!!! Problem solved. For some reason my src directory had the s attribute set. Not sure how I managed to do it, but anyway. The following worked:
chmod -R a-s /usr/src

Regards,
Stefan

BTW Thanks for the guide - very useful.
 
Old 03-29-2008, 01:59 AM   #235
East
Member
 
Registered: Jan 2008
Posts: 84

Rep: Reputation: 15
Post Error in kernel upgrade

I have installed the knoppix 5.1.1 in my system using poor man install method. Now i want to upgrade the kernel. I have followed the below steps,

1. Check for the packages ,kernel-package,ncurses-dev fake root wget bzip2.
2. Downloaded the linux source for 2.6.23.12 and copied into /usr/src
3.Unpacked the file and get into that linux 2.6.23.12 dir.
4.typed make menuconfig. In that i havent selected anything.Checked for the SATA support.
5.make-kpkg clean
6.fakeroot make-kpkg --revision=custom.1.0 kernel_image. this command tooks more than 1.5 hours to create an linux.2.6.23.12.deb file in /usr/src
7.get into /usr/src and typed dpkg -i <linux custom image file.deb>
When i did i got the error in lilo.conf as
Fatal:Trying to map files from unnamed devce 0x0010 (NFS/RAID mirror down ?)

I dont know how to proceed. I am new to the knoppix.Mean while i got the error as No space left on device when i installing the linux custom image file and i deleted the linux.2.6.23.12.tar.bz2 file. For past two days i am trying to resolve this. can aynone help me.
 
Old 04-09-2008, 03:50 PM   #236
El1iP3S01D
LQ Newbie
 
Registered: Apr 2008
Location: Bklyn
Distribution: Debian Etch amd64
Posts: 21

Rep: Reputation: 15
Wink Is there an upgrade for this image?

Is there an upgrade for this image 2.6.18-6-amd64?
 
Old 04-12-2008, 01:16 PM   #237
mikieboy
Member
 
Registered: Apr 2004
Location: Warrington, Cheshire, UK
Distribution: Linux Mint 12 LXDE
Posts: 555

Rep: Reputation: 33
Well I had framebuffer support and the Debian boot logo working as stated above but now, without consciously changing anything, it has all disappeared and reverted to the default boot text. The only thing I have done is "aptitude upgrade".
As I am using a custom kernel, I wouldn't expect an upgrade to change the kernel boot parameters. Could this be a GRUB thing?

Edit: Sorry, I'm being dense.
I've just checked my /boot/grub/menu.lst and the "video=vesafb:ywrap,mtrr vga=788" cheatcode is missing.
Clearly the upgrade has overwritten this.
Anyone know how to stop this happening each time GRUB upgrades?

2nd edit: I found this on a Ubuntu site:

Quote:
Add the parameter changes to the end of the line "#kopt...". These parameters will then be automatically added to any new kernel entries and should also survive an upgrade of grub.
I'll give this a try!

Last edited by mikieboy; 04-12-2008 at 03:02 PM.
 
Old 04-12-2008, 04:20 PM   #238
mikieboy
Member
 
Registered: Apr 2004
Location: Warrington, Cheshire, UK
Distribution: Linux Mint 12 LXDE
Posts: 555

Rep: Reputation: 33
Originally posted by myself:
Quote:
The kernel boots OK but part way through the boot process the text suddenly shifts to the right of the screen so that it disappears off the end and reappears on left hand side leaving a wide gap up the middle of the screen. Anyone know what causes this? I'm using a SIS integrated graphics chip.
For information, I've solved the above problem by using the following boot parameter: "video=vesafb:ypan,vga=791"

I think ywrap may have been the problem, but also vga=791 seems to look better than vga=788
 
Old 04-30-2008, 07:49 PM   #239
thveillon
Member
 
Registered: Dec 2007
Posts: 59

Rep: Reputation: 16
Rolled my 2.6.25 kernel from Unstable fresh sources, did it the debian way (fakeroot make-kpkg --initrd --append-to-version -blabla --revision 1 kernel-image kernel-headers).

Nvidia beta drivers x86 and x86-64 build just fine (not the stable 168.12). KVM and Kqemu work great, but couldn't get the VirtualBox module to load so far (didn't try OSE version).

A hardware clock sync bug appeared with 2.6.24 is gone, intel hd audio chip is better handled and so is acpi.

Good kernel for me, my Lenny boxes are happy !
 
Old 01-29-2009, 01:37 AM   #240
propofol
Member
 
Registered: Nov 2007
Location: Seattle
Distribution: Debian Wheezy & Jessie; Ubuntu
Posts: 260

Rep: Reputation: 50
Kernel 2.6.28 vs NVIDIA drivers

I have a nVidia GeForce FX 5200 video card with Debian Sid and upgraded from a 2.6.26 kernel to a 2.6.28.2. I ran into the following problem:

NVIDIA-Linux-x86-173.14.12-pkg1.run failed with:
"-> Kernel source path: '/lib/modules/2.6.28.2/source'
-> Kernel output path: '/lib/modules/2.6.28.2/build'
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system."

This driver worked before with no issues on my previous kernel.

Following some advice from Debian forums I found a newer driver here which did work:
ftp://download.nvidia.com/XFree86/Linux-x86/96.43.09/

ie NVIDIA-Linux-x86-173.14.16-pkg1.run

Interestingly this driver was not listed under the official NVIDIA drivers page for linux.

Does anyone know what changed in the newer kernels? It just seems strange that the NVIDIA driver could not find the kernel source / headers which was in the usual place and the path indicated was correct.

Regards,
Stefan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recompile drivers after upgrade? Tons of Fun Debian 4 09-11-2005 10:00 PM
recompile kernel laurentwahl Linux - Software 5 06-02-2005 02:27 PM
Another Kernel Guide 2.6.11 xaos5 Slackware 20 03-26-2005 12:49 PM
kernel recompile error (kernel panic) tombaaaaa Linux - Newbie 4 08-04-2004 04:32 PM
should i recompile after kernel upgrade? doralsoral Linux - Software 1 03-26-2004 11:50 PM


All times are GMT -5. The time now is 05:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration