LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-31-2009, 01:01 AM   #1
mrshanim
Member
 
Registered: Aug 2009
Posts: 30

Rep: Reputation: 16
GLIB version mismatch


Hi
I need to install trace toolkit which need glib >=2.4

I check my version it is 2.3 when I try to install new glib from gnu it gives me error ... debian 2.6.27
Can you please tell me how to install glib with easy steps

Thanks

shanim
 
Old 08-31-2009, 03:15 AM   #2
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 481

Rep: Reputation: 108Reputation: 108
What branch of debian are you on and where did you get that kernel from?

I am 100% certain that debian, in any branch, did not release 2.6.27 due to the release schedule of stable.
 
Old 08-31-2009, 01:36 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,551

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
Debian 3.1 'Sarge' from 2004 ?
Please show the outputs from the commands

dpkg --get-selections | grep libglib2
and
dpkg --get-selections | grep libc6

.. which will give an idea about your Debian branch.
.....
P.S.: TraceToolkit-0.9.5a is old and unsupported too,
last update = 2002 , ltt-0.9.6-pre4 = 2004.
.....

Last edited by knudfl; 08-31-2009 at 01:48 PM.
 
Old 08-31-2009, 03:13 PM   #4
mrshanim
Member
 
Registered: Aug 2009
Posts: 30

Original Poster
Rep: Reputation: 16
Hi
I got the vanilla kernel from kernel.org (2.6.27)
Also trace toolkit is old but I forgot to mention It is now linux trace toolkit which updated recently (last month)
checkout on lttng.org

"dpkg --get-selections | grep libglib2
dpkg --get-selections | grep libc6 "
This provides error.

can you please explain in detail

Thanks for reply
 
Old 09-01-2009, 07:55 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,551

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
And you have no idea, which Debian, you are using ?
Debian Sarge or Debian Etch ?


Other way to list and find installed packages
ls -tl /var/lib/dpkg/info/ | grep list > packages.txt \
&& grep libglib2 packages.txt

apt-cache search libglib2.0-0

dpkg -l libglib2.0-0 | grep -iA 2 version

dpkg -l libc6 | grep -iA 2 version

dpkg -l : the letter l is a lower case L.

Hopefully you can now tell the versions of
libglib2.0-0 and libc6
.....
P.S.: Today your logo shows 'Ubuntu' :
Could be, you have an old version of Ubuntu ?
.....

Last edited by knudfl; 09-01-2009 at 12:53 PM.
 
Old 09-01-2009, 02:17 PM   #6
mrshanim
Member
 
Registered: Aug 2009
Posts: 30

Original Poster
Rep: Reputation: 16
Hi
I know I have debian etch4.0
Previous message send from ubuntu desktop, but I have issues with debian etch 2.6.27

libglib2.0-dev 2.12.4-2+etch1
libc6-dev 2.3 6.ds1-13etch9+b1

these are the versions.
I used apt-cache show libglib2.0-dev
dpk -l ..... is not working on mine.

Thanks

Last edited by mrshanim; 09-01-2009 at 03:18 PM.
 
  


Reply

Tags
error, glib


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 02:54 PM
ABI version mismatch with server version rjpilla Ubuntu 1 10-03-2006 10:03 PM
help, gcc version and kernel version mismatch akanitkar Linux - Newbie 1 05-06-2006 07:02 AM
Kernel version Source Version mismatch after recompile chuckleberry Linux - Software 1 06-20-2005 06:37 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration