LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-18-2011, 03:17 AM   #1
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 707
Blog Entries: 1

Rep: Reputation: 32
Post Assign MTU value for network interface. need help


Hi,
I have dsl broadband shared through a Modem Bridge Mode forwarded to wireless router which is configured for dhcp lease to the clients(1 Desktop, 1 Laptop).

So, in My Debian Testing Desktop, I have following lines in /etc/network/interfaces :
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
hwaddress ether xx:xx:xx:xx:xx:xx
I need to give a Custom MTU value of 1454. Simply adding "MTU 1454" to /etc/network/interfaces file does not seems to work for Me.

How can I assign MTU value as 1454 on start up itself?
BTW, I can manually change MTU as :
Code:
ifconfig eth0 mtu 1454
Is there any option like editing dhcp client configuration files to reflect change in MTU?

I tried tcpdump to observe network interface and it shows some packets are dropped. is this due to wrong MTU/MSS value?
Code:
:~# tcpdump -i eth0
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
14:09:15.546657 IP 192.168.2.1.1900 > 239.255.255.250.1900: UDP, length 323

1 packets captured
60 packets received by filter
29 packets dropped by kernel
TIA+

Last edited by deepclutch; 05-18-2011 at 03:43 AM.
 
Old 05-18-2011, 03:52 AM   #2
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 707
Blog Entries: 1

Original Poster
Rep: Reputation: 32
Post

OK. I got the MTU value assigned at boot by adding below line to /etc/network/interfaces file:
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
hwaddress ether xx:xx:xx:xx:xx:xx
pre-up /sbin/ifconfig $IFACE mtu 1454
But, the issue of packet dropping continues
Code:
367 packets captured
437 packets received by filter
70 packets dropped by kernel
 
  


Reply

Tags
debian, debian testing, dhcp, mtu, router


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Assign port dedicatedly against an interface ! shipon_97 Linux - Newbie 2 04-22-2010 02:56 AM
DHCP server not using 'option interface-mtu'? Moloko Linux - Networking 2 01-09-2010 11:30 AM
LXer: How to Change MTU (Maximum Transmission Unit) of network interface in Ubuntu Li LXer Syndicated Linux News 0 08-16-2008 07:20 AM
Sending ICMP messages of type 3 when packet size exceeds MTU of the interface nmb1081 Linux - Networking 1 04-13-2008 10:14 PM
Help me cant assign gateway to interface shueib Linux - Networking 10 01-02-2006 11:34 AM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration