LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Assign MTU value for network interface. need help (http://www.linuxquestions.org/questions/debian-26/assign-mtu-value-for-network-interface-need-help-881358/)

deepclutch 05-18-2011 03:17 AM

Assign MTU value for network interface. need help
 
Hi,
I have dsl broadband shared through a Modem Bridge Mode forwarded to wireless router which is configured for dhcp lease to the clients(1 Desktop, 1 Laptop).

So, in My Debian Testing Desktop, I have following lines in /etc/network/interfaces :
Code:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
hwaddress ether xx:xx:xx:xx:xx:xx

I need to give a Custom MTU value of 1454. Simply adding "MTU 1454" to /etc/network/interfaces file does not seems to work for Me.

How can I assign MTU value as 1454 on start up itself?
BTW, I can manually change MTU as :
Code:

ifconfig eth0 mtu 1454
Is there any option like editing dhcp client configuration files to reflect change in MTU?

I tried tcpdump to observe network interface and it shows some packets are dropped. is this due to wrong MTU/MSS value?
Code:

:~# tcpdump -i eth0
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
14:09:15.546657 IP 192.168.2.1.1900 > 239.255.255.250.1900: UDP, length 323

1 packets captured
60 packets received by filter
29 packets dropped by kernel

TIA+

deepclutch 05-18-2011 03:52 AM

OK. I got the MTU value assigned at boot by adding below line to /etc/network/interfaces file:
Code:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
hwaddress ether xx:xx:xx:xx:xx:xx
pre-up /sbin/ifconfig $IFACE mtu 1454

But, the issue of packet dropping continues :confused:
Code:

367 packets captured
437 packets received by filter
70 packets dropped by kernel



All times are GMT -5. The time now is 11:48 AM.