LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-22-2008, 08:25 AM   #1
Optimistic
Member
 
Registered: Jun 2004
Location: Germany
Distribution: Debian (testing)
Posts: 276

Rep: Reputation: 31
ALSA suddenly stopped working.


At some point I no longer had sound. I'm not sure if it was after an update or what. I've since updated to the most recent packages in Testing, and gone up to kernel 2.6.24 (old was 2.6.18) and I still don't have sound.

Using a .asoundrc file, alsaplayer gives:
Code:
opti@linuxbox:~$ alsaplayer 
ALSA lib pcm_dmix.c:996:(snd_pcm_dmix_open) unable to open slave
snd_pcm_open: No such file or directory (default)
Failed to initialize plugin!
Failed to register plugin: /usr/lib/alsaplayer/output/libalsa_out.so
Failed to load output plugin "alsa". Trying defaults.
ALSA lib pcm_dmix.c:996:(snd_pcm_dmix_open) unable to open slave
snd_pcm_open: No such file or directory (default)
Failed to initialize plugin!
/usr/lib/alsaplayer/output/libalsa_out.so failed to load
NOTE: THIS IS THE NULL PLUGIN.      YOU WILL NOT HEAR SOUND!!
Without using a .asoundrc file I get no sound and no output.

In alsamixer my card shows up as:

Card:Intel 82801DB-ICH4
Chip: Analog Devices AD1981A

The levels are configurable and everything, ostensibly seems to be working.

lsmod | grep snd output:
Code:
opti@linuxbox:~$ lsmod | grep snd
snd_intel8x0           32028  0 
snd_ac97_codec         92932  1 snd_intel8x0
ac97_bus                2176  1 snd_ac97_codec
snd_pcm_oss            38272  0 
snd_mixer_oss          15296  1 snd_pcm_oss
snd_pcm                71780  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              21092  1 snd_pcm
snd                    48612  6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               7552  1 snd
snd_page_alloc         10056  2 snd_intel8x0,snd_pcm
Any ideas?
 
Old 05-22-2008, 10:00 AM   #2
Stéphane Ascoët
Member
 
Registered: Feb 2004
Location: Orleans, 120 km south of Paris
Distribution: Mandrake, Freeduc (the one I'm making), Slackware, MacOS X
Posts: 111

Rep: Reputation: 20
Red face Oh...

I'm faced with a similar problem...
 
Old 05-22-2008, 11:13 AM   #3
Pearlseattle
Member
 
Registered: Aug 2007
Location: Switzerland
Distribution: Gentoo
Posts: 705

Rep: Reputation: 80
And what happens when you run alsaconf?
 
Old 05-22-2008, 11:22 AM   #4
Optimistic
Member
 
Registered: Jun 2004
Location: Germany
Distribution: Debian (testing)
Posts: 276

Original Poster
Rep: Reputation: 31
When I run alsaconf it detects the card and everything goes through like normal, but there still isn't sound---even after a restart.
 
Old 05-22-2008, 11:35 AM   #5
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Is sound working with the old kernel,if you still have one?
 
Old 05-22-2008, 12:32 PM   #6
Optimistic
Member
 
Registered: Jun 2004
Location: Germany
Distribution: Debian (testing)
Posts: 276

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by alan_ri View Post
Is sound working with the old kernel,if you still have one?
Nope. It didn't work with 2.6.18 and it doesn't work with 2.6.24.
 
Old 05-22-2008, 01:03 PM   #7
Pearlseattle
Member
 
Registered: Aug 2007
Location: Switzerland
Distribution: Gentoo
Posts: 705

Rep: Reputation: 80
Damn.
What about "/etc/conf.d/alsasound"? Everything set to "yes" in there?
And what if you just do a "cat" of any big file you have somewhere and send it to the dsp? E.g. "cat mybigexcelfile.xls > /dev/dsp" - do you hear a big mess coming out of the speakers?
 
Old 05-22-2008, 02:19 PM   #8
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
See if this will work
Code:
# alsaplayer -d default
 
Old 05-22-2008, 03:35 PM   #9
Optimistic
Member
 
Registered: Jun 2004
Location: Germany
Distribution: Debian (testing)
Posts: 276

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by Pearlseattle View Post
Damn.
What about "/etc/conf.d/alsasound"? Everything set to "yes" in there?
And what if you just do a "cat" of any big file you have somewhere and send it to the dsp? E.g. "cat mybigexcelfile.xls > /dev/dsp" - do you hear a big mess coming out of the speakers?

I don't have a /etc/conf.d/alsasound. Maybe Debian keeps that somewhere else?

cat bigfile > /dev/dsp makes a racket in the motherboard speaker---that little one that beeps.

alsaplayer -d default

Doesn't work either.
 
Old 05-22-2008, 04:20 PM   #10
Pearlseattle
Member
 
Registered: Aug 2007
Location: Switzerland
Distribution: Gentoo
Posts: 705

Rep: Reputation: 80
And do you have a file called "/etc/modules.d/alsa"? Mine contains the following:
Code:
alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.14 ---
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
 
Old 05-23-2008, 02:16 AM   #11
Optimistic
Member
 
Registered: Jun 2004
Location: Germany
Distribution: Debian (testing)
Posts: 276

Original Poster
Rep: Reputation: 31
/etc/modules.d/alsa

Doesn't exist on my system. I don't know where the Debian equivalents are kept.
 
Old 05-23-2008, 07:57 AM   #12
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Try /etc/modprobe.d/sound
 
Old 05-23-2008, 08:32 AM   #13
Optimistic
Member
 
Registered: Jun 2004
Location: Germany
Distribution: Debian (testing)
Posts: 276

Original Poster
Rep: Reputation: 31
/etc/modprobe.d/sound is there.

Code:
opti@linuxbox:~$ cat /etc/modprobe.d/sound 
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0
 
Old 05-23-2008, 09:20 AM   #14
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Try changing snd-intel8x0 to snd-intel8x0m
Then blacklist snd-intel8x0 in /etc/modprobe.d/alsa-base-blacklist

Edit: Me wonders if teh modem driver gives sound though. Perhaps instead remove the comment from snd-intel8x0m in alsa-base-blacklist.

Last edited by makuyl; 05-23-2008 at 09:24 AM.
 
Old 05-23-2008, 11:04 AM   #15
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
You should have etc/alsa directory and in etc/modprobe.d there should be alsa-base and some related files,so check them out and look for any errors.Also have a look in var/log for errors related to sound.If you didn't try to reinstall alsa,then you should try it.You should also visit AlsaProject for more info.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vmware suddenly stopped working leupi Linux - Software 7 01-22-2007 08:47 PM
apache suddenly stopped working newlinuxnewbie Linux - General 21 11-25-2005 03:56 PM
Internet suddenly stopped working. figster Linux - Newbie 2 08-29-2005 05:18 PM
yum suddenly stopped working DJOtaku Fedora 3 05-01-2005 11:38 AM
crontab suddenly stopped working corepuncher Linux - General 4 02-18-2005 05:57 PM


All times are GMT -5. The time now is 03:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration