LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   ALSA suddenly stopped working. (http://www.linuxquestions.org/questions/debian-26/alsa-suddenly-stopped-working-644023/)

Optimistic 05-22-2008 08:25 AM

ALSA suddenly stopped working.
 
At some point I no longer had sound. I'm not sure if it was after an update or what. I've since updated to the most recent packages in Testing, and gone up to kernel 2.6.24 (old was 2.6.18) and I still don't have sound.

Using a .asoundrc file, alsaplayer gives:
Code:

opti@linuxbox:~$ alsaplayer
ALSA lib pcm_dmix.c:996:(snd_pcm_dmix_open) unable to open slave
snd_pcm_open: No such file or directory (default)
Failed to initialize plugin!
Failed to register plugin: /usr/lib/alsaplayer/output/libalsa_out.so
Failed to load output plugin "alsa". Trying defaults.
ALSA lib pcm_dmix.c:996:(snd_pcm_dmix_open) unable to open slave
snd_pcm_open: No such file or directory (default)
Failed to initialize plugin!
/usr/lib/alsaplayer/output/libalsa_out.so failed to load
NOTE: THIS IS THE NULL PLUGIN.      YOU WILL NOT HEAR SOUND!!

Without using a .asoundrc file I get no sound and no output.

In alsamixer my card shows up as:

Card:Intel 82801DB-ICH4
Chip: Analog Devices AD1981A

The levels are configurable and everything, ostensibly seems to be working.

lsmod | grep snd output:
Code:

opti@linuxbox:~$ lsmod | grep snd
snd_intel8x0          32028  0
snd_ac97_codec        92932  1 snd_intel8x0
ac97_bus                2176  1 snd_ac97_codec
snd_pcm_oss            38272  0
snd_mixer_oss          15296  1 snd_pcm_oss
snd_pcm                71780  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              21092  1 snd_pcm
snd                    48612  6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              7552  1 snd
snd_page_alloc        10056  2 snd_intel8x0,snd_pcm

Any ideas?

Stéphane Ascoët 05-22-2008 10:00 AM

Oh...
 
I'm faced with a similar problem...

Pearlseattle 05-22-2008 11:13 AM

And what happens when you run alsaconf?

Optimistic 05-22-2008 11:22 AM

When I run alsaconf it detects the card and everything goes through like normal, but there still isn't sound---even after a restart.

alan_ri 05-22-2008 11:35 AM

Is sound working with the old kernel,if you still have one?

Optimistic 05-22-2008 12:32 PM

Quote:

Originally Posted by alan_ri (Post 3161508)
Is sound working with the old kernel,if you still have one?

Nope. It didn't work with 2.6.18 and it doesn't work with 2.6.24.

Pearlseattle 05-22-2008 01:03 PM

Damn.
What about "/etc/conf.d/alsasound"? Everything set to "yes" in there?
And what if you just do a "cat" of any big file you have somewhere and send it to the dsp? E.g. "cat mybigexcelfile.xls > /dev/dsp" - do you hear a big mess coming out of the speakers?

alan_ri 05-22-2008 02:19 PM

See if this will work
Code:

# alsaplayer -d default

Optimistic 05-22-2008 03:35 PM

Quote:

Originally Posted by Pearlseattle (Post 3161590)
Damn.
What about "/etc/conf.d/alsasound"? Everything set to "yes" in there?
And what if you just do a "cat" of any big file you have somewhere and send it to the dsp? E.g. "cat mybigexcelfile.xls > /dev/dsp" - do you hear a big mess coming out of the speakers?


I don't have a /etc/conf.d/alsasound. Maybe Debian keeps that somewhere else?

cat bigfile > /dev/dsp makes a racket in the motherboard speaker---that little one that beeps.

alsaplayer -d default

Doesn't work either.

Pearlseattle 05-22-2008 04:20 PM

And do you have a file called "/etc/modules.d/alsa"? Mine contains the following:
Code:

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.14 ---
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel


Optimistic 05-23-2008 02:16 AM

/etc/modules.d/alsa

Doesn't exist on my system. I don't know where the Debian equivalents are kept.

makuyl 05-23-2008 07:57 AM

Try /etc/modprobe.d/sound

Optimistic 05-23-2008 08:32 AM

/etc/modprobe.d/sound is there.

Code:

opti@linuxbox:~$ cat /etc/modprobe.d/sound
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0


makuyl 05-23-2008 09:20 AM

Try changing snd-intel8x0 to snd-intel8x0m
Then blacklist snd-intel8x0 in /etc/modprobe.d/alsa-base-blacklist

Edit: Me wonders if teh modem driver gives sound though. Perhaps instead remove the comment from snd-intel8x0m in alsa-base-blacklist.

alan_ri 05-23-2008 11:04 AM

You should have etc/alsa directory and in etc/modprobe.d there should be alsa-base and some related files,so check them out and look for any errors.Also have a look in var/log for errors related to sound.If you didn't try to reinstall alsa,then you should try it.You should also visit AlsaProject for more info.


All times are GMT -5. The time now is 04:52 AM.