LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 10-27-2005, 06:26 AM   #1
mechmg93
Member
 
Registered: Oct 2004
Distribution: debian sarge-backported
Posts: 41

Rep: Reputation: 15
after ctrl+alt+fn my pc stops responding


i have a serious problem with ctrl+alt+fn. when i try it i change to console, but when i give alt+f7 or ctrl+alt+f7 my pc crashes. i don't know what to do in order to fix it.

i use debian sarge 3.1 with kde 3.4.1(but i had this problem with kde 3.3 too)
 
Old 10-27-2005, 06:41 AM   #2
mechmg93
Member
 
Registered: Oct 2004
Distribution: debian sarge-backported
Posts: 41

Original Poster
Rep: Reputation: 15
i fogot to write that my graphics card is an ati radeon 9600 pro and i have the latest ati drivers installed(i had that problem with the previous too)
 
Old 10-27-2005, 07:04 AM   #3
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 771

Rep: Reputation: 32
I have almost the opposite problem. I cannot get to console mode from within KDE.

For your case, as a start, I'd suggest trying: Become root. Do ps -A|grep kdm to see if the display manager is still loaded before you try to get back to console 7.
 
Old 10-27-2005, 08:52 AM   #4
mechmg93
Member
 
Registered: Oct 2004
Distribution: debian sarge-backported
Posts: 41

Original Poster
Rep: Reputation: 15
i typed as root:

ps -A|grep kdm
and the output was:

3968 ? 00:00:00 kdm
4061? 00:00:00 kdm
 
Old 10-27-2005, 09:33 AM   #5
mechmg93
Member
 
Registered: Oct 2004
Distribution: debian sarge-backported
Posts: 41

Original Poster
Rep: Reputation: 15
i rebooted and then booted in failsafe mode. i discovered that alt+fn does not work. i cannot understand what problem i do have..

Last edited by mechmg93; 10-27-2005 at 10:18 AM.
 
Old 10-27-2005, 08:42 PM   #6
mechmg93
Member
 
Registered: Oct 2004
Distribution: debian sarge-backported
Posts: 41

Original Poster
Rep: Reputation: 15
i have just discovered something very strange.

if, before i use ctrl+alt+fn for the first time, i type

sudo /etc/init.d/kdm stop
and then i start kdm again
/etc/init.d/kdm start

my ctrl+alt+fn works fine! why do i need to stop and restart kdm??i do not believe that this is a kdm's problem because i had the same problem when i tried xdm.
 
Old 11-01-2005, 01:44 PM   #7
mechmg93
Member
 
Registered: Oct 2004
Distribution: debian sarge-backported
Posts: 41

Original Poster
Rep: Reputation: 15
i cannot fix my problem so i post a part of my /etc/kde3/kdm/kdmrc file which has to do with virtual consoles:

[General]
# This option exists solely for the purpose of a clean automatic upgrade.
# Do not even think about changing it!
ConfigVersion=2.3
# List of permanent displays. Displays with a hostname are foreign. A display
# class may be specified separated by an underscore.
# Default is ":0"
StaticServers=:0
# List of on-demand displays. See StaticServers for syntax.
# Default is ""
ReserveServers=:1,:2,:3
# VTs to allocate to X-servers. A negative number means that the VT will be
# used only if it is free. If all VTs in this list are used up, the next free
# one greater than the last one in this list will be allocated.
# Default is ""
ServerVTs=-7
# TTYs (without /dev/) to monitor for activity while in console mode.
# Default is ""
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
# Where KDM should store its PID (do not store if empty).
# Default is ""
PidFile=/var/run/kdm.pid
# Whether KDM should lock the PID file to prevent having multiple KDM
# instances running at once. Do not change unless you are brave.
# Default is true
#LockPidFile=false

is anything wrong???
 
Old 11-02-2005, 07:16 AM   #8
mechmg93
Member
 
Registered: Oct 2004
Distribution: debian sarge-backported
Posts: 41

Original Poster
Rep: Reputation: 15
i uninstalled kdm, and used startx, and i had the same problem....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No alt-ctrl-F7/F8 spotslayer Suse/Novell 3 04-26-2005 08:50 PM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 09:13 AM
Switching window focus (like alt+tab in windows) and Ctrl+Alt+F1 X windows problem... DiZASTiX Linux - Software 3 01-20-2005 05:56 PM
How To Disable CTRL-ALT-F1 beajedi Linux - Security 6 12-24-2004 12:07 AM
Ctrl-Alt-F* Fiskarn Mandriva 2 10-15-2003 03:44 AM


All times are GMT -5. The time now is 11:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration