LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 01-08-2004, 03:09 PM   #1
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Rep: Reputation: 15
How To Disable CTRL-ALT-F1


I'm trying to strip down a machine so I can get it to be a internet-kiosk for a school.

I went into /etc/inittab and did this:

# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
# 2:2345:respawn:/sbin/mingetty tty2
# 3:2345:respawn:/sbin/mingetty tty3
# 4:2345:respawn:/sbin/mingetty tty4
# 5:2345:respawn:/sbin/mingetty tty5
# 6:2345:respawn:/sbin/mingetty tty6

This allowed me to disable the console switching by pressing ALT-F1 - ALT-F6

However, when I press "CTRL-ALT-F1" it takes me to another console with a login screen.

How do I disable the CTRL-ALT-F1 buttons?

Thanks in advance!
 
Old 01-08-2004, 05:47 PM   #2
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
What do you mean by "another"? tty1 should be the only one...
if you mean you run xdm/gdm and just want graphical login, you can disable tty1 the same way...
In case you get in trouble in future, to boot into single-user console mode use the 'single' kernel parameter in lilo/grub prompt
 
Old 01-08-2004, 06:30 PM   #3
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
I think I got it.

By commenting out the "1:2345:respawn:/sbin/mingetty tty1" part of my inittab, there is no other way to login besides using the graphical thing.

I still don't like the fact that you can still hit say, CTRL-ALT-F2, and have it switch to a blank screen. I know that someone will try it someday and won't know what to do.
 
Old 01-08-2004, 06:53 PM   #4
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
Let he/she admire the uncommensurable beauty of the smooth dark color on that screen... *he will probably panic and start pressing alt+ctrl+Fx until it will go back to screen 7, I suppose. Or *he will try to hack the system, but since *he's writing on a pipe to /dev/null, that would be difficult!

One interesting thing is tha if you have it installed (and that's quite easy), running "gdmflexiserver" from a shell box will open other graphic login shells (on screen 8-12) so many people can be logged at the same time. Enjoy it!
 
Old 12-13-2004, 12:48 PM   #5
tosalstefedo
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
Angry Disable CTRL+ALT+F(1-6)

We are currently using SuSE Linux SE 8, and running XF86 version 4.0.2. And we are not able to disable the CTRL+ALT+F(1-6) keys. We do not want to allow our users to be able to get to any other Desktop sessions. Is there a way to disable this? We already tried to comment out the entries in /etc/inittab, it does not give us a blank screen, we are still able to log in and it messes up the colors once we return using CTRL+ALT+F7.

Thanks in advance!
 
Old 12-20-2004, 10:33 AM   #6
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
To my knowledge, there is no other way to stop desktop switching keys than to hack and rebuild the XF86 source, which I doubt you want to do.
As for the console tty, I'm not sure where it may be started besides inittab; however you can find it out this way:
Code:
grep -n tty1 /etc/*
 
Old 12-23-2004, 11:07 PM   #7
LinuxDave
LQ Newbie
 
Registered: Dec 2004
Posts: 21

Rep: Reputation: 15
Add the option "DontVTSwitch" to the serverflags section of the config file to disable switching with <ctrl>-<alt>-<f1-f12> from X windows.

Note that this may not work with the older XFree86 servers.


LinuxDave
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No alt-ctrl-F7/F8 spotslayer Suse/Novell 3 04-26-2005 07:50 PM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
Switching window focus (like alt+tab in windows) and Ctrl+Alt+F1 X windows problem... DiZASTiX Linux - Software 3 01-20-2005 04:56 PM
How to disable Ctrl and Alt keys? (and maybe sysrq) bigperk420 Slackware 13 12-07-2004 05:53 PM
Disable CTRL-ALT-DEL dog606 Red Hat 2 04-19-2004 01:25 PM


All times are GMT -5. The time now is 07:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration