LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices


Reply
  Search this Thread
Old 10-12-2010, 02:16 AM   #16
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297

Quote:
Originally Posted by mjl1297 View Post
Yes we do have a backup.
Hello,

That's always good news So check your / for any 'big' files that are unneeded and delete them to free up space. After that you should check if you can boot normally without errors and login correctly. If any errors are shown, please post them and we'll take it from there.

Kind regards,

Eric
 
Old 10-12-2010, 02:35 AM   #17
mjl1297
LQ Newbie
 
Registered: Dec 2001
Posts: 23

Original Poster
Rep: Reputation: 0
In order to check the / I will need to enter a change directory command correct? Then it will list the files in that directory right?

I'm thinking cd /

then enter ls -l to display files and detailed information.

Last edited by mjl1297; 10-12-2010 at 02:37 AM.
 
Old 10-12-2010, 03:05 AM   #18
mjl1297
LQ Newbie
 
Registered: Dec 2001
Posts: 23

Original Poster
Rep: Reputation: 0
When I type in pwd it tellls me I'm at /var already. Isn't that where I need to be? How do I list the files at this level?
 
Old 10-12-2010, 03:15 AM   #19
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297
Quote:
Originally Posted by mjl1297 View Post
In order to check the / I will need to enter a change directory command correct? Then it will list the files in that directory right?

I'm thinking cd /

then enter ls -l to display files and detailed information.
Hi,

You're correct, with
Code:
cd /
you will be in the / directory. You can check with
Code:
pwd
If pwd shows you that you're in /var then you need to change to / since /var is on another disk then the one you have problems with.

Kind regards,

Eric

EDIT: I've added a quicksheet for AIX for your convenience. Hope it comes in handy.
Attached Files
File Type: pdf aix-quicksheet.pdf (61.6 KB, 33 views)

Last edited by EricTRA; 10-12-2010 at 03:21 AM.
 
Old 10-12-2010, 03:23 AM   #20
mjl1297
LQ Newbie
 
Registered: Dec 2001
Posts: 23

Original Poster
Rep: Reputation: 0
All right I have the files displaying at the / level. Took me a moment there.

I do see about three files that seem a bit large based on what they are but I'm not sure if they are the guilty parties or not.

I have a

inst.log at 19343

inst_brisque_sys.log at 61178

smit.log at 80738


Those last two in particular seem uncommonly portly for log files.

OOPS! missed your post above there. Thanks for the AIX sheet.
 
Old 10-12-2010, 03:27 AM   #21
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297
Quote:
Originally Posted by mjl1297 View Post
All right I have the files displaying at the / level. Took me a moment there.

I do see about three files that seem a bit large based on what they are but I'm not sure if they are the guilty parties or not.

I have a

inst.log at 19343

inst_brisque_sys.log at 61178

smit.log at 80738


Those last two in particular seem uncommonly portly for log files.

OOPS! missed your post above there. Thanks for the AIX sheet.
Hi,

Those are log files so you should be safe setting them to zero, don't delete them though. Normally if everything is set up correctly they would be recreated but since you didn't install nor configure the system it's better to just delete the contents like this:
Code:
echo "" > /inst.log
and repeat that for the other logs as well.

Kind regards,

Eric
 
Old 10-12-2010, 03:56 AM   #22
mjl1297
LQ Newbie
 
Registered: Dec 2001
Posts: 23

Original Poster
Rep: Reputation: 0
Ok I will give that a go here in a few minutes. The echo command will reset them to zero correct?

I don't know if I will be back this morning to update the thread. I've been doing a fair bit of multitasking while troubleshooting this problem (hence the occasional lag in posting a response) and I've just had another job come up that will probably keep me occupied the rest of my shift. I'll update this thread tomorrow and hopefully I'll see you then with good news!!

Thanks again for your assistance.
 
Old 10-12-2010, 04:00 AM   #23
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297
Quote:
Originally Posted by mjl1297 View Post
Ok I will give that a go here in a few minutes. The echo command will reset them to zero correct?

I don't know if I will be back this morning to update the thread. I've been doing a fair bit of multitasking while troubleshooting this problem (hence the occasional lag in posting a response) and I've just had another job come up that will probably keep me occupied the rest of my shift. I'll update this thread tomorrow and hopefully I'll see you then with good news!!

Thanks again for your assistance.
Hello,

The echo command will delete the contents of the file(s) hence reducing the size. Good luck with your multitasking I'm changing jobs this week, doing two jobs so I know what you're going through.

You're welcome, that's what LinuxQuestions is all about, helping out each other.

Kind regards,

Eric
 
Old 10-14-2010, 11:53 AM   #24
crabboy
Senior Member
 
Registered: Feb 2001
Location: Atlanta, GA
Distribution: Slackware
Posts: 1,821

Rep: Reputation: 121Reputation: 121
The easy way out is to allocate more space to your / partition if you have the space. You can check for available space in the volume group (vg) with a few commands.

lsfs /dev/hd4
Code:
$ lsfs /dev/hd4
Name            Nodename   Mount Pt               VFS   Size    Options    Auto Accounting
/dev/hd4        --         /                      jfs2  524288  --         yes  no
List details of the logical volume (lv)

lslv hd4
Code:
$ lslv hd4
LOGICAL VOLUME:     hd4                    VOLUME GROUP:   rootvg
LV IDENTIFIER:      00c29b8000004c00000001153d3d6581.4 PERMISSION:     read/write
VG STATE:           active/complete        LV STATE:       opened/syncd
TYPE:               jfs2                   WRITE VERIFY:   off
MAX LPs:            512                    PP SIZE:        256 megabyte(s)
COPIES:             2                      SCHED POLICY:   parallel
LPs:                1                      PPs:            2
STALE PPs:          0                      BB POLICY:      relocatable
INTER-POLICY:       minimum                RELOCATABLE:    yes
INTRA-POLICY:       center                 UPPER BOUND:    32
MOUNT POINT:        /                      LABEL:          /
MIRROR WRITE CONSISTENCY: on/ACTIVE
EACH LP COPY ON A SEPARATE PV ?: yes
Serialize IO ?:     NO
In my case the volume group is called rootvg, you will have to get the name of your vg from your output.

lsvg rootvg
Code:
$ lsvg rootvg
VOLUME GROUP:       rootvg                   VG IDENTIFIER:  00c29b8000004c00000001153d3d6581
VG STATE:           active                   PP SIZE:        256 megabyte(s)
VG PERMISSION:      read/write               TOTAL PPs:      1092 (279552 megabytes)
MAX LVs:            256                      FREE PPs:       490 (125440 megabytes)
LVs:                15                       USED PPs:       602 (154112 megabytes)
OPEN LVs:           14                       QUORUM:         1
TOTAL PVs:          2                        VG DESCRIPTORS: 3
STALE PVs:          0                        STALE PPs:      0
ACTIVE PVs:         2                        AUTO ON:        yes
MAX PPs per VG:     32512
MAX PPs per PV:     1016                     MAX PVs:        32
LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
HOT SPARE:          no                       BB POLICY:      relocatable
In my case, I have 490 free PPs which is about 125 gigs, you should see similar output and if you have free space, it can be allocated to the lv.
 
Old 10-18-2010, 03:47 AM   #25
mjl1297
LQ Newbie
 
Registered: Dec 2001
Posts: 23

Original Poster
Rep: Reputation: 0
Eric just wanted you to know that everything is running fine this side of the pond. Thanks again!

crabboy thanks for the information in your post as well. I will definitely file that away and may implement those changes during the next maintenance interval.

Cheers!
 
Old 10-18-2010, 02:08 PM   #26
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297
Hello,

Glad you got this issue solved. Please mark the thread as such using the Thread Tools.

Kind regards,

Eric
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Port issues in AIX mail2mphani AIX 3 07-29-2010 06:27 AM
AIX Filter issues meera AIX 2 04-10-2009 06:16 AM
LXer: Java on AIX: Data Collection For AIX Core Dumps LXer Syndicated Linux News 0 05-17-2007 06:46 PM
auto login for serial tty terminal on AIX 4.3.3.0 msilvers AIX 0 01-13-2006 11:42 AM
AIX login problem after first installation vinay88819 AIX 2 05-10-2005 03:12 PM

LinuxQuestions.org > Forums > Other *NIX Forums > AIX

All times are GMT -5. The time now is 06:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration