LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 07-06-2008, 07:04 AM   #1
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Rep: Reputation: 31
.xinitrc and fluxbox/startup don't work?


Hello,
I'm trying to execute some commands at X starting time - like 'xset b off', 'xset m 4' and so on. I thought that putting them in ~/.xinitrc would do the job, but it doesn't.
This is my .xinitrc, and I start X with 'startx':
Code:
rexima vol 100
rexima pcm 100
xset b off
xset m 4
exec startfluxbox
Then I went to a fluxbox-specific solution - ~/.fluxbox/startup:
Code:
/usr/local/bin/fbsetroot -solid black
xset -b
xset m 4
rexima vol 100
rexima pcm 100
exec /usr/local/bin/fluxbox
But the situation is the same.
Any ideas?
 
Old 07-06-2008, 08:14 AM   #2
antegallya
Member
 
Registered: Jun 2008
Location: Belgium
Distribution: Debian
Posts: 109

Rep: Reputation: 42
Hi,
how do you start X, is it started by your display manager (like xdm or so) or do you use the startx command or other ?
In all cases, are you sure that your fluxbox starting scripts are executing your ~/.xinitrc or your ~/.xsession files ?
Try to add on the first line of your ~/.fluxbox/startup something like :
Code:
echo "Startup file executed" > ~/STARTUP
Restart X and see if the file is created.

Regards,
ante
 
Old 07-06-2008, 09:29 AM   #3
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
I already wrote that I use 'startx' to start X.
I've done a little debug and it appears that both scripts are being run. Mistery.
 
Old 07-06-2008, 10:51 AM   #4
antegallya
Member
 
Registered: Jun 2008
Location: Belgium
Distribution: Debian
Posts: 109

Rep: Reputation: 42
oops sorry for the 'startx' i've didn't see it.

That some commands like 'echo' work (and presuming that fluxbox starts) and that others don't, sounds really strange to me. Maybe that your commands don't work for any reason ?
 
Old 07-06-2008, 02:28 PM   #5
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by ivanatora
This is my .xinitrc, and I start X with 'startx':
Code:
rexima vol 100
rexima pcm 100
xset b off
xset m 4
exec startfluxbox
You need to be using:
Code:
rexima vol 100 &
rexima pcm 100 &
xset b off &
xset m 4 &
exec startfluxbox
But there may be better ways to accomplish these goals anyway.

I'm not familiar with rexima, but if all you're after is setting the sound to your liking, read 7.2.4 Setting Default Values for Mixer Channels.

To turn off the bell, use:
# echo 'hw.syscons.bell=0' >> /etc/sysctl.conf

Upon reboot, the bell will be off. (Or you can use sysctl to set the MIB afterwards to avoid a reboot.)

Quote:
Then I went to a fluxbox-specific solution - ~/.fluxbox/startup:
Code:
/usr/local/bin/fbsetroot -solid black
...
That should not be necessary with fluxbox. Once you've set the background within a fluxbox session, IIRC, it should default to ~/.fluxbox/lastwallpaper.
 
Old 07-06-2008, 02:31 PM   #6
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
Also, why are you cranking vol and pcm up to 100 each? Let's see the results of the following command:
% mixer
 
Old 07-06-2008, 04:12 PM   #7
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
Here is the mixer:
Code:
[ivanatora] ~> mixer 
Mixer vol      is currently set to 100:100
Mixer pcm      is currently set to 100:100
Mixer line     is currently set to 100:100
Mixer mic      is currently set to 100:100
Mixer cd       is currently set to  99:99
Mixer rec      is currently set to 100:100
Recording source: mic
About why I'm cranking with vol and pcm... don't know - that's how I'm used to from linux
You are right about sending the processes in background with '&' but I think these are completed within a part of a second so it is not so critical to background these.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox startup programs on DSL 3.0 (.xinitrc file) broknindarkagain Linux - Newbie 1 07-02-2006 08:01 PM
fluxbox and .xinitrc littlemidget Linux - Software 18 01-02-2005 05:40 PM
.xinitrc, fluxbox, startup programs jdier Linux - Newbie 4 08-26-2004 03:41 PM
.xinitrc fluxbox question Abe_the_Man Linux - General 13 06-28-2004 08:25 AM
.xinitrc/.xsession - Where are they? Fluxbox the_rydster Slackware 3 03-07-2004 02:45 PM


All times are GMT -5. The time now is 09:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration