LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-06-2004, 06:22 AM   #1
the_rydster
Member
 
Registered: Nov 2003
Location: UK mostly.
Distribution: Slackware 9.1
Posts: 103

Rep: Reputation: 15
.xinitrc/.xsession - Where are they? Fluxbox


Just been tinkering with my fluxbox window manager and been reading the FAQ.

According to the FAQ you need to edit the .xinitrc/.xsession script (depending upon your distro I guess) to get thinks like xclock to startup automatically.

Well I can't find either of these files anywhere on my computer.

I also did:

fluxbox -i

Failed to load groupfile:
BScreen::BScreen: an error occured while querying the X server.
another window manager is already running on display :0.0.
Blackbox::Blackbox: no managable screens found, aborting
Fluxbox: Unknown error.

I did this because I was interested in the fancy transparent menus but could not find the option in the fluxbox-menu. fluxbox -i should say RENDER if the option is available. Not sure why it tells me that blackbox is running.

 
Old 03-06-2004, 06:52 AM   #2
thereof
Member
 
Registered: Jan 2003
Location: Sweden
Distribution: Slackware
Posts: 54

Rep: Reputation: 15
I'm not sure about .xsession but you can make a .xinitrc in your home-directory. Below is the content of my ~/.xinitrc

Code:
# ~/.xinitrc
gkrellm -w &
exec fluxbox
You should have the "&" after all programs you start before fluxbox. This is to make sure that all applications but the window manager runs in the background. Also make sure that you have fluxbox on the last line. That way X will shutdown properly after fluxbox gets terminated.
 
Old 03-06-2004, 08:02 AM   #3
kiedis
LQ Newbie
 
Registered: Feb 2004
Distribution: Slackware 9.1
Posts: 8

Rep: Reputation: 0
@ applications at startup
i prefer using .fluxbox/apps file for starting applications at fluxbox startup
it doesn't work in the stable version of flux, so you can try one of the latest builds

@ render,
try simple recompiling fluxbox
make sure render is enabled
 
Old 03-07-2004, 02:45 PM   #4
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,772

Rep: Reputation: 478Reputation: 478Reputation: 478Reputation: 478Reputation: 478
Are you aware that files and directories prefixed with a period are hidden? In order to see them you have to use ls-a
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
.xinitrc and .xsession ignored Whitman Debian 2 09-18-2005 01:11 PM
.xinitrc vs. .Xdefaults vs .Xsession frankie_DJ Linux - Newbie 4 08-02-2005 06:39 AM
Make KDM run .xinitrc or .xsession asrisk Linux - Newbie 7 08-01-2005 07:20 AM
.Xsession .xinitrc a10392 Linux - Newbie 2 12-10-2004 03:34 PM
No .Xdefaults, .xsession, .xinitrc madchmst82 Linux - Newbie 3 09-23-2003 08:05 PM


All times are GMT -5. The time now is 01:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration